[CHAT] ColorMe (Changed ownership), read first post

Discussion in 'Inactive/Unsupported Plugins' started by Valrix, Feb 27, 2011.

  1. Offline


    Does this work with the 766 version?
  2. Offline


    From what I hear, yes.
  3. Offline


    works on 766, but only on myself, not on other players
    and when i do it on myself it says internal error occured, still works tho
  4. Offline


    Weird. I'll take a look at it in a bit as long as I don't get too busy. I'll be posting an update in a bit anyway since I improved the code a bit.
  5. Offline


    I dont know why and how, but in the errors it comes up with iConomy

    2011-05-17 15:21:38 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'colorme' in plugin ColorMe v2.0
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:85)
        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:278)
        at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:682)
        at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:645)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:639)
        at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
        at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
        at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)
    Caused by: java.lang.NoClassDefFoundError: com/nijiko/coelho/iConomy/iConomy
        at com.sparkedia.valrix.ColorMe.ColorMe$1.onCommand(ColorMe.java:121)
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
        ... 12 more
    Caused by: java.lang.ClassNotFoundException: com.nijiko.coelho.iConomy.iConomy
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
        ... 14 more
  6. Offline


    It looks like you don't have iConomy v5. I'll make sure to state that in the first post.
  7. Offline


    Getting a weird error, exactly like Wolfx7's. I was using this with the latest build of Essentials, and it worked just fine (a few admins were having fun playing with the colors), then after a few restarts, I installed iConomy and iConomyChestShops. Now, every time someone tries to set someone's color, it says on the client that there was "an internal error while trying to perform this command" and comes up with as far as I can tell the exact same thing as Wolfx7 posted.

    I'm using the latest build of iConomy, as I got it literally today. Any help would be appreciated. Thanks.
  8. Offline


    Weird, I got the latest too, but it's working fine. I'll download it again and do a bit of testing.
  9. Offline


    You want to know what other plugins I have? They may be related.
  10. Offline


    Sure, the more info you give me the better.
  11. Offline


    Installed before errors: BorderGuard, ColorMe, EasyTravel, Essentials, EssentialsChat, EssentialsGeoIP, GroupManager, EssentialsSpawn, FalseBookBlock, FalseBookCart, FalseBookChat, FalseBookCore, FalseBookExtra, FalseBookIC, Permissions, Prefixer, Stargate, WorldEdit, WorldGuard, Permissions. (Not sure why, but Permissions shows up in my /plugins list twice, so there it is)

    The commands worked perfectly while these were installed.

    When iConomy, and iConomyChestShop were installed, the commands stopped working.

    Since then I've installed WeatherControl. Those are all of the plugins. All of them have been downloaded within the past 3-5 days or so. Craftbukkit version: 766. Server version: 1.5_02.

    This is all the information I find relevant. If you have any questions in particular, I'll answer them to the best of my knowledge.
  12. Offline


    That's really weird, especially since you had both ColorMe and Prefixer working with Essentials, and it was iConomy that broke it. I wonder if something is going weird with how it handles iConomy or something...but that shouldn't have changed anything, especially since things were going well until after a few restarts what is the iConomy build number?
  13. Offline


    I have 5.0.1

    Updated again literally minutes ago to be sure I have the latest version.
  14. Offline


    Still not working with 5.0.1? I think that's what I tested with and it seemed to work fine. When I get a chance I'll need to have people join my server and see if I can replicate the problem.
  15. Offline


    Well, I found out that I don't need ColorMe, as what I was trying to do can be done with EssentialsChat. But I hope you found out what was wrong. Still using Prefixer, so I'm still supporting your other plugins. Keep up the good work. :)
  16. Offline


    I cant give People Colors, on my Hosting Server:S
  17. Offline


    Nice pluginXD
    It even did work with essentials as you said it wont work:D
  18. Offline


    That doesn't tell me anything about the problem...a simple "it doesn't work" tells me nothing.

    Glad you got it working. Sometimes it does work, sometimes it doesn't. It depends on the person it seems.
  19. Offline


    Hi there,

    Updated from ColorMe 2.0 to ColorMe 2.1

    All users have been returned to default White color and the plugin is no longer working.
    Server message shows ColorMe 2.1 enabled.
    /colorme list - works as expected
    /colorme <color> - doesn't change color, no errors in server, simply nothing happens.

    Permission nodes have not changed, just the ColorMe.jar was updated

    EDIT: when using /colorme <color> - I've noticed it changes the color setting in the /plugins/ColorMe/players.color but still doesn't work.

    Worked fine in previous version, shouldn't have updated really lol :)

    Any suggestions?
  20. Offline


    Odd, I'll have to see what was changed between versions and see if something between the two messed up players actually having the colors shown. Thanks for the added bit of info, I'll work on that today.
  21. Offline


    Thanks for the prompt response!

    I found I had ColorMe 2.0 backed up somewhere, so I rolled back, and still no joy.
    I had actually updated some of my other plugins aswell, so I've gone through them, turning them off one by one and I have identified the problem.

    Previously I was using iChat 2.2.3 with ColorMe which worked fine, I updated this to iChat 2.3.0 which no longer works with ColorMe.


  22. Offline


    Ah, ok. Yeah, other chat plugins like to mess up ColorMe and Prefixer which tends to be really annoying. I wish they would either support the two plugins, or change how they alter player names/prefixes so they wouldn't break my plugins. Thanks for the update.
  23. Offline


    You could have taken the ~5 minutes required to look at the iChat source and see WHY it wasn't working. Your plugin sets the "displayname" of the player, the default message format that players will use is +name, not +displayname.

    So, as a courtesy to your plugin users, here is how to get iChat working with ColorMe:
    In your "message-format" change "+name" to "+displayname" and BAM, it works.

    I would also recommend setting the priority on the playerChat event to lowest, as you want to set the displayname prior to any other chat plugins using it.
    Unscrewed likes this.
  24. Offline


    Ahh, thanks Drakia. Fixing that now. Sorry to be a pain.
    Unscrewed likes this.
  25. Offline


    I'm currently using bColoredChat and ColorMe on my server. May I suggest a few improvements for this plugin? Perhaps a bit of to-do.
    Make chat text Coloreable.
    Make signs text colorable.
    Make command to change wool colors.
    Also implement rainbow effect in chat and name.
    Just a few suggestion, if there were implement i would use this as my main color.
    Also if possible, you could do what iChat does, allows you to config you chat... Then I wouldn't need iChat, or bColor and that would be the most epic thing evar. =D
  26. Offline


    I dont want that at all,
    I've chosen this plugin just because it Doesn't have all that.
    =( It's ColorMe not ColorEverythingYouSee. :(
    Valrix and Drakia like this.
  27. Offline


    ok. have a good one.
    idk why i'm severly depressed today.... :(
  28. Offline


    I'm having the same problem here, I think I'll just develop something simple.
  29. Offline


    Unscrewed? From MasterCraft? :)
  30. Offline


    Yes, hey Lildirt! :)
    Lildirt likes this.

Share This Page