[CHAT] ColorMe (Changed ownership), read first post

Discussion in 'Inactive/Unsupported Plugins' started by Valrix, Feb 27, 2011.

  1. Offline


    Well... that's odd then. Perhaps the problem really is due to permissions... not sure though. Can you please explain to me how to setup the Config file? I am quite confused...
  2. Offline


    After 10min of starting my dedicated server it started working, but without being an OP but having the node it doesnt say: Gave *** the color: ***

    But still, it does work, awesome Plugin!!
  3. Offline


    Glad it's working, but why it doesn't give the message doesn't make sense. In the code I have it see if permissions is enabled, if so then it disregards the OP=true/false in place of users having the correct permissions to run each the allowed commands. If permissions are not found then it will default to OPs only being allowed to use commands unless OP=false, then players are allowed to use /coorme list, /colorme <color>, and /colorme <self> [color] (where <self> is their own name). Only OPs can set another player's color when permissions isn't enabled.

    Here's how I have my permissions config set up as an example:
            default: true
                prefix: ''
                suffix: ''
                build: false
            inheritance: null
            - 'colorme.list'
            default: false
                prefix: ''
                suffix: ''
                build: true
            - Default
            - 'colorme.self'
            - 'colorme.other'
            - 'colorme.remove'
            default: false
                prefix: ''
                suffix: ''
                build: true
            inheritance: null
            - '*'
    Default only has permission to use the /colorme list, and /colorme <self> to remove their name color. No permissions is needed to remove your own color.
    Moderator is allowed to use the rest of the commands that Default doesn't have.
    Admins have all commands

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  4. Ok, got a minor problem. When I type /colorme list it displays the list, but when I type /colorme darkblue eccentricw, it does nothing. Am I doing something wrong?
  5. Offline


    Yes, the order of the arguments are wrong. It goes /colorme <name> <color> instead of /colorme <color> <name>

    That was my fault, I forgot to change the first post to match how the commands work. Sorry about that.
  6. Offline


    Erm my server now ceased working... I have no idea why. Something is wrong and I have absolutely no idea what...
    And Valrix, I'll check my permissions and make sure it's all setup properly. Thanks.
  7. Offline


    It's the other way around in the spoiler of the first post :s

    unless you just edited it x.x
  8. Offline


    Weird, hope you get it all sorted out. No problem, let me know if you need any more help.

    Haha, yeah I just fixed it. I had it messed up because I forgot to change it.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  9. Offline


    Yes I had forgotten to include apostrophes in my permissions file... thanks very much!
    And yeah, I don't know if you would know why, but after attempting to stop then start my server (I run it on a Mac and turn it on/off through a start.command file), it returned no result in Terminal. I double clicked the file to open it in Terminal as usual, but literally nothing happened. I am really confused and I have no idea how to fix this. Is there a spot for this in the forum somewhere?

    Oh, and to correct myself, it isn't that nothing happened... Terminal opened, but there was no result in Terminal. Just a blank, open Terminal window. Very odd...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  10. Offline


    What's in your .command file? I run Mac as well but do thing a bit differently than most since I know my way around a Mac really well.
  11. Offline


    The .command file says the following:

    What do you suggest is the problem?
  12. Offline


    Hmm, well that method of entering the directory looks a bit odd, I'll give you what I use for mine:
    cd "${0%/*}";
    java \
    -server \
    -XX:+UseConcMarkSweepGC \
    -XX:+CMSIncrementalMode \
    -XX:+CMSIncrementalPacing \
    -XX:+AggressiveOpts \
    -XX:+UseFastAccessorMethods \
    -XX:+OptimizeStringConcat \
    -XX:+UseBiasedLocking \
    -Xmn512m \
    -Xms768m \
    -Xmx1g \
    -Xss512k \
    -d64 \
    -jar $bukkit nogui
    What that does is cd into the directory the .command (or in my case it's just called "server" since I used a chmod +x server on it to make it executable) then it looks for any .jar files (make sure you only have one in that directory and that it's your craftbukkit server) then it launches with those config options. You may not want to add all of those unless you know what you're doing. I have it use the bukkit=./*.jar so you can have your server.jar named whatever you want it to be and it'll still launch perfectly fine.
  13. Offline


    Doesn't save if you log out for like 5 min. I always gotta re do the command. It's annoying fix please :(!
  14. Offline


    Ah. Well, I have an sqlite jar in the same directory as my craftbukkit jar file... could that possibly cause a problem? I sure hope not... Also, I'm not very good with codes, so would you mind explaining to me why I should use your code instead of mine or how to edit your code to fit my methods? Thanks a bunch.
  15. Offline


    Oh snap, nice find. I got it fixed. Jar is updated and I'm updating the changelog now.

    The sqlite jar should be in a folder called /lib/ or something similar. It's best to not have anything "extra" that isn't created by craftbukkit inside the base server folder. Depending on the specs of your computer my load options should help speed up the server a bit since it uses better garbage collection methods than the default. If you tell me more about your computer then I can alter mine to better fit your system. Also tell me the name of your server.jar so I can change the script for you.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  16. Offline


    Thank's! Good Plugin :D
  17. Offline


    Alright, fixed my server folder. The name of my server.jar is "craftbukkit1.4.jar" (without the quotation marks of course). I really appreciate your help and I'll let you know if it works.
  18. Offline


    No problem, hope all goes well for you.

    Thanks for the support ^^

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  19. Offline


    Do you need to use permissions to change other peoples' colors? I can change my own name, but not the others on my server.
  20. Offline


    Yes, you either have to be OP or have permissions to change another person's name color otherwise everyone could change each other's color and that would be a mess.
  21. Hey Valrix, I tried a combo of the following:

    /colorme <eccentricw> <Blue>
    /colorme [eccentricw] <blue>
    /colorme [eccentricw] blue
    /colorme eccentric blue

    None of them seemed to work. Should I submit my config file? Thanks for the help.
  22. Offline


    There's no need for the symbols, those are just to tell you what they are without thinking of them literally. To make myself gold I would use /colorme valrix gold OR /colorme gold

    Sure, also tell me which version you're using, what craftbukkit build you're on, if you're OP, etc. The more you tell me, the better. I think I also found a bug, so once I check that out I'll tell you to grab the latest version and test it if you could
  23. Offline


    Valrix I read that some plugins interfere with your colorme. But I cannot figure out which ones.
  24. Offline


    I should have more clearly said I was an OP
    I can only change my name :s
    It's the same for the other OP
  25. Offline


    IT dosnt work HELP
  26. Offline


    Everyone: I just fixed it a little while ago, if you're having issues then download the jar again and it should work perfectly.
  27. Offline


    Hmm, I get what you mean.
    I will take a look at your source and see if I can find something. :)
  28. Offline


  29. Offline


    Alright Valrix, I tried running the start.command but the same problem keeps occurring. Terminal opens, but absolutely nothing happens. I tried just clicking craftbukkit1.4.jar, and the server worked... but I can't save that way and all.

    Also, I re-downloaded your plugin, and it doesn't work still. The commands "/colorme" and "/colorme list" work, but when attempting to change somebody else's color or my own color, it does not work. I have Permissions installed, and the nodes are entered correctly. It is very odd. Do you recommend I download Craftbuild 670? I currently have 617 installed.
  30. Ok, tried something new today. I went /colorme blue. Boom it worked...for me. When I try to give the color to another player, it didn't work. I am an op (founder) and I am running CB 670. Also, when I look at players.color, there is nothing in that file. But my name in game is blue until I leave and rejoin. When I rejoin the color goes away. My intent is to use this plugin as a reward for donations, but that idea wont' work if the color doesn't stay.

    Ok here are the files:

    # ColorMe Color File -1.7

    #Minecraft Properties File
    #Tue Apr 12 16:13:10 CDT 2011

    Thanks for the help!

Share This Page