Can't Plant Flowers in Pots

Discussion in 'Bukkit Help' started by Strazman, Jan 17, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    This is a very specific issue, but it is baffling me. I am a server admin and recently one of my friends discovered he could no longer plant flowers / saplings in pots. I tried it myself and sure enough, I got an error message that read, "You're not allowed to plant that here" I haven't done anything to the server or plugin files in a while and this just started happening a couple days ago.

    Amongst other less critical plugins, I use PEX, Essentials, and WorldGuard. I have never restricted access to building or using specific blocks or items. I have verified that all of my permissions for building are correct. I even OP'ed myself and still couldn't plant a flower in a pot. If it was a Permissions issue, I would think I'd get the "You don't have permission to do that" message, but I very specifically get "You're not allowed to plant that here"

    When I run debug through my console it even says "checking if <my_name> has essentials.protect.ownerinfo - true"

    Any suggestions on this? I can't figure out if this is a plugin issue or a server issue or what. Again, I have made no recent changes to any permissions or anything. This just started randomly happening. And we can plant stuff no problem in the's very specific to not being able to plant in pots.
  2. Offline


    Try to move far away from that area because "You're not allowed to plant that here" tells me theres some sort of zone of someones or something
  3. Offline


    I did try that. I moved about 1000 blocks away just to check zoning or biomes or anything. Currently there is only 1 defined region through WorldGuard / WorldEdit and it is no where near where we have been trying to plant flowers.
  4. Offline


    I believe the issue is with Worldguard. I just installed it and I am having a similar issue in our main spawn area. I don't recall making any adjustments to the config, so maybe it's a default, or needs to be updated to a dev version. I am going to try that this weekend.
  5. Offline


    They changed this in worldguard 5.7:

    Fixed players without region permissions being able to trigger tripwires, use enderchests, use wooden buttons, and put plants in flower pots.
  6. Offline


    Ah so i'm not the only one with the problem ^,^ I was also wondering why it was doing this.
    Happening on my server to.
  7. Offline


    Me too have this problem
  8. Offline


    So indeed this is an issue with WorldGuard. I took the plugin out of my server and I could plant no problem. I have verified and re-downloaded WorldGuard 5.7 and still having no luck. I only have 1 region in the world which is way far away from the places I've been testing this. Even as OP I can't put a flower in a pot. I noticed the Fix says that wooden buttons are working now. They've never not worked for any of us, and I can still use those just fine.

    I apologize in advance for this long post, but just wondering if anyone sees anything wrong with my WorldGuard config file....

        use-scheduler: true
        use-creature-spawn-event: true
            use: false
            dsn: jdbc:mysql://localhost/worldguard
            username: worldguard
            password: worldguard
        enable: true
        invincibility-removes-mobs: false
        high-frequency-flags: false
        wand: 334
        max-claim-volume: 30000
        claim-only-inside-existing-regions: false
            default: 7
    auto-invincible: false
    use-player-move-event: true
        deop-everyone-on-join: false
        block-in-game-op-command: false
    host-keys: {}
    op-permissions: true
        item-durability: true
        remove-infinite-stacks: false
        disable-xp-orb-drops: false
        disable-obsidian-generators: false
        block-potions: []
        block-potions-overly-reliably: false
            enable: true
            radius: 3
            redstone: false
        pumpkin-scuba: false
        disable-health-regain: false
        no-physics-gravel: false
        no-physics-sand: false
        vine-like-rope-ladders: false
        allow-portal-anywhere: false
        disable-water-damage-blocks: []
        block-tnt: false
        block-tnt-block-damage: false
        block-lighter: false
        disable-lava-fire-spread: false
        disable-all-fire-spread: false
        disable-fire-spread-blocks: []
        lava-spread-blocks: []
        block-creeper-explosions: false
        block-creeper-block-damage: false
        block-wither-explosions: false
        block-wither-block-damage: false
        block-wither-skull-explosions: false
        block-wither-skull-block-damage: false
        block-enderdragon-block-damage: false
        block-enderdragon-portal-creation: false
        block-fireball-explosions: false
        block-fireball-block-damage: false
        anti-wolf-dumbness: false
        disable-enderman-griefing: false
        block-painting-destroy: false
        block-item-frame-destroy: false
        block-plugin-spawning: true
        block-above-ground-slimes: false
        block-other-explosions: false
        block-zombie-door-destruction: false
        block-creature-spawn: []
        disable-fall-damage: false
        disable-lava-damage: false
        disable-fire-damage: false
        disable-lightning-damage: false
        disable-drowning-damage: false
        disable-suffocation-damage: false
        disable-contact-damage: false
        teleport-on-suffocation: false
        disable-void-damage: false
        teleport-on-void-falling: false
        disable-explosion-damage: false
        disable-mob-damage: false
        disable-death-messages: false
        enable: false
        disable-off-check: false
        disable-creature-trampling: false
        disable-player-trampling: false
        prevent-lightning-strike-blocks: []
        disable-lightning-strike-fire: false
        disable-thunderstorm: false
        disable-weather: false
        disable-pig-zombification: false
        disable-powered-creepers: false
        always-raining: false
        always-thundering: false
        disable-mushroom-spread: false
        disable-ice-melting: false
        disable-snow-melting: false
        disable-snow-formation: false
        disable-ice-formation: false
        disable-leaf-decay: false
        disable-grass-growth: false
        disable-mycelium-spread: false
        use-as-whitelist: false
                enable: true
                enable: false
                dsn: jdbc:mysql://localhost:3306/minecraft
                user: root
                pass: ''
                table: blacklist_events
                enable: false
                path: worldguard/logs/%Y-%m-%d.log
                open-files: 10
    summary-on-start: true
    Thanks again for everyone's suggestions.
  9. Offline


    Oke found it, it is a bug in worldguard 5.7!

    If you really want it working again i suggest trying one of the latest dev builds from worldguard.
  10. Offline


    Hey! I tried to fix this by myself and I did on my first try!!! when you go to your default world /plugins/WorldGuard/worlds/world/ open the config and remove the {} and write :
      default: block planting : false
    it worked for me so I hope it work for you too ;)
Thread Status:
Not open for further replies.

Share This Page