Can't get a LAN server to work

Discussion in 'Bukkit Help' started by Lolinder, Feb 4, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Computers within my network get a "Communication error" when trying to connect. I haven't yet had an opportunity to test it on a computer outside my network.

    I'm using Tekkit 1.1.4 right now, but this same problem occurred when running Bukkit earlier (I forget which version).

    According to, the port is open, so I've forwarded it correctly, which is well and good. But I can't connect to the server within my network.

    When server-ip= has no value after it, I can access the server using localhost, but not from a different computer in the network. I tried putting my internal IP there, but that just renders localhost unusable, without any access available to other computers.

    When I add the internal IP to the servers list in minecraft from another computer, I get this message:

    This happens even when I'm using a computer that supposedly can't access the server.

    I've looked everywhere for a solution to my problem, but nothing's come up. If anyone here can help me, I'd be much obliged.

    I'm running Windows 7 64bit using jre6. Bukkit build git-Bukkit-1.0.1-R1-b1597jnks. Plugins listed in the plugin folder are ChopTree, CommandBook, RecipeManager, and WorldEdit. Folders outside of the plugins folder that aren't there in normal bukkit are Buildcraft and Redpower. Any other plugins added by tekkit are also presumably there, but the problem is the same whether using Bukkit or Tekkit.

    EDIT: It's occurred to me that Tekkit may be different enough that help isn't possible here. If that's the case, please say so, and I'll switch forums. The problem is the same with both programs, but I'd understand if you didn't want to deal with it.
  2. Offline


    I really hate it when people do this, but... bump?

    Any more information you people need, I can provide easily.
  3. Offline


    Well there could be a possible router configuration problem, go into the settings (start, cmd, type ipconfig, Then type in the default gateway in your browser). Hope I helped?
  4. Offline


    I've made all the changes anyone says are necessary. I appreciate the try, but I can't just go into the settings and look for something wrong when I don't know what it should be.
  5. Offline


    online-mode=false :p
  6. Offline


    If it's on a LAN, like you say, then no port-forwarding is necessary. Just give them the internal IP of your server.

    Check Windows firewall though; that may be blocking you.
  7. Offline


    I know, but I was running out of things to try.

    I think both were disabled when I tried it first, and I know that all the java exes have permission to get through.
Thread Status:
Not open for further replies.

Share This Page