Can't allocate more RAM to java even in 64-bit?

Discussion in 'Bukkit Help' started by creepycreeper, Jun 26, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Hey guys, I recently bought a new pc to host my minecraft server- wait? Did i just say that? I meant work :p

    Jokes aside, I'm running on a 64-bit Windows 7 Home Premium OS, yet i still can't allocate more than 1GB of RAM to the server. I get the usual message saying unable to create virtual machine and all. Now, I got 10GB of good RAM sittin around doin nothing. I have no clue as to what on earth is going on. Is there a specific version of java that I need? Or do I need to play around with the settings? Or...... could it be that my windows ain't legit? I used my friend's disc, fyi.

    Kinda pisses me off, so any ideas would be greatly appreciated.:)
  2. Try upgrading your Java to the latest version.
  3. Offline


    Specifically, grab the 64-bit java installer.
  4. Offline


    I´ve the same problem.
  5. Offline


    Switch to a Linux based OS like Ubuntu and then install Java 1.7 64bit.

    What you're doing wrong is you're running Java 32bit instead of 64bit.
  6. Although Linux is an awesome platform he doesn't need to change to it. All he needs to do is go to Java's website and download the 64bit version for Windows.
  7. Offline


    Yes but if you buy a machine dedicated to minecraft then you'll want Linux to get the most of it.
  8. Offline


    Really? AS far I've seen, Linux is pretty hard to run. IT's not going to be FULLY dedicated to mc, just partially. Thanks for the answers anyway. I'm gonna try that out right now.:p THanks for the quick reply everyone!

    But when I run the thingy and I see it in task manager, it doesn't have the (x32) sign beside it like every 32-bit app has. PLease forgive me, I'm kinda new to this 64-bit OS. ALso, I don't plan to swap OS anytime soon, btw ;)
  9. If you buy a dedicated box just to run Minecraft, you are insanely rich, can have money pl0x? But on a serious note if you're like me and have a dedicated box and run numerous things (including several game servers) then you want an OS with that isn't bloated and is very stable, which most popular linux builds offer. Linux may seem complicated at first but it's very very easy to pick up.

    As for your issue, are you running minecraft through Java located in C:\Program Files (x86)\ or C:\Program Files\
  10. Offline


    You may have both 32-bit and 64-bit java installed, in which case you can just substitute "C:\Program Files\Java\jre6\bin\java.exe" instead of "java" in your batch file to point to the 64-bit install.
  11. Offline


    SCREW ME UP! Sry for that, but I had to do it. I misread the wiki's instruction. They said if I was running 32-bit mode on a 64- bit machine, which I misread as 64-bit machine! Silly me, I'll have to sort it out as soon as I get back home. I was using the (86x) script just so you know.

    And I don't think I'll be running any dedicated game servers anytime soon with a lousy 5mb up and down line. And that's already faster than 95% of my country! I guess I'll have to wait till they upgrade to IPV6.

    Ok, I'll try that out tonite, but my best bet would be Gishank's solution. Thnx anyway :p

    GAHHHHHH, another stupid problem. Well, now it's churning out messages saying that


    isn't recognized as an internal or external command, operable program or batch file. Funny, I'm runnin the exact same script on the other pc, but it works fine there. Could it be that my OS is screwed? I hope nt.....

    Oh, as a side note, if I tweak the directory a bit, it says windows could not find the specified directory. So.. I guess that makes it even more confusing? Pls help and if this is considered bumping, sry

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  12. Offline


    Try C:\Program Files or C:\Program Files (x86) instead of %ProgramFiles%
  13. Offline


    I just tried that, but to no avail. Still gives the same message,

    "C:\Program Files\Java\jre6\bin\java.exe" -Xincgc -Xmx1G -jar craftbukkit-0.0.1-SNAPSHOT.jar

    That right?
  14. Offline


    Yes and then try the other one with (x86).
  15. Offline


    ohhhhk? I'll try that, but what difference does the directory make? Jus askin.
  16. Offline


    32-bit and 64-bit.
  17. Offline


    Ok, but I still can't start it. Instead of saying unrecognized command, this time it says it cannot find the directory specified. And as a matter of fact, I went to the directory it showed, and found no java.exe. Is there supposed to be one?

    SWEET! AFter a reinstall of Java, it now works. Thanks a lot for the help you've given. And nice tutorial on how to reduce lag btw, that helped me out a lot too. THnx :p

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
Thread Status:
Not open for further replies.

Share This Page