Bukkit crash and Server Error

Discussion in 'Bukkit Help' started by Recolance, Aug 4, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    This is causing my bukkit to crash. And create a crash report

    2012-08-04 20:57:54 [SEVERE] java.util.ConcurrentModificationException
    2012-08-04 20:57:54 [SEVERE]    at java.util.AbstractList$Itr.checkForComodification(Unknown Source)
    2012-08-04 20:57:54 [SEVERE]    at java.util.AbstractList$Itr.next(Unknown Source)
    2012-08-04 20:57:54 [SEVERE]    at net.minecraft.server.PlayerManager.flush(PlayerManager.java:36)
    2012-08-04 20:57:54 [SEVERE]    at net.minecraft.server.WorldServer.doTick(WorldServer.java:172)
    2012-08-04 20:57:54 [SEVERE]    at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:560)
    2012-08-04 20:57:54 [SEVERE]    at net.minecraft.server.DedicatedServer.q(DedicatedServer.java:212)
    2012-08-04 20:57:54 [SEVERE]    at net.minecraft.server.MinecraftServer.p(MinecraftServer.java:476)
    2012-08-04 20:57:54 [SEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:408)
    2012-08-04 20:57:54 [SEVERE]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:539)
    2012-08-04 20:57:54 [SEVERE] Encountered an unexpected exception ConcurrentModificationException
        at java.util.AbstractList$Itr.checkForComodification(Unknown Source)
        at java.util.AbstractList$Itr.next(Unknown Source)
        at net.minecraft.server.PlayerManager.flush(PlayerManager.java:36)
        at net.minecraft.server.WorldServer.doTick(WorldServer.java:172)
        at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:560)
        at net.minecraft.server.DedicatedServer.q(DedicatedServer.java:212)
        at net.minecraft.server.MinecraftServer.p(MinecraftServer.java:476)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:408)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:539)
  2. Offline


    I've been getting this frequently too.
  3. Offline


    What craftbukkit builds are you guys using?

    Also see if you can reproduce the error with out any plugins. It could be a outdated/poorly developed plugin.
  4. Offline


    Yup, today I get:

    at java.util.ArrayList$Itr.checkForComodification(Unknown Source)
    at java.util.ArrayList$Itr.next(Unknown Source)
    at net.minecraft.server.World.tickEntities(World.java:1143)
    at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:565)
    at net.minecraft.server.DedicatedServer.q(DedicatedServer.java:212)
    at net.minecraft.server.MinecraftServer.p(MinecraftServer.java:474)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:406)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:539)
  5. Offline


    I have no plugins, and it is on R1.0 all the way to the newest dev build.

    I also get this bug (but rarely, maybe once a day or two)
        at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:819)
        at java.util.ArrayList$Itr.next(ArrayList.java:791)
        at net.minecraft.server.World.tickEntities(World.java:1144)
        at net.minecraft.server.MinecraftServer.q(MinecraftServer.java:565)
        at net.minecraft.server.DedicatedServer.q(DedicatedServer.java:212)
        at net.minecraft.server.MinecraftServer.p(MinecraftServer.java:474)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:406)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:539)
  6. Offline


    This is new:

    Please, guys do something becouse I can't stay and restart the server at any time. :(
  7. Offline


    exactly. I keep on getting this every once in a while!
  8. Offline


    Try updating to Java7 (if you haven't already)
  9. Offline


    I'm with Java 7.

    More infomation:
  10. Offline


    It happens on Java 5 - 7 this bug is not Java dependent. This is a REAL bug so everyone needs to stop suggesting user end fixes because this bug is no caused by anything the user does, or has.

    Sorry if I sound rude by I spent 4 hours rummaging through the actual code from the Bukkit GIT and found that the issue is an Array List being accessed by an Iterator's "next" when casting to a TileEntity, therefor Java has multiple threads accessing this same list. Also, I tried Synchronizing the list and this did nolt help, and because the code is obfuscated and Notch code, it might be best to report this bug to Mojang seeing as how it's not Bukkit's fault, but they might be able to fix it being that they know more about the obfuscated code than I do being that I develop plugins and Android apps, not Minecraft Servers.

    Thank-you. :)
  11. Offline


    Same error as you Bjornke, been looking for hours on how to fix. No plugins and it happens maybe once a day. Glad to know it's not cause of me.
  12. Offline


    Bjornke I'm running Java7 on my Ubuntu box with Multicraft and I had these errors up until I updated WorldGuard, now they're gone and i'm yet to see 1...
  13. Offline


    I get the same problem but I haven't even fully "installed" the craftbukkit server
    (All I have is run.bat and craftbukkit-1.3.1-R1.0.jar
  14. Offline


    That's good for you but I hate WorldGuard and have never used it. I set my server up without any plugins and still got the error. It might be that WorldGuard increased the occurrence of the error but I can say 100% WorldGuard does not cause the error.

    As long as Bukkit still comes up in a command prompt and is still running you're fine. I use the exact same method to start up my server:

    start.bat->server starts with 3Gigs of ram

    The batch file should not effect anything at all in terms of getting this error/crash.
  15. Offline


    Glad to hear you might have found the cause(wont agree or deny with you, I'm no programmer :p), the only thing I think about when trying to help with bug reports, is simply find out what might be causing it. (Mr. Obvious :D)

    So why does mine work when theirs has this error?
    What might be different from their computer/set-up to mine?

    Generally we all run the same craftbukkit.jar (of course there are different builds) and we ususally use one of these OS's, Windows/Mac/Linux.
    We all use Java, usually v6 or v7, either Oracles version or the OpenJDK version.

    The main things that are different however, different users, we all like to use our computers in our own way.
    We all install and use different software.
    We usually have different hardware, custom built or pre-built, which in turn means different drivers.

    So based on that... how can I find out what's causing an issue someone else has, that I don't?
    First off, I try to clone their setup as best I can, see if anything pops up, generally this doesn't turn up anything though.
    Simply offer suggestions, wrong or right, trying to narrow down the differences between the machines, the more info I can find out about their set-up the better.

    Simply rinse and repeat until it something, or even nothing appears...

    That's pretty much how I work.

    Sometimes my answers may be simple and rather insulting to some but I can only work from the information given to me and can only ask what I need to know.
    (No one had actually mentioned what version of java they used, no full start-up logs, no start-up scripts, no plugins lists, etc. just an error.)

    Sometimes I miss a sentence and cause some grief from my answer/question (I won't deny I don't. :p)

    So... the only thing I am still wondering about is the wonderful... "Well it works for me".
    So my question... (after the long winded and largely pointless post), I know this will annoy you :p
    You said you found the error and I'm assuming this error will be in my build of craftbukkit too, so why don't I actually get this error?

    You don't have to answer that, if you feel you've found it then by all means report it, I wont get in the way.
    I just hate not knowing why a few people are getting an error that I don't get...
  16. Offline


    Xmillsa, we are not only members with this error.
    You can to see how many members has that problem in bukkit.atlassian.net

    I'm tired of waiting a fix staying and restart server all day. I lose players because this is very annoying. They lose items and etc. I saw there are complaints from this bug week ago but still no fix.

    So, the fact that this bug doesn't persist to you , dosen't mean there is no bug.

    BTW: I found https://github.com/johnoliverdriscoll/CraftBukkit/commit/83e5e967cb08dd99c97d81a0efc4ac40df7925e7 which confirms the fact there is a bug.

    Lol, nice a?


    One error in every file:

    So, anyone to know a fix?

    My plugns:
    AntiMining.jar, AuthMe.jar, ChestShop.jar, clearlag.jar, Essentials.jar, EssentialsChat.jar, EssentialsSpawn.jar, iConomy.jar, Lockette.jar, LogBlock.jar, LogBlockQuestioner.jar, MinecraftRKitPlugin.jar, Modifyworld.jar, Multiverse-Core.jar, NoCheatPlus.jar, NoSpawners.jar, Orebfuscator.jar, EPDisabler.jar, PermissionsEx.jar, RandomTeleport.jar, RegexFilter.jar, Residence.jar, ResProtect.jar, sandgeneratorfix-0.1.jar, SimpleReserve.jar, SpamExclude.jar, VanishNoPacket.jar, Vault.jar, Websend.jar, WorldBorder.jar, WorldEdit.jar, WorldGuard.jar

    All plugins are up to date and there are no errors.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  17. Offline


    Good news, guys. :)

    I have fixed the crash bug. I don't know how exactly. I just updated WorldGuard and WorldEdit to their last dev version. Also updated bukkit to the last dev version - #2336 (I don't know if Bukkit team are fixed it).

    Also I have removed RandomTeleport because I saw errors in my console log.
    Btw, is there any way this plugin caused this crash error?

    However, today I haven't errors. :) You guys just have to work about this lag spikes. :)
  18. Offline


    They have to use an Iterator<Entity>, in which they can call the remove() method. Way better.
  19. Offline


    My top 5 list of Bukkit 1.3 issue which they have yet to fix, save the best for last??

    1. Auto World saving issue, every 40+- seconds
    2. Auto World saving issue, every 10+- seconds randomly
    3. Ram leeks, 16 gigs of ram drops like a mother fucker on my Dedicated server.
    4. TPS fucking lag drops, TPS drops from 20 -> 6, lag spike fucks me, then it jumps back to 35TPS/20,
    so thats about -25% lag...Seriously Bukkit?
    5. And finaly, the worst issue of them all, in all of my support tickets they blame this shit on my plugins :)
  20. Offline


    Plugins that handle World Entities will cause this bug t creep out of the wood work faster because they make many calls to the bukkit API to retrieve a list of Entities. Although some plugin developer might have found a work around, the bug is still very present and if you run around your map spawning animals or mobs with eggs you WILL get this bug and error once more. (That's how I confirmed it was not plugin related bug :) )

    I can get this bug without any plugins and with plugins. I have noticed certain plugins do cause this bug to come out of the wood work because of how they handle entities. However this is still a very real bug, even for users without plugins. I've had this crash happen to me twice on a server running NO plugins.
  21. Offline


    Ok, then why bukkit doesn't do anything about that? :S
  22. Offline


  23. Offline


    As been said earlier in this thread, its either a plugin problem, or your using an old build of CraftBukkit. Update your plugins and CraftBukkit.
  24. Offline


    Running the 1.3.2-Ro.1 beta build, and all plugins up to date.
    My full list pf plugins is:

    TnT but several people say it is not due to plugins as this happens without plugins as well:
    If it were a plugin that was causing this, then what type of plugins would I be looking for?
  25. Offline


    I'm not a Bukkit dev, I'm a BukkitDev :p

    I have had this a few times and to be honest I also doubt that it's caused by a plugin. It seems to be very rare and only happens when a player changes world.

    EDIT: In addition instead of just "it's plugins" can we decide what the plugins are doing and say "it's plugins that do X"
  26. Offline


    Try running with a new world
  27. Offline


    I have ran my server for days and not seen that error. Fairly certain it is plugin related, or an old bug that has already been fixed.

    Using multiverse to constantly change worlds I have not seen this myself. Are you using a different plugin for changing worlds, or using basic minecraft multiworld management?
  28. Offline


    I'm using Multiverse too. The world changing is done by Multiverse-Portals but I think that just calls .teleport() right ? So that should be okay. I may be seeing a pattern that is not actually there with the world thing.

    Attached are the three crash reports from the times it has happened recently anyway, maybe someone can see something I can't.

    EDIT: Fine direct links it is !


    Attached Files:

  29. Offline


    We are running the 1.3.2-R0.1 Beta build.
    I still don't see how this would purely be caused by a plugin when Bjornke above says he "successfully" managed to get this crash to happen without any plugins at all.
    On the other hand I do understand that some sort of plugins may trigger this crash to happen more often, but uninstalling all plugins would'nt then really be the solution to it? Also that having over 150+ players on most time of the day increases the chance of this to happen.

    I'll attach my most recent crash:

    I wonder if its really Multiverse, we all 3 use it but the other users above seems to have gotten it without it.. Very strange. :/
  30. Offline


    You have plugins running async threads outside of the scheduler. That is what has caused Jacek's crashes, and yours as well.

    I would like to see the crash reports and server.log for that person who said those crashes occurred without plugins. Until then, the crash reports listed are caused by plugins, no doubt about it.
Thread Status:
Not open for further replies.

Share This Page