Blocks respawning bug?

Discussion in 'Bukkit Help' started by joopie, Feb 23, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    Same here, even when running no plugins. Looks like a bukkit and / or MC server issue. Running 432
  3. Offline


    The server i play on is having this problem too
  4. Offline


    I have this problem (same build) after I warp between worlds
  5. Offline


    I have this too after teleporting.

    Using teleport with Essentials or EekRunes, both have same strange behavior. Relog can solve this problem.

    I guess it is a problem with the new chunk reloading.
  6. Offline


    Relog doesn't help me. Only a server restart does.
  7. Offline


    Ill check it again. Using 432 right now, was 424 before. Relogging helped me to solve the problem
  8. Offline


    Restarting is the only way to do it. Reload, relog, and forced saves don't do it.

    I was also seeing that in minecart mania, blocks wouldn't function until the server restarted...
  9. Offline


    Yup, I was having this problem too, on 433. Just updated to 435, gonna play around for a while and see if it's still happening.
  10. Offline


    I am having this problem as well - on 432
  11. Offline


    Interesting update, i also find it impossible to trigger pressure plates when i encounter this block-respawning bug.

    Can anyone else confirm?
  12. Offline


    Well, I'm still having this issue on 435.. =/
  13. Offline


  14. Offline

    Dinnerbone Bukkit Team Member

    It's a bloody annoying bug. The patch of indestructible blocks moves every time the server restarts, so if we think we've fixed it and go to test it, we don't know if it's fixed or not because we don't know where the indestructible blocks are :D
  15. Offline


    Same problem.
    This server is running Craftbukkit version git-Bukkit-0.0.0-400-g28bec2a-b314 (MC: 1.2_01)
  16. Offline


    The problem everyone is reporting is affecting only the newer builds of CB - 420+. Your build is 314. You have a different issue, probably either plugin or server lag related.
  17. Offline


    Wait, you say 420+? Which builds support MC 1.3? Maybe we could downgrade first...

    EDIT: Nevermind >: Tried downgrading to 419 (first build to support 1.3) Problem still came up...
  18. Offline


    Our server is pretty consistent in having the problems near active players (or so it seems, given that you can't tell the extent of the problem if you don't test the blocks), but perhaps you can try forcing it to appear by using minecart Mania (core, signs, and chests) and worldedit. I've gotten the bug to appear pretty consistently as I've worked on making a station. The bug seems to remove all special functionality of the blocks (eg, obsidian won't catch/launch, gold won't accelerate, chests won't capture/dispense carts) until the server restarts.

    This is naturally more based on intuition via the fallacy of correlation (w/o evidence of causation), but it seems like a good way to look into the problem.
  19. Offline


    Respawning blocks happened to us on Notch's new vanilla server...

    Just sayin...
  20. Offline


    I have this problem also with minecraft_server.jar
  21. Offline


    Mkay so it sounds like its not Bukkit's fault >w< Which is a relief? I dunno...
  22. Offline


    I'm willing to bet it has something to do with the new anti-cheating code Mojang implemented. Specifically the fix for insta-destroying blocks.
  23. Offline


    There's a related bug that was reported right before the 1.3 update, where some blocks would suddenly start reporting random types (i.e. you break dirt and bukkit thinks it's air, water, grass... you name it). The blocks is showing correctly in-game however, which makes me think the bukkit block object becomes somehow out of sync with the minecraft server block. It also seem to take a little while before this problem happens, perhaps only after a chunk gets unloaded / reloaded.

    Some code was added last night to try and debug / fix this and now when the problem happens, all blocks become unbreakable but they do report the correct type .
  24. Offline


    Actually it isn't. Because bukkit bugs get fixed pretty fast, Notch takes months even (see the sand generation bug).
  25. Offline


    It seems to work when I'm using the recommended build, didn't work with the newer builds than that one
  26. Offline


    Block don't respawn if we break them one after one, if u start breaking a second before the first is broke (droped item) is respawn ....
  27. Offline


    I'm getting the same problem, but only with blocks that I have placed (I can break blocks that were part of generated world, but if I build something, I can't destroy it). Relog does not fix this problem (at least not immediately).
  28. Offline


    I'd been looking for the vanilla MC verification... seems I guessed right, not that it matters. Wonder if it's related to the new chunk saving system.
  29. Offline


    It's a relief in the sense that the Bukkit team don't have to worry so hard about fixing it, but it's not because of what you said XD
  30. Offline


    Experienced this after 1.3.

    An area, usually pretty far from spawn, wouldn't allow you to destroy user placed blocks (world blocks could be destroyed, but when replaced were indestructible as they kept on coming back). Friend cannot destroy blocks at his site, as this happens whenever he builds there. I also experienced it several times while miles from spawn, and my first thought was that it was some sort of vague perimeter around the world.
Thread Status:
Not open for further replies.

Share This Page