Solved Banned by "hardcore" mode with no hardcore mode

Discussion in 'Bukkit Help' started by DarkRedman, Nov 13, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Hello, I'm using the last stable release of CraftBukkit.

    One day I switched the server property hardcore to true just to try, and then I switched if off to false.
    But still me and the others players get banned on dying, and even if I reset the file banned-players.txt we still got banned again from my server. But hardcore=false and difficulty=1 so i don't understand I got still banned from my own server. :(

    I need some help, how to fix this ?

    Thanks in advance.
  2. Offline


    One (costly) solution I have is to delete their .dat file. That is the only thing I have found out so far, but if I find another way I will tell you.
  3. Offline


    When you say "their" do you talk about the worlds folder ?
    Is there any documentation that explains how the .dat files are encoded ? Then perhaps I could remove the single data that could fix it without losing the rest.

    I'll try to delete and take a backup just in case.
  4. Offline


    Hello, I've deleted all .dat files sadly but it seems to work, but not totally.
    I don't understand why I've skulls instead of heart but my server is not in hardcore mode when I check my client settings the difficulty is in extreme mode, and the button is grayed I can't change it, I'm not sure this comes from the server or my client. It's the only server where my client is set on hardcore and it's locked.
  5. Offline


    create a new server (or copy the old 1 as backup) remove evey file of all plugins, then u change all config back to what u had, and try it again? maybe this will work?
  6. Offline


    I finally deleted the level.dat file of the world and the difficulty isn't locked anymore, it works very well :)

    In fact I made this world in the solo game with bad settings because I couldn't make a world correctly in the console.
Thread Status:
Not open for further replies.

Share This Page