Anti-Item drop

Discussion in 'Archived: Plugin Requests' started by T04ST3DMinecraft, Dec 3, 2013.

  1. Plugin Category: Mechanics

    Name: Don't drop

    What I want: I was thinking it would be nice to have a plugin that stops people from dropping items on death or out of their inventory in certain worlds. I have already tried plugins such as NoDrop, Don't Drop my Items, and so on but they haven't worked. I did post on the forums but didn't get a response so I deleted it.

    Ideas for commands: /dontdrop #turns off item dropping in that world

    Ideas for permissions: none

    When I'd like it by: 12/10/13

    I'd be much obliged if you could do this or point me to a plugin that actually works.
  2. Offline


  3. Offline


  4. Offline


    Ever tried "/gamerule keepInventory true" ?
  5. I tried that, it didn't work I gave the permissions and de-opped myself and it still didn't work

    but then they can still drop stuff out of their inventory I am going to try exel80 's plugin

    exel80 I tried downloading your plugin to my server, I added the 1.6.4 jar into my plugins folder, restarted and I didn't get the files for it, I'm sure that It's just my mistake
  6. Offline


    WorldGuard, Modify World, Essentials Protect, etc etc there are too many to list....
  7. Offline


    if you read the installation you also have to ensable the plugin in the world your in.
  8. T04ST3DMinecraft - I know for a fact that NoDrop works because I use it on my server.

    Anyway, you can use /gamerule keepInventory true and Skript to make your own script to disable dropping.
  9. Offline


    Select a region, define it and use "/rg flag item-drop deny" without quotes. (It may be something different, I haven't used it in a while.)

  10. Folder + config files are already in the zip file.
  11. mattrick so, I did that and it works, but it doesn't work on death. I turned on /gamerule keepInventory and had commandblocks at spawn that they have to step on but it doesn't get rid of armor, is there a way to do that? in the command block i have it set to /clear @p

    Fixed it! I did /gamerule keepInventory true and then I did /rg flag <worldname> item-drop deny and then had pressure plates set up like I said in my above post and put /clear @p ** in the command block

Share This Page