[ADMN/SEC/WEB] HawkEye [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by oliverw92, Aug 15, 2011.

  1. Offline


    sethgandy, phimt, matan7890 and 7 others like this.
  2. Offline


    I had this problem as well until i updated to bukkit 1.0.1-R1 and hawkeye 1.0.5b
  3. Offline


    I have both of those. and its not workin, i redownloaded the plugin and reset up the config, and still nothin

    Edit: Nevermind, it eventually worked when the server restarted
  4. Offline


    Is it just me or does this plugin *not* restore water damage? I have water flow loging set to true, but still, if I used water to say, destroy a ton of placed torches, crops etc, it can't rollback the torches? i'm not using a player param just radius and time.

    [EDIT] Oh, also I have been using BB in the past, and I can get hawkeye to rollback other changes just fine [/EDIT]
  5. Offline


    which are the differences between "cleanse-period: 20m" and "cleanse-age:" in config file?
  6. Offline


    Period: How often the Cleanser runs
    Age: Records older than this get deleted
  7. Offline


    Alright, I set my HawkEye up on the website, and installed it on my Minecraft server. I get this error when I try to search a user via website, and I am assuming I didn't link the Minecraft plugin config properly to the websites MySql host "Table 'eternalc_HawkEye.hawk_players' doesn't exist"

    The MySql Database is on my website, which is also on a different host. The problem I assume is that I didn't link the plugin config properly from the Minecraft host to the Website Database.

    Plugin Config
    Website Config
    //Enter your MySQL database information
                        //Do not change 'dbTable'
    "dbHost"  => "localhost:3306",
    "dbDbase" => "eternalc_HawkEye",
    "dbUser"  => "eternalc_HEuser",
    "dbPass"  => "urkqsrk?1337",
    "dbTable" => "hawkeyes",
    "dbPlayerTable" => "hawk_players",
    "dbWorldTable" => "hawk_worlds",
    //Set this to the password you want people to have to use to access the interface
                        //Leave blank for no password
    "password" => "asnaeb",
    //Default radius to search for if user supplies a location
    "radius" => 30,
    //Limit the maximum number of results that can be returned. Do not use quotes
                        //Set to 0 for no limit
    "maxResults" => 0,
    //Language pack - default is english.php
                        //You can create your own based off the english.php file,
                        //then change the name below to your language file name
    "langFile" => "english.php",
    //Log queries to log.txt
                        //Useful to keep track of who is querying what
    "logQueries" => true,
    //Use forum for authentication?
                        //Default is false
    "forumAuth" => false,
    //The relative location for the forum to this file.
                        //Default is "../forum/"
    "forumDir" => "../forum/",
    //The type of forum that will be used.
                        //Default is phpbb3
                        //Available types are: phpbb3 and smf
    "forumType" => "phpbb3"
  8. Offline


    Would be nice if this could log and rollback WorldEdit changes.
  9. Offline


    HELP :S

    Everything is okay, but i really want to do, sometimes, some rollback. So.. but, if i type this command:
    /hawk, everything what i see is:
    /hawk help <command>

    And i do not have any command :S

    What can i do? :S HELP please.
  10. Offline


    2011-12-21 06:31:00 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:02 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:04 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:06 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:08 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:10 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:12 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:14 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:16 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:18 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:20 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:22 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:24 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:26 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:28 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:30 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:32 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:34 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:36 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:38 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:40 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:42 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:44 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:46 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:48 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:50 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:52 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:54 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:56 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:31:58 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:32:00 [SEVERE] [HawkEye] Exception: java.lang.NullPointerException
    2011-12-21 06:32:01 [INFO] [HawkEye] Version 1.0.5b disabled!
    Why Must it hate me so much </3
  11. Offline


    Server crashes on preview apply or just rollback, wvwn if small area
  12. Offline


    Im not sure whats happening but recently im finding that hawkeye seems to stop working... i'll start my server, it'll work fine for a few hours, then i won't be able to see results. I have to restart my server to see new results...

    I cleared my entire SQL database (dropped the table) and started new. I also tried downgrading to the 1 earlier release of hawkeye then whats current, same results. I also tried the latest dev build of bukkit and the normal RC but same thing.

    Anybody know why this is? I see no errors in the console as to why it would stop logging... just STOPS. I have 16gb of ram, an i7 processor so my speeds are fine.

    I had no issues for months using it, but lately lots of issues...

    If i reload my config it seems to fix logging, but only works for new entries after i reload.... any help would be appreciated.
  13. Offline


    When I do a hawk preview, then hawk apply, it crashes. It never used to do this...
  14. Offline


    Getting error:

    26.12 23:53:22 [Server] INFO [HawkEye] Version 1.0.5b disabled!
    26.12 23:53:22 [Server] SEVERE [HawkEye] Error initiating HawkEye database connection, disabling plugin
    26.12 23:53:22 [Server] SEVERE [HawkEye] Error whilst attempting to get connection: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Access denied for user 'mc_474'@'%' to database 'mc_474'
    26.12 23:53:21 [Server] INFO [HawkEye] No updates available for HawkEye
    26.12 23:53:20 [Server] INFO [HawkEye] Performing update check...
    26.12 23:53:20 [Server] INFO [HawkEye] Using PermissionsEx for user permissions
    26.12 23:53:20 [Server] INFO [HawkEye] Starting HawkEye 1.0.5b initiation process...
    Notice the % sign where the password is supposed to be? I've tried using the password with, and without the apostrophes(' ') around it:

      hawkeye-table: hawkeye
      port: 3306
      player-table: hawk_players
      username: mc_474
      world-table: hawk_worlds
      hostname: minecraftfloridamysql.avantehosting.net
      max-connections: 10
      password: '*********'
      database: mc_474
    Keep getting the same error, or the error that it can't connect at all. :(
  15. Offline


    Getting this error over and over again:

    2011-12-27 19:55:45 [SEVERE] [HawkEye] Exception: com.mysql.jdbc.exceptions.jdbc4.MySQLIntegrityConstraintViolationException: Duplicate entry '326722' for key 'PRIMARY'
    2011-12-27 19:55:47 [SEVERE] [HawkEye] Exception: com.mysql.jdbc.exceptions.jdbc4.MySQLIntegrityConstraintViolationException: Duplicate entry '326722' for key 'PRIMARY'
  16. Offline


    This is a truly brilliant plugin, but would it be possible to exempt people from being logged?
  17. Offline


    hawkeye spams my console after start nonstop with:
    [SEVERE] [HawkEye] Exception: java.lang.NullPointerException

    i dont know why and how to fix it. hawkeye is up to date and doesnt gives any error on startup neither another plugin does.

    problem started when i updated the regios plugin wich on works again but hawkeye makes problems still.
  18. Offline


    I am having problems with the web interface. Everything works fine, except that
    i cannot use the login.php. It will only work if there is no password set. So to be extra clear:
    i can use the web interface
    i cant use a password because it gets stuck at the login screen

    I already tried several things:
    - removing all the files from the web interface, unpacked latest version, made sure all settings are correct
    - tried from different pcs and browsers
    - disabled selinux

    nothing seems to work. I really dont get why the login screen does not send me to the main screen of the web interface.

    Anyone knows what this could be and how this can be solved?
    (im running latest version 1.05b i believe, and latest RB)
  19. Offline


    Does anyone know of a stats plugin that uses hawkeye data? Hawkeye already logs everything, so why install a second plugin that does the same logging but uses the data differently?

    I had the same problem initially, this is what worked for me:
    - "password" => "somepass",
    - "forumauth", false
    - "forumdir", "../",
  20. Offline


    I am using the latest hawkeye and I am trying to rollback some chest transactions. I have done it with just:
    /hawk rollback p:<name>

    and also tried
    /hawk rollback a:container-transaction p:<name>

    Both say "attempting to rollback 4 results. Rollback complete, 0 changes"
  21. Offline


    The plugin is disabling??
  22. Offline


    Yeah im getting same issues, where the plugin works then stops logging... anybody know why that suddenly started happening?
  23. Offline


    After 1h using HawkEye with default conf we have 16.000 Entries in the Database - how long can my server handle that?! Does this Plugin has any kind of log rotation or log deleting?
  24. Offline

    bridge troll

    hi whenever i try to rollback i get a internal error how can i fix it so i can rollback with the plugin without any errors also here is the error i get 11:55:18 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'he' in plugin HawkEye v1.0.5b
    at org.bukkit.command.PluginCommand.execute…
    at org.bukkit.command.SimpleCommandMap.disp…
    at org.bukkit.craftbukkit.CraftServer.dispa…
    at net.minecraft.server.NetServerHandler.ha…
    at net.minecraft.server.NetServerHandler.ch…
    at net.minecraft.server.NetServerHandler.a(…
    at net.minecraft.server.Packet3Chat.a(Packe…
    at net.minecraft.server.NetworkManager.b(Ne…
    at net.minecraft.server.NetServerHandler.a(…
    at net.minecraft.server.NetworkListenThread…
    at net.minecraft.server.MinecraftServer.w(M…
    at net.minecraft.server.MinecraftServer.run…
    at net.minecraft.server.ThreadServerApplica…
    Caused by: java.lang.NullPointerException
    at uk.co.oliwali.HawkEye.Undo.<init>(Undo.j…
    at uk.co.oliwali.HawkEye.commands.UndoComma…
    at uk.co.oliwali.HawkEye.commands.BaseComma…
    at uk.co.oliwali.HawkEye.HawkEye.onCommand(…
    at org.bukkit.command.PluginCommand.execute…
    ... 12 more
    thanks for any answers for my problem :D
  25. Offline


    when using multiverse with custom terrain generators (any bspace, cityworld etc) when i go to the map i get nullpointer exceptions in java.lang - is there a way to fix this ? is it hawkeye or multiverse to blame here?

    should say exeact error is thrown by hawkeye : java.lang nullpointerexception
  26. Offline


    I get an error when i try to add HawkEye.
    08.01 11:54:59 [Server] INFO [HawkEye] Version 1.0.5b disabled!
    08.01 11:54:59 [Server] SEVERE [HawkEye] Error initiating HawkEye database connection, disabling plugin
    08.01 11:54:59 [Server] INFO The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
    08.01 11:54:59 [Server] SEVERE [HawkEye] Error whilst attempting to get connection: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
    08.01 11:54:59 [Server] INFO [HawkEye] No updates available for HawkEye
    08.01 11:54:59 [Server] INFO [HawkEye] Performing update check...
    08.01 11:54:59 [Server] INFO [HawkEye] No permission handler detected, only ops can use commands
    08.01 11:54:59 [Server] INFO [HawkEye] Starting HawkEye 1.0.5b initiation process...
  27. Offline


    As this is one of the best and most useful plugins I have encountered, and because the web interface is so professional i've left a donation - thank you for sharing your plugin!

    I do still think it would be nice to add in a means to exempt certain people from being logged, though! No idea if that's really difficult, but it would be quite helpful!
  28. Offline


    you can exempt people i think already edit: apparently not maybe that was bigbrother

    and scribs have you installed mysql and set up a hawkeye schema?
  29. Offline


    Is there a way i can use it without mysql?
  30. Offline


    It doesn't work for me.... The plugin is red when I do /plugins :(.
  31. Offline


    Hi, I installed Hawkeye and it worked perfectly for 10 seconds and then started displaying these messages:
    HawkeyeError1.png What am I doing wrong!
    Please help, mmob18
    Bukkit: R1
    Operating system: Windows 7 64 bit
    I am running the server off of my computer
    My mysql database is hosted using GoDaddy(it came with my website)
    Server: worflcraft.net
    Server forums: worflcraft.net

Share This Page