[ADMN/SEC/WEB] HawkEye [BukkitDev]

Discussion in 'Archived: Plugin Releases' started by oliverw92, Aug 15, 2011.

  1. Offline


    sethgandy, phimt, matan7890 and 7 others like this.
  2. Offline


    I keep getting the error (on the web) table <my tablename>.hawkeye doesnt exist!
  3. Which doesn't really tell us anything that helps. :) Post your config in code tags and remove the sql account info.
  4. Offline


    I'm just saying that it works perfectly with Bukkit 1136 +
  5. Offline


    Is it just me or does it stop logging after a certain period?
  6. Offline


  7. Offline


    so has anyone else noticed a huge sql db from this plugin. My sql db is so big now that it seazes up the machine while im trying to do a dump for backups. it used to take a couple of seconds now it takes about 5 mins to do the dump and it has about 25,000,000+ (25,492,392 to be exact) rows in the hawkeye table and the sql dump is 1.9GB. I have it set to clean every 7 days and it does but it just seems if you have a server with about 15 - 20 ppl the db get gigantic. I didn't notice this problem in BigBrother. I am running HE ver 1.0.4b on Craftbukkit 1150 but the bukkit build i dont think matters cause i believe it had the same problem in 1060 but its tough to say since when 1.8 came out my server got way more popular but thats b/c its one of the few running a bukkit 1.8.
  8. Offline


  9. Offline


    Seeing this when a chest is rightclicked that has glass over it.

    1.8 (1149)
  10. Offline


    First error is my problem - thanks. Second, not me
  11. Offline


    Seems to be resolved on 1185
  12. Offline


    Weird :confused:

    Hey guys I just realised that the forums were a pile of shite and didn't tell me anyone had been talking in this thread for the last 3 pages...

    If anyone still has the problems they were talking about then ask again with as much info as possible. I don't have time to go through 3 of comments right now if most of them have been solved.

    With this, I bring you a new dev build for 1.8.1. I really need people to help me test this out. REMEMBER - this is a dev build, don't use it live on your server unless you are prepared for any kind of breakage.

    Dev Build 1.0.5
    http://dl.dropbox.com/u/24279633/Bukkit/HawkEye/HawkEye v1.0.5 DEV.zip
    • NEW! Ability to bind your own commands to the tool with /hawk tool bind <parameters>
    • Added endermen logging
    • Added option to stop version checking (not recommended)Added option to control cleanse period as well as age
    • Fixed deprecated damage event
    • New optional forum auth system for web interface (thanks but2002!) - currently supports phpbb3 and SMF
    • 'Fake' JSON functions now included in interface
    • Implemented the concept of sub-commands
    • Apply and Cancel commands now come underneath the preview command (i.e. /hawk preview apply)
    • Implemented better session manager
    • Fixed sessions not persisting
    • Implemented tool manager
    As I said, I really need people to help me with this, I don't have much time to spend testing at the moment.

    @Kainzo @Justin The Cynical @spencerocks @The Wizard

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 18, 2016
  13. Offline


    Is this related to these error messages I see all over my console?

    [SEVERE] Could not pass event ENDERMAN_PLACE to HawkEye
            at uk.co.oliwali.HawkEye.listeners.MonitorEntityListener.onEndermanPlace(MonitorEntityListener.java:129)
            at org.bukkit.plugin.java.JavaPluginLoader$77.execute(JavaPluginLoader.java:782)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:338)
            at net.minecraft.server.EntityEnderman.s(EntityEnderman.java:126)
            at net.minecraft.server.EntityLiving.s_(EntityLiving.java:280)
            at net.minecraft.server.EntityMonster.s_(EntityMonster.java:31)
            at net.minecraft.server.World.entityJoinedWorld(World.java:1193)
            at net.minecraft.server.WorldServer.entityJoinedWorld(WorldServer.java:48)
            at net.minecraft.server.World.playerJoinedWorld(World.java:1175)
            at net.minecraft.server.World.cleanUp(World.java:1090)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:460)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:374)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
  14. Offline


    Yes, fixed in my new dev build I'll be releasing later.
  15. Offline


    Hi oliver, I also have had the issue where hawk seemed to stop loggin after a while. Ive installed your latest dev build, but the issue still seems to be present.

    I cannot give you any error logs, because i dont get any, it just seems to stop loggin new activity, yet still remembers older stuff.

    Is this an issue you are still aware of?

  16. Offline


    Great! I fixed it temporarily by disabling Enderman logging.
  17. Offline


    Great plugin, used to use BigBrother and I found it lagged the server - this one feels like it isn't even doing anything (but it's logging far more in more detail, discreetly ;)).
  18. @oliverw92 - I understand the time thing as well, I just recently got time to start converting my server over to the new bukkit for 1.8.1.

    I've installed the dev version and so far:
    • I get the enderman block place error as Gyn3r does
    • If I hit a painting with the log to see who placed it, the picture is knocked off
    That's all I have so far. I will add more as I find it once I get some more 'real-world' testing done with it.
  19. Offline


  20. Offline


    >13:48:52 [SEVERE] Exception in thread "Timer-3"
    >13:48:52 [SEVERE] java.lang.NullPointerException>13:48:52 [SEVERE] at uk.co.oliwali.HawkEye.database.DataManager.run(DataManager.java:344)
    >13:48:52 [SEVERE] at java.util.TimerThread.mainLoop(Unknown Source)
    >13:48:52 [SEVERE] at java.util.TimerThread.run(Unknown Source)

    This is what happens whenever I go into my second world called "sera". HawkEye works on logging old blocks but then if you place a block and scan it..nothing happens. Any ideas I'm running 1.0.5 build for HawkEye
  21. Offline


    Brilliant PLUGIN!

    I have a request can you add a player KILL count? Thanks!
  22. Offline


    [SEVERE] [HawkEye] Unable to execute cleanse utility: java.sql.SQLException: Incorrect key file for table './Minecraft/hawkeye.MYI'; try to repair it

    I'm getting this. How exactly do I repair it?
  23. Offline


    Try using phpmyadmin and use repair tool
  24. Offline


    Possible to log changes on Noteblocks and Repeaters?
  25. Offline


    Thank you. I already have it running on the server so when I get the chance, I'll do this.
  26. Offline


    Is there currently a working build on b1215+ ?

    Seeing this

    16:29:24 [SEVERE] Error occurred while enabling HawkEye v1.0.5 (Is it up to date?): tried to access method org.bukkit.command.ConsoleCommandSender.<init>(Lorg/bukkit/Server;)V from class uk.co.oliwali.HawkEye.HawkEye
    java.lang.IllegalAccessError: tried to access method org.bukkit.command.ConsoleCommandSender.<init>(Lorg/bukkit/Server;)V from class uk.co.oliwali.HawkEye.HawkEye
    at uk.co.oliwali.HawkEye.HawkEye.onEnable(HawkEye.java:98)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:920)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:280)
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:174)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:157)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)

    Also happens on the dev version I saw earlier in this thread.
  27. Offline


    Getting the same error with a few of my plugins.
  28. Offline


    Love this plugin so far : )
  29. Offline


    Justin The Cynical likes this.
  30. Offline


    Thank you for this fix!

Share This Page