Inactive [ADMN/SEC] Regios v5.0.01 - Advanced Region Management! + Multi-World, Protection + More![1.0.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Adamki11s, May 3, 2011.

  1. Regio's - Advanced Region Management! + Multiworld support, protection, entry control, health control, movement control, custom messages and more!
    Version : 5.0.01

    Changelog :​
    Version 5.0.01 : Fixed NPE's regarding ChunkGrids & Regions​
    Version 5.0.0 : Updated for 1.0.0 and fixed glaring protection issues.​
    Version 4.0.80 : Mobs Fixed and Economy Support for iConomy6 (Thanks to Pianosaurus)​
    Version 4.0.71 : Complete Recode.​
  2. Override needs to be true. There is a section on the wiki if you need clarity.

    There is already the global interaction prevention but this is not available for specific items. I may add this as a feature.
  3. Offline


  4. Read the previous posts.
  5. Offline


    I cant work out how to use the CMD-SET command. i.e. i tried adding /balance into the config file for the region and that didn't work, then i tried the node itself, that didn't work. what am meant to put in?
    In the process of typing this message I realised I had to type the command with out /.
    Awesome Plugin! One of my favourites!
  6. Thanks for your support :).
  7. Offline


    This looks like an amazing plugin! I have a 1.8.1 server though. I eagerly await an update for this plugin. :)
  8. Offline


    love it wait for update... :p
  9. Offline


    Hey, are there some way of expanding a border by bits?
    Like real life country borders and the like.

    Love the pluggin, though. Eagerly waiting for update. ^^
  10. Offline


    so its not working with 1185 ?shame ;( i wanted to upgrade my server to 1.8,but without regios it will be holly war :3
  11. I'm working on updating it.

    Updated for 1.8. Enjoy!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  12. Offline


    now we need to wait for spout to chatch up and make this compatable with craftbukkit servers...
  13. Offline


    I'm having trubles with writing in the Editor GUI...
    Can't seem to write in any column other then at page 4 and 5.

    Edit: Is this a 1.8 thing?
  14. I think it has. There are still a lot of bugs though.

    Not sure, I'll test. Spout is having a lot of bugs caused by 1.8 so it may be something to do with that.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  15. Offline


    hi. Thanks for the update, but i lost all of my regions! Is there any way i can get them back? thanks
  16. How did you loose them? If you made a backup using the backup command or did it manually then yes you can, otherwise the answer is probably not.
  17. Offline


    Is the wiki not updated or something? I just installed Regios and I can't set prices on different flags yet. (Can't find any options for it in the configuration file either) Running CB 1185 and regios v. 4.0.71
  18. Offline


    All of my regions are stored in plugins\regios\regions , but the plugin isn't reading it.
  19. Offline


    just a tip for everyone use spout dev build not spout stable build, it causes reading issues.
  20. Offline


    thanks for the update, but im having a problem with permissons.... if i am an OP, or use true, reloading regios works fine, but if i use*: true, if i try to reload regios, it says i dont have permission. this is only an example, there could be more cases like this. also, does regios.*: true work the same as being an OP? i tried it and the permissions loaded fine, but once again, trying to reload regios said i didnt have permission

    hmm aparently even though the wiki says reload is under data, its not, using the regios help system, it says its under general... just a side note, but the wiki says nothing about general commands
  21. Offline


    Remember the pig problem? Well, enderman or silverfish dont spawn anymore :(
  22. Offline


    Is Spout still requird for this plugin? I have Problems with Spout, so I cant use this =/
  23. Offline


    i dont have spout and it, for the most part, runs fine. im not 100% sure, but i dont think spout was ever actually required, i was using it a couple months ago without spout and i dont think spout was even part of it at that time. spout just adds more features im pretty sure
  24. Spout is optional.

    I need to add options for those and yes I will fix this thanks :).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  25. Offline


    does regios.*: true work the same as being an OP, or at all/is it potentially broken? i tried it and the permissions loaded fine, but trying to reload regios said i didnt have permission
  26. Offline


    Yes, yes, I saw that.... but that's for buying and selling pre-made lots... how about if a user creates a lot himself, I want to be able to charge for the creation. Also, I want to make it so that some of the flags cost money for them to add. (I thought that's what you meant. Sorry.)
  27. Ah yes, I am still working/planning to work on that feature.
  28. Offline


    goddam, apparently im invisible.... ignored twice in a row

    sorry, i know you're probably fairly busy, with life, or this project, or just about anything, but everyone else above and below my questions were answered
  29. Offline


    I tried disabling spout to solve the problem, but every time I start regios, this happens and regios does not work at all
    2011-09-26 13:56:23 [INFO] [Regios] Spout not detected. No Spout support.
    2011-09-26 13:56:23 [INFO] [Regios] Checking directories.
    2011-09-26 13:56:23 [INFO] [Regios] Deleting directory @_root/plugins/Regios/Dependancies
    2011-09-26 13:56:23 [INFO] [Regios] Directory check completed.
    2011-09-26 13:56:23 [INFO] [Regios] Checking configuration files.
    2011-09-26 13:56:23 [INFO] [Regios] Configuration check completed.
    2011-09-26 13:56:23 [INFO] [Regios] Loading configuration files.
    2011-09-26 13:56:23 [INFO] [Regios] Loaded default region configuation file.
    2011-09-26 13:56:23 [INFO] [Regios] No economy preset specified in config.
    2011-09-26 13:56:23 [INFO] [Regios] Loading world configuration for world : world
    2011-09-26 13:56:23 [INFO] [Regios] Configuration files loaded successfully!
    2011-09-26 13:56:23 [INFO] [Regios] Loading [64] Regions.
    2011-09-26 13:56:23 [SEVERE] Error occurred while enabling Regios v4.0.71 (Is it up to date?): null
        at couk.Adamki11s.Regios.Checks.ChunkGrid.<init>(
        at couk.Adamki11s.Regios.Regions.Region.<init>(
        at couk.Adamki11s.Regios.Data.LoaderCore.loadRegions(
        at couk.Adamki11s.Regios.Data.LoaderCore.setup(
        at couk.Adamki11s.Regios.Data.CreationCore.setup(
        at couk.Adamki11s.Regios.Main.Regios.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
  30. Offline


    it looks like its more or less running into a problem with loading your regions, i would try to make a temp backup of your regions database on your desktop or something then delete the regions database in regios to try and make it load nothing, see if it loads properly then... maybe a region somehow got messed up?
  31. Offline


    Ahh... gotcha, good to know. Thanks. :)

Share This Page