Inactive [ADMN/SEC] Regios v5.0.01 - Advanced Region Management! + Multi-World, Protection + More![1.0.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Adamki11s, May 3, 2011.

  1. Regio's - Advanced Region Management! + Multiworld support, protection, entry control, health control, movement control, custom messages and more!
    Version : 5.0.01

    Changelog :​
    Version 5.0.01 : Fixed NPE's regarding ChunkGrids & Regions​
    Version 5.0.0 : Updated for 1.0.0 and fixed glaring protection issues.​
    Version 4.0.80 : Mobs Fixed and Economy Support for iConomy6 (Thanks to Pianosaurus)​
    Version 4.0.71 : Complete Recode.​
  2. Offline


    Thx Adam works now
  3. Offline


    Hey, when I protect my space, everyone is still breaking the blocks. I remexed them. I expanded max. I did everything but people are able to break an area? Any ideas. I have spout installed. Also, the only download i see is the unstable one? are there any older versions that are stable?
  4. Offline


    Hey I downloaded Spout and Regios and it seems everything works fine, I type in "/regios set" it tells me "[Regios] Left and right click to select points" but when I do that (with a golden axe) it does not say or register points. It doesn't say anything in the "terminal" where I run the server and such so I am not sure if something is blocking it or I am missing something. I tried with only Regios and Spout as plugins and it still didn't work. Sorry if I missed an obvious point I just installed ALOT of addons within the past couple hours so I might have skipped a step =P
  5. I only call it unstable because it's unfinished and may still have a few small bugs. To fully protect an area do /regios protect-all <region> The command has changed as you can now independently protect from block place and block break.

    The default selection tool for settings regions is a wooden axe. You can change this in the config if you want.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  6. Offline


    i haven´t a jar-file: spout
  7. Then download one. Sorry but it really is extremely simple!
  8. Offline


    ok but where i can download this?
  9. Offline


  10. Ok
  11. Offline


    *bows down* @Adamki11s i have to worship your patience and admire the effort you have made here.... it is amazing, and thank you to everyone who dont know how to read english... it saves me embarrasing myself with amature questions("dont ask, you wont find out"). Plugin installed tested and loved by my server. It has almost fully replaced my need for the residence plugin.... :) thank you sir. Keep up the epic work. Just a request, im not sure if i have seen it around at all, but is there an updated version of a how to video on regios with sell+buy etc etc? just asking. ;) i might have missed it somewhere but wanted to link it via my website for staff
  12. Offline


    Do I NEED Spout on the server to run Regios?
    Will old regions be gone? :confused:
  13. Yes you do need Spout, it says it clearly in the post. If you don't have it the latest version will automatically be downloaded to the folder plugins > Regios > Dependencies.

    Thank you :D
    To sell regios do /r set-price <region> <price>
    People can the buy this region, the simplest way is put a sign down:
    Line 1 : [Regios]
    Line 2 : regionname
    Then people only have to right click and the region will be theirs. I am nearly finished the recode and when I am I will release full documentation, sorry for the lack of it currently.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  14. Offline


    Currently I have the Dev build for regios and I have the spout server plugin. At first, Everything worked fine, except everybody could build in all regios with the general protection on. Then, after I restarted my server, in the server log it said "Spout plugin found! Spout support enabled!". After I tried to use ANY regios command it says "Regios requires the spout server plugin". I have no idea what I am doing wrong.

    EDIT: I did another restart and now it is says "error in enableing regios, is it up to date?
    Null pointer exception in chunk...<init>..."
  15. Are you sure you have the normal spout server plugin?

    General protection applies to bukkits etc so to brotect block breaking and placement you need to either do :

    /regios protect-bb <region>
    /regios protect-bp <region>


    /regios protect-all <region>
    Which will have the same effect as doing both of the above and General protection also. All will become clear when I release documentation :p
  16. Offline


    Hey, I got everything working with setting and defining regions and all but for some reason certain commands wont work or recognize in-game. Like I can do (set, create, lsps, expandmax, and maybe a couple more) but like for example "/regios setwelcome test welcome to my home" is that correct? Some commands just do not say anything. I can go into the configs and change them and they work but not all work in-game.
    I am an admin and have the '*' so it can't be permissions right?
  17. Sorry its the command page which is outdated as i am recoding so some commands have changed.
    "/regios set-welcome test welcome to my home"
    I'll modify the commands so that it accepts it without the dash also, sorry for the inconvenience.
  18. Offline


    Oh ok, sweet, thanks for the quick response, at least now I know I'm not going crazy haha.

    Amazing plugin btw, can't wait for it to be finished!
    Adamki11s likes this.
  19. Offline


    Oh, thanks. I just did /r protect <region>. I must have missed the -all, -bb, and -bp in the /r help page. Thanks!!! You have solved all of my problems. BTW: I LOVE THE NEW UPDATE!!!
  20. What update would that be? Thanks :D
  21. Offline


    This one of course! I'm using the dev version

    I have found another error. On startup, it says:
    2011-09-11 14:33:06 [INFO] [Regios] Spout detected! Spout support enabled!
    2011-09-11 14:33:06 [INFO] [Regios] Checking directories.
    2011-09-11 14:33:06 [INFO] [Regios] Directory check completed.
    2011-09-11 14:33:06 [INFO] [Regios] Checking configuration files.
    2011-09-11 14:33:06 [INFO] [Regios] Configuration check completed.
    2011-09-11 14:33:06 [INFO] [Regios] Loading configuration files.
    2011-09-11 14:33:06 [INFO] [Regios] Loaded default region configuation file.
    2011-09-11 14:33:06 [INFO] [Regios] No economy preset specified in config.
    2011-09-11 14:33:06 [INFO] [Regios] Loading world configuration for world : MineLand
    2011-09-11 14:33:06 [INFO] [Regios] Loading world configuration for world : MineLand_nether
    2011-09-11 14:33:07 [INFO] [Regios] Configuration files loaded successfully!
    2011-09-11 14:33:07 [INFO] [Regios] Loading [13] Regions.
    2011-09-11 14:33:07 [SEVERE] Error occurred while enabling Regios v4.0.71 (Is it up to date?): null
        at couk.Adamki11s.Regios.Checks.ChunkGrid.<init>(
        at couk.Adamki11s.Regios.Regions.Region.<init>(
        at couk.Adamki11s.Regios.Data.LoaderCore.loadRegions(
        at couk.Adamki11s.Regios.Data.LoaderCore.setup(
        at couk.Adamki11s.Regios.Data.CreationCore.setup(
        at couk.Adamki11s.Regios.Main.Regios.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
    Also, it looks fine on disable though:

    2011-09-11 14:33:13 [INFO] [Regios] Shutting down scheduler task...
    2011-09-11 14:33:13 [INFO] [Regios] Scheduler task stopped successfully!
    2011-09-11 14:33:13 [INFO] [Regios] Regios version 4.0.71 disabled successfully!
    Thanks For the help!

    EDIT: This error only occurs AFTER you RENAME regions
    EDIT #2: In the "database" folder, it has a folder for the region's old name AND the region's new name. If I delete the folder with the NEW name, the error does not show up
    EDIT #3 [last edit]: I went into the <region name>.rz file, changed the name manually, and now I get no more errors at all

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
    Adamki11s likes this.
  22. Ok thanks thanks for the bug report, I will test and fix this :)
  23. Offline


    k, no problem
  24. Offline


    o.o the plugin is destroyed.. :(
    I guess I have to find another plugin then :S
  25. How is this destroyed in any way???
  26. Offline


    Ok, well nvm i just thought that it is VERY good having 100 ppl online with only 2GB .. nice work
  27. Starting on the documentation now! Plugin is almost complete :D

    Messages and hierarchy explanation done. The wiki write-up should probably take a total of 5-6 hours, should be done in a few days along with polishing off the GUI!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
    gameswereus likes this.
  28. Question 1, Can I do anti Pvp in an area other than the spawn area? like I want to protect my town area. And 2 can I get the link to the Spout download.
  29. Go to the wiki : for the spout download. I will be doing pvp explanations soon.
  30. So There is pvp protection, or ur adding it? or its already included but not well explain yet

Share This Page