Inactive [ADMN/SEC] Regios v5.0.01 - Advanced Region Management! + Multi-World, Protection + More![1.0.1-R1]

Discussion in 'Inactive/Unsupported Plugins' started by Adamki11s, May 3, 2011.

  1. Regio's - Advanced Region Management! + Multiworld support, protection, entry control, health control, movement control, custom messages and more!
    Version : 5.0.01

    Changelog :​
    Version 5.0.01 : Fixed NPE's regarding ChunkGrids & Regions​
    Version 5.0.0 : Updated for 1.0.0 and fixed glaring protection issues.​
    Version 4.0.80 : Mobs Fixed and Economy Support for iConomy6 (Thanks to Pianosaurus)​
    Version 4.0.71 : Complete Recode.​
  2. Offline


    Adam you are doing such an amazing job, you've inspired me to make my own plugin! You put so much time and effort into this, and for that I made a donation! just enough to buy you a soda or two lol ,but it counts :)

    Thank you so much!
  3. Thanks :D, and good luck with your plugin.
  4. So this doesn't work without spout? Does this mean that the server needs spout or that both server and client need it?

    I've tried this on my server (which have spout btw) but no matter how I try I can't set the permissions to work. Does this support permissionsbukkit?

    Sorry for being a total noob at this, I just have the server for me and a couple of friends so the demands on me isn't so hight, but I still like to try as many things as possible.
  5. Offline


    I can't seem to disable monster spawning, is this a known bug?
  6. Only the server requires spout, I support permissions but i may look into supporting permissions bukkit.

    You cant seem to do it because you don't know the command or you have done the command and it doesn't work?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  7. I've installed permissions 3 and the bridge to permissionsbukkit. Couldn't solve it any other way so.
    About spout. When running the client I get tons of errormessages on the server console. Running without spoutclient and everything tuns perfect.

    It's good to know that it's only the serverside of spout needed. :)
  8. Offline


    Okay i got it working :) but many of the commands arent working :(
    /regios mobspawn castle false
    /regios mobspawn castle f
    /regios health-regen 4
    and the /regios healthregen isnt giving me like any health regen even if i set it to 100 D:

    so pretty much non of the cmds are working for me lol
    i got spoutcraft, using it. and got spout plugin for the server,

    Anyone know?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  9. Offline


    Um Regios wont work on my server
    any thoughts the server log looks fine??
    The commands dont work either
  10. Yeah, the client mod is optional :D

    Just wait for the documentation or use the current GUI editor.

    What isn't working? It works fine for me.

    Ok, this is going to be my official explanation and I would appreciate if everyone could drop the issue after this.

    In my code there was a check which allowed any player with the name 'Adamki11s' to bypass Region protection. This was meant purely for testing purposes and I had no malicious intent for it whatsoever. I admit I should not have published it to GitHub until I had tested and removed the code in question. I'm sure most of you know I am not a malicious developer at all but I can see why people who do not know me may draw the conclusions expressed in the posts above.

    I assure you this was not malicious and have finished that line of testing and removed the code immediatley. If you still doubt the integrity and security of my plugin then I'd be happy to provide you with an MD5 checksum.

    Sorry for the misunderstanding everyone, I hope we can just forget about this unfortunate issue and move on.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  11. Offline


    how i protect an area?
  12. Offline


    Hmm, just a note but /regios just returns the message to use /regios help [pagenumber] and doing any /regios command returns the same message OVER and OVER and OVER - there's nothing at all in the console log. Another thing I noticed is that Regios didn't generate a Regios folder at all.. I am and op and at the top Pex rank on my server, at the time Pail wasn't working so I removed Pail completely. I might now reinstall Regios and *crosses fingers* hope it works! If it doesn't, I will report below...

    Ok, i'm getting the same problem again and again. Afraid i'll only be on tomorrow, gotta go for now..

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  13. It sounds like you don't have Spout installed. Regios will disable itself if you do not have Spout. You only need the server plugin, the client one is optional.
  14. Offline


    Oh, ok. Thanks.
  15. No Problem, I've updated the download to have the latest compiled dev build as of now which will now notify you that you need spout instead of just saying use help ;)

    Just added fallback support for Bukkit permissions.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Dec 14, 2016
  16. Offline


    Nice! really?! Adam once again you are amazing! Are they in the version that I have or should I stick with the version you gave me for now?
  17. They should be in the latest download of the dev build, if you could test it out and let me know that'd be great :D
  18. Offline


    Deffinatly! will do now! what are the perms so I can add them to my moderator group to see if it works?
  19. Offline


    They work perfectly adam! Wow! that just made my life even easier!
  20. Awesome :D
  21. Offline


    Where can I download the latest stable version? The download link on your website is broken
  22. You can get the latest dev build from this thread, download link at the top. I am almost finished with the recode
  23. Offline


    Whats the status on the recode adam? Do you think it will still be done by sunday?
  24. I am very close to finishing the GUI. After that I have to do a few little extra thing but yes I hope so. If not the release will probably be pushed back another week.
  25. Offline


    Then I hope you get it done sunday! I dont know how i'd wait another week! :) And also adam, this could be an issue with another one of my plugins, but I cant light fire anywhere, not in a regios region, with or without fire protection. Ill try to see if its a porblem with another one of my pluggins, do you know anything about it?
  26. I was just having this discussion with a friend :p I need to do a slight modification to the world settings so that fire is enabled by default. Just go into plugins > Regios > Configuration > World Configurations > yourworldname.rwc

    Open with notepad and change fire enabled to true
  27. Offline


    posted an issue on github ... probably made something wrong doing it :(
    When patching from old to new with a region name that includes a "/" .. example region name: "dave/kira"
    The patching process adds the forward slash as part of the path and therefore triggers an error message "The system cannot find the path specified"
    After running a stop/start on the server i recieve another error message, most likely due to the region errors during patch process, but youcan answer that better then me :p
    This was made on a Windows 7 computer (no access to a test server running linux)
    Pastebin for patch error:
    Pastebin for startup error after patch:
    i need to provide more info?
  28. Thank you, a very good bug report - rare ;)
    The second pastebin link is broken though. The second error is probably due to an error while patching. I'll just run a check for invalid name modifiers and change delete them. Thanks for the bug report :)
  29. Offline


    Thanks adam! also is selling working yet? I tried /r list-for-sale plot 100 and nothing happened I tried many different ways. I have economy set to iConomy also.


Share This Page