Inactive [ADMN/SEC] bPermissions v2.9.2 - no support on this post, ask for support on bukkitdev [1.2.5]

Discussion in 'Inactive/Unsupported Plugins' started by codename_B, Jul 21, 2011.

  1. Offline


    kahlilnc, Lappy, Gobiel and 4 others like this.
  2. Offline


    That was removed in favour of multigroup in 1.2
  3. Offline


    I am finally deciding to drop Permissions 3.1, I am just wondering if there is something like a "SuperPermsBridge" for bPermissions.
  4. Offline


    Built in.
    68x likes this.
  5. Offline


    Ill get it running on my test server and see whats what. Personally it didnt seem to have the functionality i wanted. So i didnt bother to update to this version on my live server yet.

    I'll see whats what and post any weird findings.

    ***888*** pretty much what everyone else is saying ***888***
    so ... I cant get this running lol - basically i cant seem to find the correct syntax
    mostly i just get
    "/p" after i give commands.
    or "/p are you sure your doing that right"
    what it do.
    Loads players in to the world yml as they join the world
    for Multiworld It auto joins the player when they join, and not before.
    I tried adding groups through console but nothing i could think of would work.
    When i did find the correct syntax( i think) nothing happened.

    /permissions global setgroup Member turtleplayer
    returns "that world doesn't exist"

    /permissions world setgroup Member turtleplayer world
    does nothing.
  6. Offline


    Multigroups is great and must be used with BananaTracks anyway.

    My problem is that bInfo is useless now if using the new multigroups!

    Do you have a workaround?
  7. Offline


    So you just add people to multiple groups instead of inheritance? Ok, then. Also, opping a player in game doesn't give the '*' node to them. Is this a bug? Running CB 1060 and bPermissions 1.2
  8. Offline


    How do I enable bridge?
  9. Offline


    Good morning.
    I did some testing by writing a small plugin. It doesn't matter how to type the permission. When checking against the String Bukkit normalizes both, the entered String and the result. This means when checking if a player has the permission "test" you can enter "test", "Test", "TEST", "TeST"... it will always return true.
    I also did this with "WelcomeGift.receivegift" and it returned true during the test. But when i make the same call from the actual WelcomeGift-Plugin it returns false. But why? :mad:
    I double checked the spelling, redownloaded bPermissions a few hours ago, made debug outputs to the console, tried hardcoding the String, added a method to the main .java-file and checked the permission from there, renamed the plugin and the permission-string, added the line "softdepend: [bPermissions]" to the plugin.yml... nothing worked for me. It always returns false... And why is there no crying smilie in this forum?

    Well... the post attachment contains the testing plugin, its code and the world.yml-file I used for testing.
    The command is /stress and output is made to the console. When somebody tries this remember to adjust the name in the world.yml-file.

    I will go on with rewriting my other plugins for Superperms now. If the gods of 0's and 1's have a heart they will send me inspiration.

    Attached Files:

  10. Offline


    It's not useless - because you can set negative permission nodes!
    That does something for me, can you double check you're doing everything correctly?
    It depends the plugin you're using - opping a player SHOULD override permissions (if the plugin is written correctly)
    It's automatic.
    See if I rewrite that and use && instead of & and it works... what will you do? :p
  11. Offline


    Try it again just to see that the condition still returns false. And (again) I added a line to output the result of hasPermission() to the console and it prints: false. I also redownloaded the jar and recreated the configs before. Before you say it again I also printed the output of !Settings.PropKnownPlayers.contains(player.getName()) to the console and it returns true and false after i added my name manually to the config as it should do.
    I will now try it again by building against Bukkit build 805 instead of the recommended 804.

    { // TODO DEBUG
    11:19:25 [INFO] true
    11:19:25 [INFO] false
    and Settings.PermReceive returns "WelcomeGift.receivegift" as it should.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  12. Offline


    Perhaps you're not ending up in the correct group? I dunno. Send me your bPermissions world.yml and tell me your exact IGN including caps in the right places.
  13. Offline


    I'm using the default group generated by the plugin (named default) as soon as the first player (me) joins. My IGN is exactly like my name here in the forum.
    Shall I try to define a group manually?

    The current world.yml:
    default: default
        - default
        - WelcomeGift.receivegift
  14. Offline


    check it with player.hasPermission("welcomegift.receivegift"); don't reference a static string outside the class, just use it right there.
  15. Offline


    { // TODO DEBUG
    still returns
    12:48:02 [INFO] true
    12:48:02 [INFO] false
    I have some work to do and will try out 2 ideas in the evening. I think there is a coherency between the permission and the pluginname itself. I'm curious because System.out.println(player.hasPermission("welcomegift.receivegift")); returned true in the test plugin i posted earlier.

    Is there someone who can post a success-story?
  16. Offline


    Well this plugins inbuilt nodes work fine and bPermissions.admin :S
  17. Offline


    someone should make a video how to make groups with preffix and stuff to
  18. Offline


    There's lots of different plugins for that.
    I use bChat and bInfo.
  19. Offline


    what aboute ichat ? and do you know a permssions plugin there works like Permissions 3.x
  20. Offline


    Permissions have been moved internally to bukkit, this does not include prefix/suffix. You need a seperate plugin to supply prefix/suffix.
    bChat works exactly the same as iChat along with bInfo.
  21. Offline


    So does anyone want to convert my Permissions 3.1.2 system over to this? I am willing to pay about $10 to get this done. I have 5 worlds. Send me a message. I would need the worlds to be setup and all the nodes for the plugins that I am using listed for the last group!
  22. Offline


    Well, after I removed MultiVerse-Core, (only one of the multiverse I used) the problems seem to have went away. Maybe there is a problem with that plugin.
  23. Offline


  24. Offline


        - Gast
        - Spieler
        - Admin
        - Gast
        - Spieler
        - Admin
    You also need to assign the group Spieler to admins, and also the group Gast

    Oh. and "defaults" should be "defaults: Gast" because you want every player to join as guest ;)

    Let us see your configfiles :)
  25. Offline


    Sorry codename_B... maybe I need sleep but I am lost.

    Do you mean adding something like this:^binfo. guest to the next group so it skips that prefix?
  26. Offline


    Config Files ? They are standart.....

    but why are SO MANY plugins useless after I use bPermissions ... MagicCarpet, Demigods, Godpowers.... all useless ... not working ... I even cannot use /spawn or something

    can you help me with that ? Please edit my to a working file ( I am OP ... why I am limited ? )
  27. Offline


  28. Offline


    Hi, if you want to, I could design a shiny logo for this. Just for the lulz.

    No really, I'm serious.
    I just made this because I didn't have to do anything and was bored.
    I dunno, maybe you like it.
    If you want a more colorful or "funny" version, tell me. :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
    codename_B likes this.
  29. Offline


    efstajas likes this.
  30. Offline


    Thanks :D
  31. Offline


    @efstajas That's awesome! Mad skillz!
    efstajas likes this.

Share This Page