[ADMN] PlugMan - In-Game and Console Plugin Manager [BukkitDev]

Discussion in 'Inactive/Unsupported Plugins' started by bekvon, Feb 20, 2011.

  1. Offline


    Project has been continued by ryanclancy000 at dev-bukkit here: http://dev.bukkit.org/server-mods/plugman/

    PlugMan - A Bukkit Plugin Manager
    Current Version: v1.3.2

    • Enable/Disable/Reload Plugins on the fly.
    • All commands work on the server console.
    • List plugins and show their status in green (enabled) or red (disabled) without client crashes.
    • Get plugin info such as the version, author(s), and description.
    • Permissions support (not required though).
    • List the commands a plugin has registered.
    • Describe the usage of a plugins commands.

    • /plugman list <Page> - lists all plugins loaded on the server. Page is optional
    • /plugman vlist <Page> - lists all plugins loaded with their version next to them. Page is optional
    • /plugman load <PluginName> - load a new plugin.
    • /plugman disable <PluginName> - disables a plugin.
    • /plugman enable <PluginName> - enables a plugin
    • /plugman info <PluginName> - shows the version, author, description and status of the plugin.
    • /plugman reload <PluginName> - disables and then re-enables a plugin.
    • /plugman usage <PluginName> - gets all the commands a plugin has registered.
    • /plugman describe <CommandName> <PluginName> - describe a command a plugin has registered.

    PlugMan will use the Permissions plugin automatically if found. If Permissions is not found, it will simple give server OPs full permission and everyone else nothing.

    Permission Nodes:
    • 'plugman.list' - gives the ability to use /plugman "list" and "info"
    • 'plugman.describe' - gives the ability to use /plugman "usage" and "describe"
    • 'plugman.admin' - give the ability to use all commands.
    v1.3.2 - 8/16/2011
    - Update for new bukkit permissions.

    v1.3 - 3/19/2011
    - Rebuilt against latest Recommended CB (556).
    - Added ability to list plugins with pages.
    - Added ability to list plugins with version numbers next to each plugin.

    Change Log (open)

    v1.2.2 - 2/28/2011
    - Rebuilt against latest recommended craftbukkit build (440 as of now).
    - Changed to a static download link.

    v1.2.1 - 2/23/2011
    - Changed namespace to no longer use com.bukkit in preparation for com.bukkit being sealed.

    v1.2 - 2/21/2011
    - Added the "usage" and "describe" commands to allow plugman to list all the commands a plugin has registered.

    v1.1 - 2/21/2011
    - Fixed minor bug causing a plugin to not be enabled on load if the jar filename was different then the plugin name.

    v1.0 - 2/21/2011
    - Initial Release.


    Source: GitHub
  2. Offline


    Just posted a request for this, the same time you posted the plugin!

  3. Offline


    Haha, thats awsome :D

    Well, let me know how it works for you and any improvements I can make.
  4. Offline


    I will :D
  5. Well seems like your plugin isn't up to date with the latest bukkit version as says my shell output, by the way none of the commands work, maybe because Permissions isn't up to date too ?

    By the way, using Bukkit#361

    Edit : Same with Bukkit#405
  6. Offline


    Ok, I managed to get it to work under 405 by simply compiling with the latest 405 bukkit.jar. I've provided links for both the 405 version and the 335 version now. I will test with some more versions so I can to provide a wider range of compatibility. The 405 version will still spit out that debug message, I'll fix that in a bit too.

    EDIT: Ok, it works as far back as 403 as well. Also, I went ahead and removed the long constructor, so that debug message should be gone now too.
  7. Thank you very much for this fast answer and debug :)
    I'll test that right away.

    Edit : Tested it with the #405 version, without Permissions and works perfectly.
    Tested with Permissions too, but it's like it wasn't here and allows everyone from typing the command. I bet we'll have to wait for a Permissions update.
    By the way, I first tryed it with other plugins loaded and it wasn't working, i'll tell ya soon which one was making your plugin bug (probably because of a non-updated version of plugin).
    Thank you again for your fast answer and debug :)
  8. Offline


    So it is not possible to do a real plugin reload ? (unload and load) only disable/enable ?

    I hate having to restart my server every time I need to update a plugin :(

    Nice work on fixing the client crash on plugin list though.
  9. Offline


    I believe its actually a java limitation, although I'm not 100% sure... Either way, as of now there is no bukkit API function that allows removal of a plugin completely. :( I would love to have it be able to do a real reload as well as I like to update plugins often, but at the moment I don't think its possible.
  10. Ok tested adding each of my plugins one by one, and seems like iMonster (which bugs with its "onEnable" method) completely blocks PlugMan, when iMonster (bugged version) is trying to be loaded, PlugMan doesn't work anymore.
    I'll pass this information to the iMonster developper right away by the way.
    Seems like after iMonster crashes on loading itself, the loader stops loading Plugins, so yours which is alphabetically after it doesn't load. Could there be a fix on your plugin, or on bukkit to handle these exceptions and continue loading plugins anyway ? Maybe bukkit developpers should be aware of that bug too.

  11. Offline


    Theres nothing I can do about that exception I'm afraid, that's up to the Bukkit developers.... If my plugin were to be loaded before it died, then it would be possible at least to load other plugins using PlugMan. I'm not sure if the bukkit devs are aware of it, but if they aren't then yea they need to be.
  12. Offline


    Ok, I just released a new version 1.2, which brings the ability to list the commands of another plugin. You do this with /plugman usage <PluginName> to get the list. You can also get the description of a command with /plugman describe <CommandName> <PluginName> Do note, that descriptions only work if the plugin author has provided a built in description. This is stored in the Plugin.yml file inside every plugin's .jar file.
  13. Offline


    um, i got it and i viewed that it worked on console, but i cant do anything, none of its commands work
  14. Offline


    Can you tell me what version of CraftBukkit you are using?
  15. Offline


    i am using jenkins build 53, thats like 430 or something if it was bamboo
  16. Very nice update :) Works perfectly under Bukkit#405
  17. Offline


    Very nice...even with the lack of a full unload/reload functionality this is pretty awesome for server ops.
  18. Offline


    This plugins purely amazing mate however wheneva i type in /plugman enable MagicCarpet is says failed to enable plugin how would i enable this in permissions ?? btw its an awesome plugin mate well dun ;)
  19. Offline


    Hmm, I just tested it with build 53 and it works fine for me, you are using the 403+ version right?

    Thanks :) As for the MagicCarpet issue, its probably not a issue with your permissions, but rather with the MagicCarpet plugin itself. If it downright fails to enable that usually means that either its not supported with the CraftBukkit build your using or it depends on another plugin to run which is missing from your server.
  20. Offline


    Having trouble with craftbukkit 432.

    I'm using GroupManager instead of Permissions (all other plugins work with it), and I have the plugman.* permission (GroupManager confirms), but I do not have access to any plugman commands.
  21. Offline


    Try giving yourself plugman.admin instead of plugman.* as it gives you the exact same permissions (all commands). I will look and see if its something I've done wrong or something wrong in GroupManager.

    EDIT: Ok, I tested it with CB 432 and GroupManager 9.0d, and everything seems to check out (even when using plugman.*). Make sure you using the latest GroupManager as I belive it fixes some bugs with the post minecraft 1.3 update versions of CraftBukkit. Let me know if you continue to have troubles.
  22. Offline

    Kevin Forte

    Hello, I have been sent by my cmd prompt to ask you to post the update source for your plugin here. (Links to the CraftBukkitUpToDate plugin forum, apparently the dev implemented plugin updating)
  23. Offline


    Ok, I'll get to implementing that when I can. However, It will be a few days since I am away from home right now.
  24. Offline


    Any chance of getting this plugin built against the recommended builds per the Bukkit team's requirements?
  25. Offline


    Yea, just did that, thanks for reminding me :)
  26. I have notice an error with the plugin "Wand" and "Spells" When I disable Wand, it still works but if I have Wand enable and Spells disable, than the wand doesn't work. I have also notice that by disable Wand and enable it, it's effects are Wand x N (N = the number of times you disable and enable it)
  27. Offline


    Hey there! Thanks for your hard work towards this plugin. It's great for seeing what's currently running and such on the server. However, I wanted to give you some feedback regarding my experience. Specifically, while PlugMan seems to be working fine for reloading plugins, any that I've disabled do NOT get disabled and are still active. For example, if I turn off a shop plugin, users can still access all features of the shop.
  28. Offline


    Hi, we've just installed this plugin (version 1.2.2) on 'git-Bukkit-0.0.0-459-g33fb4d6-b443jnks (MC: 1.3)' (not the latest perhaps, but new enough I guess).

    Anyway, I've tried a few ways, but I can't seem to figure out how to handle plugins that hat have a whitespace in the name. Maybe plugins aren't meant to have whitespaces in their names. But /plugman list does very nicely put quotes around plugin names (something this other plugin doesn't, making it one huge mess of words). That's very nice. But I'd like to be able to info/reload/etc plugins with whitespaces.

    Though the only set of plugins with whitespaces we use are from Minecart Mania.
  29. Offline


    Its usually the fault of the plugin your trying to disable, many plugin authors ignore putting in code to make their plugin stop working when you disable it. If you want to make sure plugman is working, you can try disabling plugman itself. Just realize that you will need to restart your server afterward to get it back lol, since it can't re-enable itself.

    Hmm, I've never had trouble with white spaces. Have you tried simply /plugman disable Minecart Mania Core

    I can do that on mine and it disables fine. You don't need to put it in quotes or anything, because it will simply take anything after the "disable" as part of the plugin name.

Share This Page