[ADMN] ModTRS v2.1 - Moderator Ticket Request System [1240]

Discussion in 'Inactive/Unsupported Plugins' started by Yetanotherx, Apr 4, 2011.

  1. Offline


    not working for me.
  2. Offline


    That gives me absolutely nothing to go on. What doesn't work? What do you expect it to do? What does it do instead? What does your installation setup look like? Read this and try again: http://www.chiark.greenend.org.uk/~sgtatham/bugs.html
  3. Offline


    ModTRS has been working fine, until a Moderator of mine attempted to do /modreq help, this gave them an inernal error, and did not work. I tried it and got the same result, and the same thing continued after restarting the server. Here's the error that occured when attempted to do the command:
    23:20:34 [SEVERE] java.lang.UnsupportedOperationException
    23:20:34 [SEVERE]       at java.util.AbstractList.remove(AbstractList.java:161)
    23:20:34 [SEVERE]       at yetanotherx.bukkitplugin.ModTRS.util.ModTRSFunctions.removeFirstArg(ModTRSFunctions.java:54)
    23:20:34 [SEVERE]       at yetanotherx.bukkitplugin.ModTRS.command.CommandHandler.onCommand(CommandHandler.java:120)
    23:20:34 [SEVERE]       at yetanotherx.bukkitplugin.ModTRS.ModTRS.onCommand(ModTRS.java:140)
    23:20:34 [SEVERE]       at org.bukkit.command.PluginCommand.execute(PluginCommand.java:35)
    23:20:34 [SEVERE]       at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:129)
    23:20:34 [SEVERE]       at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:320)
    23:20:34 [SEVERE]       at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:713)
    23:20:34 [SEVERE]       at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:677)
    23:20:34 [SEVERE]       at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:670)
    23:20:34 [SEVERE]       at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:33)
    23:20:34 [SEVERE]       at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    23:20:34 [SEVERE]       at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:85)
    23:20:34 [SEVERE]       at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    23:20:34 [SEVERE]       at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:451)
    23:20:34 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:361)
    23:20:34 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Using Craftbukkit RB# 1000, and an exact list of plugins is here:

    The only thing that changed with the update of ModTRS was also an update to ChestShop, as detailed here:

    So yep. if you see any conflicts let me know!

    Edit: just received news that /tp-id didn't work correctly at one point either, but it does now. I don't have any more information on that.
  4. Offline


    its ok it is working now
  5. Offline


    I wish you could reply to them. It would be easier then /msg, not that I'm lazy or anything. but you can't msg them when they are offline, so maybe you could add this? :p <--- yay for terribly worked requests!
  6. Offline


    The wiki is [SEVERE]ly outdated. :p

    Configuration page is completly missing including history which it suggests I use oddly enough.
    Other pages state 2.0 isn't released yet. I still don't know if 2.0 is going to use the old db as there doesn't seem to be any option to configure that. I guess I'm restarting my large server and hoping for the best. :/
  7. Offline


    Can you make it so the numbers reset? I currently have tickets being send in with numbers in the 150 range.
  8. Offline


    @rmb938 You'd have to wipe the database Sir.
  9. Offline


    That is inconvenient
  10. Offline


    Every time I log in I get this message
    "The following request(s) have been completed while you were offline..."

    If I'm getting this, as server owner who was showing a mod how to use the ticket system, I'm sure my users are getting this spam when they log in.
  11. Offline


    This is a known issue, and will be fixed in the next version.
  12. Offline


  13. Offline


    I really like your plugin and I decided to do a quick little video, clearly explaining how to use the system. I hope you can add it to your original post since it'll explain OPs/Admins/Moderators how to use this plugin.

    This is the video:


    royfort likes this.
  14. Offline


    Excellent, that's a great video that explains the basics! I'll add it to the original posts!
    royfort likes this.
  15. Offline


    Small thing, make it say "Thanks CyberSick99" for the video on the Minecraft if you want to. I'm known as ~Cyber to most people, I never use MineJob for any of my other usernames.

    Thanks and sorry if it seems like I'm whining :p...
  16. Offline


    Is there anyway to get this to e-mail my servers email address whenever a ticket is posted? I use Mobileadmin, and that would solve alot of problems since me and one other person are the only admins on the server.

    That way, I get an email notification on my phone, look at the ticket, and either solve the problem myself through mobileadmin, or have the other admin come online and deal with it himself.
  17. Offline


    I also get the same java.lang.UnsupportedOperationException if I try to use /modreq help as Darq. Would be nice, if you could fix this, because currently there is no ingame-help for this plugin.
    Could you add a feature, which allows my moderators to comment a request without closing it?
    Would it also be possible to save the pitch and yaw of the player, if a ticket is opened? It would be great to see, what the player saw when he sent a request.
  18. Offline


    The plugin works great, but I have one suggestion. A little addition to the login message. Adding the display of held tickets to that message.
    An example would be: "There are 3 open, and 1 held mod requests. Type...."
  19. Offline


    Update it to bukkit for 1.8.1 please :)
  20. Offline


    yes, update for 1140+ build (will obviously work for RB when it comes out).
  21. Offline


    I can't use /modreq.. I get the Jeb_ error! :)
  22. Offline


    When i try to use any command it says:

    I'm using latest permissions and bukkit 1150
  23. Offline


    Same as above D:
  24. Offline


    I've got this working with Bukkit Build 1152 without major problems, and PermissionsEx with a SQL database (too sick and tired of users.yml being destroyed)

    I notice that /modreq help command causes a NPE though.

    That error means that your users don't have modtrs.command.modreq privs
  25. Offline


    Getting the `im sorry dave i cannot let you do that` Text everytime... Im 90% sure my permissions are fine.. here they are if anyone sees any flaws

    This is just the admin portion

    default: false
    prefix: '&4'
    suffix: '&f'
    build: true
    - 'permissions.help'
    - 'permissions'
    - 'towny.admin'
    - 'towny.town.claim'
    - 'bukkit.command.whitelist'
    - 'bukkit.command.whitelist.add'
    - 'bukkit.command.whitelist.list'
    - 'OwnBlocksX.use'
    - 'OwnBlocksX.*'
    - 'shop.create.server'
    - 'OpenInv.openinv'
    - 'OpenInv.exempt'
    - 'OpenInv.search'
    - 'OpenInv.override'
    - 'residence.admin'
    - 'modtrs.mod'
    - 'modtrs.command.ban'
    - 'modtrs.command.unban'
    - 'modtrs.command.check'
    - 'modtrs.command.complete'
    - 'modtrs.command.complete.override'
    - 'modtrs.command.broadcast'
    - 'modtrs.command.teleport'
    - 'modtrs.command.reload'
    - 'modtrs.command.modlist'
    - 'modtrs.command.modreq'
    - 'modtrs.mod'
    - 'modtrs.command'
    - '*'
  26. Offline


    since both permissions 2.x and 3.x are dead, i moved to bPermissions and now everything is working :)
  27. Offline


    Why is Wildcard support gone?

    I have "*", and I get Bukkit Sad.

    CB 1160.
  28. Offline


    Can anyone transport this plugin to #11xx? Or make some plugin like this?
  29. Offline


    Dont work on 1185 - Bukkit sad.... why?
    blitzer88 likes this.
  30. Offline


    Hmm. Looks like I have the correct permission nodes to my correct groups however it is not allowing them to use the commands. I am using group manager from essentials. Any ideas?
    XCruX likes this.

Share This Page