Inactive [ADMN] MineBackup v0.4.8.1 - Auto backup worlds ! [1060]

Discussion in 'Inactive/Unsupported Plugins' started by ThisIsAreku, Jun 24, 2011.

  1. Offline


    This plugin causes read times outs during backups over here. Am I doing something wrong or...? CentOS 5, 8GB of ram, dedicated server, 8 xeon cores.
  2. Offline


    I set it to keep backups 10d...and it deleted all of yesterdays backups! :(
    Am I setting it incorrectly?
  3. Offline


    OK this is quite annoying, whenever I reboot my server it makes a back up, making even the shortest plugin-configuration downtimes significantly longer.

    Any way to set this differently?
  4. set 'delay: xxx' to the same value as 'interval: xxx'
  5. Offline


    Alright, ill try that.


    Wait, wouldn't that stop the server from autosaving?
  6. No, it just will set the delay for the FIRST autosoave you could set it to anything you like.

    interval: 3600
    delay: 300
    Saves the first time 5min after Server start/plugin reload and afterwards it takes the interval value, in this case 1h after the first autosave occured
  7. Offline


    Ok I do know it is possible being SimpleSave did it just fine, but simplesave is now inactive. You might be able to grab his source code, and find the bits you need. I'm no programmer so I can't do it myself.
  8. Offline


    So what is the problem with ram disks? I'm running MineBackup on a linux ram disk and my only issue is it not deleting old backups, but I guess that's been resolved right? What should I be looking out for?
  9. I could not program for 2 weeks (vacation), but upon my return, I'll take care of seriously. and finally I will integrate DropBox!

    I think the problem depends of how people setup their server...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  10. Offline


  11. @Fluffgar
    Oh shit, I changed the address by mistake. Now it should work.
    Fluffgar likes this.
  12. Every half an hour I keep getting the error:
    [SEVERE] [MineBackup] Unparseable date: "world_nether"
    My backup interval is set to every 15 minutes, so not only do I not quite get the error, I also don't know why it's happening not every single time if there's an error on the world. My config:
    config (open)
    # available worlds :^M
    # - world^M
    # - world_nether^M
    # - riverworld^M
    # - nightmare^M
    # - dreamland^M
    interval: 900
    backup-plugins: false
    pause-when-no-players: false
    days-to-keep: 15
    backup-dir: backups
    - world
    - world_nether
    - riverworld
    - nightmare
    - dreamland
    delay: 10
    enabled: true
    mode: DEFLATED
    backup-ended: §a[MineBackup] Backup ended.
    backup-started: §a[MineBackup] Backup started...
    backup-started-user: §a[MineBackup] Backup started by %player%.
  13. Offline


    Some help please:

    >11:45:16 [SEVERE] Could not load 'plugins/MineBackup.jar' in folder 'plugins':
    unacceptable character #FFFD special characters are not allowed
    in "<reader>", position 331
      at org.yaml.snakeyaml.reader.StreamReader.checkPrintable(
      at org.yaml.snakeyaml.reader.StreamReader.update(
      at org.yaml.snakeyaml.reader.StreamReader.peek(
      at org.yaml.snakeyaml.reader.StreamReader.peek(
      at org.yaml.snakeyaml.scanner.ScannerImpl.scanToNextToken(
      at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(
      at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(
      at org.yaml.snakeyaml.parser.ParserImpl$ParseImplicitDocumentStart.produce(
      at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
      at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
      at org.yaml.snakeyaml.composer.Composer.getSingleNode(
      at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(
      at org.yaml.snakeyaml.Yaml.load(
      at org.bukkit.util.config.Configuration.load(
      at org.bukkit.plugin.SimplePluginManager.loadPlugin(
      at org.bukkit.plugin.SimplePluginManager.loadPlugins(
      at org.bukkit.craftbukkit.CraftServer.loadPlugins(
      at org.bukkit.craftbukkit.CraftServer.<init>(
      at net.minecraft.server.ServerConfigurationManager.<init>(
      at net.minecraft.server.MinecraftServer.init(
    My config:
    # available worlds :
    # - Xerpund
    # - Xerpund_nether
    interval: 21600
    backup-plugins: false
    pause-when-no-players: false
    days-to-keep: 2
    backup-dir: minebackup
    - Xerpund
    - Xerpund_nether
    delay: 21600
        enabled: true
        level: BEST_COMPRESSION
        mode: DEFLATED
        backup-ended: �a[MineBackup] Backup ended.
        backup-started: �a[MineBackup] Backup starting...
        backup-started-user: �a[MineBackup] Backup started by %player%
  14. Offline


    Hi, I just got 4.6.1 running on CB1000 and I get this error:

    2011-08-02 17:12:19 [INFO] [MineBackup] Starting backup...
    2011-08-02 17:12:19 [INFO] [MineBackup]  * world
    2011-08-02 17:12:20 [SEVERE] [MineBackup] ---------------------------------------
    2011-08-02 17:12:20 [SEVERE] [MineBackup] --- an unexpected error has occured ---
    2011-08-02 17:12:20 [SEVERE] [MineBackup] -- please send line below to the dev --
    2011-08-02 17:12:20 [SEVERE] [MineBackup] : null
    2011-08-02 17:12:20 [SEVERE] [MineBackup]     alexoft.Minebackup.Backups.copyWorld(
    2011-08-02 17:12:20 [SEVERE] [MineBackup]     alexoft.Minebackup.Backups.MakeBackup(
    2011-08-02 17:12:20 [SEVERE] [MineBackup]     alexoft.Minebackup.Backups.backupRun(
    2011-08-02 17:12:20 [SEVERE] [MineBackup]
    2011-08-02 17:12:20 [SEVERE] [MineBackup]     org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    2011-08-02 17:12:20 [SEVERE] [MineBackup]     net.minecraft.server.MinecraftServer.h(
    2011-08-02 17:12:20 [SEVERE] [MineBackup]
    2011-08-02 17:12:20 [SEVERE] [MineBackup]
    2011-08-02 17:12:20 [SEVERE] [MineBackup] ---------------------------------------
  15. @wears_Fedora
    There's an error in your config file. Remove it and restart the server.

    I cannot help you now as I'm away from my home. I'm back in two weeks, and I've noticed your problem.

    @HereInPlainSight same remark as Samika

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
    Samika likes this.
  16. Offline


    Is this plugin safe to use? Or will it corrupt my worlds?
  17. Offline


    Is there any way I could get an older version of the plugin? I went from (I think) 0.4.3 to the latest and now I have lots of [SEVERE] type errors like Samika and no backups.
  18. Offline


    Ever since I started using this plugin, my server crashes in the middle of every backup. It kicks everyone and then like 2 minutes later everyone can join. It's not a huge problem, but when it makes backups every 30 minutes, it means my server crashes every half hour. When it builds up, it gets annoying.

    I am on Craftbukkit #1000 and I'm using the version of MineBackup. This is really annoying. This is my config file:

    # available worlds :
    # - world
    # - world_nether
    interval: 1800
    backup-plugins: false
    pause-when-no-players: true
    days-to-keep: 10
    backup-dir: minebackup
    - world
    delay: 2
        enabled: true
        level: BEST_COMPRESSION
        mode: DEFLATED
        backup-ended: §a[MineBackup] Backup ended
        backup-started: §a[MineBackup] Backup started
        backup-started-user: §a[MineBackup] Backup started by %player%
  19. Offline


    People are getting kicked at every backup. Also, I am using RAMDisk.

    # available worlds :
    # - City
    interval: 7200
    backup-plugins: false
    pause-when-no-players: true
    days-to-keep: 2
    backup-dir: minebackup
    - City
    delay: 3600
        enabled: false
        level: NO_COMPRESSION
        mode: DEFLATED
        backup-ended: §fBackup complete.
        backup-started: §fBackup started.
        backup-started-user: §fBackup started by %player%.
  20. The backup plugin function don't work!
    And how can I disable the broadcast
  21. Offline


    I really want to use this plugin, but it gives me read time out errors whilst it is backing up, causing a 2 minute downtime which is kinda annoying.
  22. Thats because currently its unused, i guess he'll add that function in the future
  23. And how can I disable the Broadcasting ?
  24. Offline


    I've got a similar problem, (exactly the same in fact), as Samika ...
    It happens after a /reload ...

    EDIT : Solved ! I've cleared some old backups. I guess that my drive was full.
    When you talk about Ramdisk, did you mean the usage of a tmpfs filesystem ?
    I run linux too.
  25. Offline


    The backup plugin function don't work!
    Please Fix it~
    Antac55 likes this.
  26. Offline


    Is the link broken? I get "taking too long to respond" when I try to download
  27. Offline


    Is there a way we could have a different directory than the folder the server is in?

    nvm i asked before i tryed doing a different directory, it works fine thank you for this plugin!
  28. Offline


    when backing up my whole server freezes and everyone disconnects, it still backs up, but no one can connect until it is done backing up ... is this a threading issue? I'm on a VPS so I'm pretty sure I only have 1 core :'(
    Antac55 likes this.
  29. Offline


    My computer i use for a server is single-core with only 2gb ram and it freezes as well but the freeze is only for 20sec and no one gets discontented. just wanted to share if it helps xD
    Antac55 likes this.
  30. Offline


    This is very good, however I'm experiencing the same issue with disconnects and Read Errors when the server backs up. I use Xenon to host.

Share This Page