Inactive [ADMN/INFO] Permissions v2.1 - Continuing the legacy.

Discussion in 'Inactive/Unsupported Plugins' started by Nijikokun, Jan 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.1 (Handler)
    Download 2.1 (Jar Only)
    Older: 2.0, 1.9, 1.8, 1.7, 1.6, 1.5, 1.4, 1.3, 1.2, 1.1, 1.0

    Permissions... Done right.
    Permissions allows plugin-authors to utalize a permission system that handles group inheritance, globalized permission settings, and more. All the features of a fine-grained permission system in one plugin.​

    1. Groups
    2. Group Inheritance, Allows for groups to gain permissions from other groups.
    3. User Permission System
    4. Fine Grained Permission system.
      1. Allowing for Globalized permissions
    5. Easy to use, setup, and implement.
    6. Two cache layers, first from file to memory, then from memory to cache.
      1. Plugins can control cache since version 2.1
    7. And much more.
    For the users

    Permissions gives server admins great control, mostly in-game reloading. Simply use /pr and the file will be re-cached and never touched again until you need to reload it. This allows you to quickly give your users the commands that they need without having to restart the server.

    Installation for 2.0 down:
    1. Download the archive.
    2. Extract contents to the /plugins folder.
    3. Open up /plugins/Permissions/config.yml
      1. Read / modify.
      2. Save.
    4. Reload Server.

    • 2.1
      • Multiple-World support
      • New cache layer, and cache control support for plugins
      • Editing features for plugins to hook into
      • Exempt nodes
      • World copying
    • 2.0
      • Forgot.
    • 1.9
      • Fully fixes inheritance.
        • Groups now inherit groups of groups that inherit groups of...
      • Cache system implemented.
      • Plugin authors can now delegate a variable system if needed.
      • API Updated with two new functions to get the point of what they do across.
        • Along with the new variable checks.
    • 1.8
      • Fixes the broken globalized node issue.
        • node.* is called a `globalized node`
    Supporting Plugins

    I have hit the character limit for this post.​

    Thanks to:
    • sk89q for hiearchical and node system idea.
    • Creator of GroupUsers for api implementation.
    This author has stopped development of this plugin. It is no longer supported and I wouldn't ask for help here, as you won't get any. New Permissions
  2. Offline


    Every time I use /pr , I get an Error: null that basically shuts permissions off and also all other plugins. Only way to fix it is to restart server.

    This is not new since today, it's been happening for a few days and still happens today after various updates.

    Below is my config... the online parser does not show any errors... can someone pls help? :(
    (it's not showing the spacing but I do have the proper spacing in here...)

    permissions: {system: default}
    default: true
    info: {prefix: '&f[&eCitizen&f]', suffix: null, build: true}
    inheritance: null
    permissions: [iConomy.payment, iConomy.rank, iConomy.list, essentials.spawn, essentials.tpdeny,
    essentials.tpaccept, essentials.helpop, essentials.home,, essentials.sethome,
    essentials.list, essentials.mail, essentials.afk, essentials.depth, essentials.msg,, essentials.warp, essentials.mail.*, essentials.motd, lwc.protect,,, essentials.kit, essentials.kit.starter]
    default: false
    info: {prefix: '&f[&aMentor&f]', suffix: null, build: true}
    inheritance: [Citizen]
    permissions: [essentials.time,*]
    default: false
    info: {prefix: '&f[&bMod&f]', suffix: null, build: true}
    inheritance: [Citizen]
    permissions: [*, /worldguardnotify, essentials.warp,,
    essentials.tphere, essentials.item, essentials.give, essentials.getpos, /worldeditselect,
    //, /butcher, /ex, /fixwater, /fixlava, /region, //wand, //pos1, //pos2, //hpos1,
    //hpos2, //expand, //contract, //stack, //move, essentials.setspawn, essentials.tree,
    essentials.bigtree,, essentials.time, essentials.heal, essentials.spawnmob,
    essentials.tele, essentials.tpa, essentials.tpahere, essentials.clearinventory,
    essentials.getpos, /stack, /stopfire, /allowfire, lwc.mod, mcbans.kick, mcbans.ban.*,
    mcbans.view_ban, mcbans.unban, mcbans.tempban, mcbans.reload]
    default: false
    info: {prefix: '&f[&cAdmin&f]', suffix: null, build: true}
    inheritance: [Mod]
    permissions: ['*']
    runelynx: {group: Admin}
    erthael: {group: Admin}
    benbestvater: {group: Admin}
    kotone: {group: Mod}
    minikyuubi: {group: Mod}
    steveval: {group: Mod}
    robertr: {group: Mod}
    xenoxhawk: {group: Mentor}
    treminer: {group: Mentor}
    timetuner: {group: Mentor}
    SethyBoy0: {group: Mentor}
    levitater: {group: Mentor}
    jackwhitaker: {group: Mentor}
    hamish_g: {group: Mentor}
    giester: {group: Mentor}
    fingerpaint: {group: Mentor}
    fallz2772: {group: Mentor}
    ericson666: {group: Mentor}
    drage65: {group: Mentor}
    cowmanodoom: {group: Mentor}
    AlleyxD: {group: Mentor}
    clay3120: {group: Mentor}
    dethknaw: {group: Mentor}
  3. Offline


    Please please can you edit that to use the code tag, that stuff is terrible to read. My eyes hurt.

    To start with, all of your 'null' :s in the config file are invalid.
  4. Offline


    Hmm, not bad. I wasn't aware of that.

    Thanks for tip, I'll try this.
  5. Offline


    I would also like to know how i can set custom titles for diffrent people
    for example, both these people are admins:
    [some other title here]<the guys namehere>

    Would this be possible?
    I'm using iChat.
  6. Offline


    Am I moron or am I missing something? Users are complaining that inheritance isn't working. Below is essentially what I have going on.

    (Permissions 1.9, CraftBukkit b137)

    My hopes is to have VIP inherit Donator, Basic, and Default group permissions. Donator just Basic and Default, and Basic to just inherit Default.

    Am I doing it right?

            default: true
                build: true
                - ''
                - 'essentials.tpaccept'
                - 'essentials.tpdeny'
                - 'essentials.helpop'
                - 'essentials.rules'
                - ''
            default: false
                build: true
                - Default
                - 'essentials.mail.*'
                - 'essentials.spawn'
                - 'myhome.home.basic.*'
                - 'essentials.nick'
            default: false
                prefix: '[&1Donator&f]'
                build: true
                - Basic
                - ''
                - ''
                - 'essentials.whois'
            default: false
                prefix: '[&bVIP Donator&f]'
                build: true
                - Donator
                - 'essentials.tpahere'
                - 'essentials.tpa'
                - 'essentials.kit.*'
  7. Offline


    Im highly confused!
    Some how, somethign changed my permissions file format. Causing persmissions to not load on start. Whats even more strange, if I do a /plugin load Permissions (essentials command), it loads and everything works as intended.

    thats what it did to ALL my groups.. Some small indints missing, but its completely changed...

    I read one page back its because of modgrp in essentials, but no one has access to that command, and I havent used it.
  8. Offline


    Make sure you're file is in YAML format. If it's not, things will break and errors will occur. When you do /pr does the server console spit errors at you? Do you get and error message when you paste your .yml file into this page:

    [EDIT] I should add that your file MUST keep the spaces (not tabs) between everything. This is how YAML works. Look at my above post on how a sample config should look like

    This is how I have mine set up:
    in iChat/config.yml:
    message-format: '+prefix <+name> +suffix+message'
    in Permissions/config.yml:
    prefix: '[&1Donator&f]'
    This way also lets you see suffix as a code colour if you want their message text to be a colour
  9. Offline


    Hello, today I tried to make a replaceable permission system. But now I null in ((Permissions) plugin).getHandler().

    You could see my wrapping system on github: xWarp
    Interesting source code:
    PermissionsPluginCreator Line 15 (There it returns null)
    WrapperCreator Line 20 (There I search for the plugins)
    MyWarp Line 43 (There I started to load the plugins)

    I know, that plugin is not null, and I get no class cast exception, so I could cast it to Permissions.

  10. Offline


    well that's not what I want, I want it to be player independent, not like groups
  11. Offline


    can some one give me an example of what a typical permissions text would look like. i'm really struggling trying to figure out how i am suppossed to do it. :D
  12. Offline


  13. Offline


    How do i add prefix and coloured names in?
  14. Offline


  15. Offline


    I understand the formatting, the forum removed it, should have used pastebin.. the problems is that something changed the way its formatted. I think it looks/works better this wat IMO though..

    Just dont understand why/how it changed.
    Dont understand why it doesnt load on startup properly, but if i use another plugin to enable it, its fine after that.
  16. Offline


    fffizzz: use the code tags or an external pastebin :)
  17. Offline


      permissions: {system: default}
        default: true
        info: {prefix: '', suffix: '', build: false}
        inheritance: []
        permissions: [essentials.spawn,, essentials.motd, essentials.helpop,
          essentials.msg, essentials.playerlist, essentials.who, essentials.list, essentials.tpaccept,
          essentials.tpdeny, essentials.home, essentials.sethome]
        default: false
        info: {prefix: '&7', suffix: '', build: true}
        inheritance: [Default]
        permissions: [essentials.mail, essentials.clearinventory, essentials.getpos, essentials.kit,
          mywarp.warp.*, mywarp.warp, msg, tell, m, who, search, cleaner.clean, cleaner.clean.force,
  18. Offline


    But it would be nice if this will be implemented.

  19. Offline


    any chance of getting either:
    - that the /pr command can be done from the command line
    - that the /pr is executed on a timer or other somehow regular or controllable event
    - a permission setting to give the /pr command to a user group that is not admin
    - to get permissions to be reloaded every time a user joins

    ANY of those would be highly appreciated!!
  20. Offline


    Sadly the creator didn't post this yet on the first page :(

    The permission is: 'permissions.reload'
    And the /pr on the command line is not possible yet because of (bukkit) if I'm not wrong.

  21. Offline


    Could be.... I love the console and running commands from it. I hope soon bukkit will also allow to run all the commands from it.
  22. Offline


    I don't doubt that you got it to work correctly on your machine, you absolutely seem to know what you are talking about in these forums (even if advice comes with a health dose of hostility). Just because our setup does not produce mirrored results doesn't mean "we're doing it wrong." Theres just too many variables at play to make an over-generalizing statement like that. Other plugins are obeying permission's hierarchies (worldedit, worldguard, iconomy, etc), which is why we have isolated the problem to the relationship between permissions and essentials.

    I'm straight-up telling you that the build of permissions (1.8) does not behave predictably. We HAD to disable the commands in the essentials config file to get inheritance working properly. I know that is not the way it is intended to work, but it is what it is. All of our YAML files are run through the parser before we restart the server and reload plugins. We take the necessary precautions, as we aren't a group of script-kiddies running a server off of our old emachine in the basement ;) Furthermore, YAML is an incredibly simple markup language (albeit relatively picky). Give us at least a little credit considering me and my mods are all working CS/IT professionals who love our fields almost as much as we love the Minecraft community.

    The main problem we've had with permissions/essentials is assuming that group/user permissions would behave like linux usergroups, etc, and that just simply has not been the case. In some cases inheritance was traveling in two directions , cascading permissions both up and down! Essentials.item (and other similar permissions nodes) were never explicitly given to anyone, and yet users were having access to them in-game. Both essentials and permissions are outdated now, so perhaps an update of both plugins will fix this.
  23. Offline



    can anybody post the command for the super pikaxe from worldedit because 'worldedit.//' doesn't work

    Thx Thallo
  24. Offline



    - '/worldedit'
  25. Offline

    Gene Myers

    How come every time i try to edit config.yml in my notepad ++ the text shows up in red.. also with this plug in do u have to enable it on other plugins? for instance in order for it to work for the essentials plugin.. do i have to somehow enable it in essentials please answer this asap i have my server down until i can install permissions because we need iconomy
  26. Offline


    This was working perfectly, but out of nowhere it gives me an error. I am able to start the server correctly, with no errors, while running the following plugins:
    general commands
    permissions (duh)
    and Worldedit
    After i start the server, and I attempt to log on, when downloading terrain it gives me this error:

    Minecraft has crashed!

    Minecraft has stopped running because it encountered a problem.

    If you wish to report this, please copy this entire text and email it to [email protected].
    Please include a description of what you did when the error occured.

    --- BEGIN ERROR REPORT a1dce528 --------
    Generated 1/30/11 12:20 PM

    Minecraft: Minecraft Beta 1.2_02
    OS: Mac OS X (i386) version 10.6.5
    Java: 1.6.0_22, Apple Inc.
    VM: Java HotSpot(TM) Client VM (mixed mode), Apple Inc.
    LWJGL: 2.4.2
    OpenGL: NVIDIA GeForce 320M OpenGL Engine version 2.1 NVIDIA-1.6.24, NVIDIA Corporation

    java.lang.StringIndexOutOfBoundsException: String index out of range: 20
    at java.lang.String.charAt(
    at nh.a(SourceFile:152)
    at nh.a(SourceFile:119)
    at pe.a(SourceFile:238)
    at ll.b(SourceFile:346)
    --- END ERROR REPORT 26e95313 ----------

    The Reason why I think this is a permissions problem, is because when I delete a # infront of a comment in the config.yml, causing permissions to not load for the plugins, I can log in fine and play on the server. It is only when
    Permissions loads that this doesn't work. I also tried deleting all code in config.yml and copying what you have on the first page of the thread, but it still doesn't work.
  27. Offline


    /pr can be used from the minecraft console ingame and I have not had any issues, works fine with craftbukkit 168
    --- merged: Jan 30, 2011 5:26 PM ---
    No, you do not "enable" it through other plugins, the plugins that are compatible with permissions are set to look for permissions when they load and then load their settings from there.
  28. Offline


    2011. 1. 31 2:24:23 org.bukkit.craftbukkit.CraftServer loadPlugins
    : java.lang.Integer cannot be cast to java.lang.String (Is it up to date?)
    java.lang.ClassCastException: java.lang.Integer cannot be cast to java.lang.Stri
    at com.nijiko.permissions.Control.load(
    at com.nijikokun.bukkit.Permissions.Permissions.setupPermissions(Permiss
    at com.nijikokun.bukkit.Permissions.Permissions.onEnable(Permissions.jav
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManage
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.c(
    at net.minecraft.server.MinecraftServer.d(
    2011-01-31 02:24:23 [INFO] Done! For help, type "help" or "?"[/CODE]

    anyone know this error?
    server work but
    plugin half load
    half disabled..
    but manually plugin reload is work..

    hot to fix this error?
  29. Offline


    At this time there is no way to male player independant colors or prefixes, only groups.
    --- merged: Jan 30, 2011 5:33 PM ---
    Have you updated craftbukkit and WorldEdit since yesterday?
  30. Offline


    @hyperch I dont want to give them all of the worldedit commands i only want to give them the super picaxe they shoudn't be allowed to use jumpto etc
  31. Offline


    thallo: tried - '//wand' ?
    --- merged: Jan 30, 2011 5:37 PM ---
    make a group for each player :)
Thread Status:
Not open for further replies.

Share This Page