[ADMN/GEN]AdminCmd 7.3.5-time, give, tp, repair,kill, warp,weather,afk,OpenInv [1.5.1]

Discussion in 'Archived: Plugin Releases' started by Dark_Balor, Apr 1, 2011.

  1. Offline


    AdminCmd - Fork of PlgEssentials:
    [​IMG] Website : www.admincmd.com
    [​IMG] Wiki : http://wiki.admincmd.com
    [​IMG] BugTracker : http://bug.admincmd.com
    [​IMG] Downloads : HERE
    [​IMG] GitHub : http://github.com/Belphemur/AdminCmd

    AdminCMD is a powerful plug-in that brings you commands that can give you total management over your server. Featuring the most widely used commands in Bukkit server management such as: inventory management, banishment of bad players, limitation to teleporting, setting spawn and home way points, and much, much more! Blockface approved and rated as one of the best plug-in by server owners.
    Unleash the power of Bukkit!

    For the blog : www.admincmd.com
  2. Offline


    This is some god stuffs :)
  3. Offline


    I just need the villagers, cause i can't trust the mod with other creatures.
    i personally just switched into creative mode, but i can't let him know that this exists, or he wants the persmissions for it too ^^
  4. Offline


    Release the 5.12 for 1.1-R6

    ONLY UPDATE IF YOU HAVE THE LAST BUKKIT RB else you can still use the 'old' dev build that is still compatible with the older version (1.1R1 minimum).

    I uploaded the wrong File ...

    Now it's corrected, the download link is for the 5.12 for 1.1-R6 (last RB now)
    This version works, for now, with the 1.2-SNAPSHOT

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  5. Offline


    Will try it. Looks nice ;)


    Tested. Some Plugins don't seem to like AdminCMD.
    I have AuthME, bChatManager, bPermissions, LogBlock, LWC, Multiverse-Core, Multiverse-Portals, WorldEdit & WorldGuard installed.
    Log : http://forums.bukkit.org/attachments/server-txt.8683/

    Attached Files:

  6. Offline


    2012-03-04 19:36:44 [INFO] This server is running CraftBukkit version git-Bukkit-1.1-R4-b1938jnks (MC: 1.1) (Implementing API version 1.1-R4)

    The last version of AdminCmd only works from the 1.1-R6 (last RB)

    To avoid that message you can disable the help for other plugins in the configuration file.
  7. Offline


    is there a way to set the max amount of homes using permissions?

    EDIT: sorry, just read your post. gonna try that now
  8. Offline


    Hey I was wondering how can I change the permissions because I want to change the permissions for /warp I want eveyone to be able to use them :)
  9. Please refer on the setup of your PermissionPlugin. In our wiki you will find all the needed permission nodes you have to set in your permission plugin!
  10. Dark_Balor Lathanael

    Using version 5.12.1-SNAPSHOT (BUILD 03.03.2012 @ 19:11:09) and CB2037, it would seem that /home tends to place you one block down into the ground occasionally. Dont know if its due to AdminCmd or bukkit tho.
  11. Offline


    Yeah it worked with the other Plugins but what about the Entity-Errors ?
  12. Offline


    Disabling the command /moblimit should do the trick.

    Sorken : Strange since we didn't changed the code used to teleport.
  13. Offline


    i got a question :
    How do i make commands like /sethome /help /warp and more aviable for all users (non-adms)
    thank you for help
  14. Use one of the various PermissionPlugins around ;)

    • PermissionsBukkit
    • PermissionsEx
    • bPermissions
  15. Offline


    could it be, that the newest admincmd isn't working with the newest pex? ._.
    my members aren't able to use any command of admincmd but they have the permissions for that
  16. Normally not. Only if PEX dropped the SuperPerms support! You can open a ticket if your problem exists for a longer time!
  17. Offline


    oah sorry, was my fault! i took an old configuration file for pex and overwrited it - so pex doesn't load
    my fault, sorry again D;
  18. Lathanael Dark_Balor

    Is this PEX or AdminCmd related?

    22:17:45 [INFO] Ramb00 lost connection: disconnect.quitting
    22:17:45 [INFO] Connection reset
    22:17:45 [SEVERE] java.util.ConcurrentModificationException
    22:17:45 [SEVERE] at java.util.LinkedHashMap$LinkedHashIterator.nextEntry(Unknown Source)
    22:17:45 [SEVERE] at java.util.LinkedHashMap$EntryIterator.next(Unknown Source)
    22:17:45 [SEVERE] at java.util.LinkedHashMap$EntryIterator.next(Unknown Source)
    22:17:45 [SEVERE] at org.bukkit.configuration.MemorySection.mapChildrenValues(MemorySection.java:947)
    22:17:45 [SEVERE] at org.bukkit.configuration.MemorySection.getValues(MemorySection.java:97)
    22:17:45 [SEVERE] at ru.tehkode.permissions.backends.file.FileEntity.getNode(FileEntity.java:57)
    22:17:45 [SEVERE] at ru.tehkode.permissions.backends.file.FileEntity.<init>(FileEntity.java:41)
    22:17:45 [SEVERE] at ru.tehkode.permissions.backends.file.FileUser.<init>(FileUser.java:39)
    22:17:45 [SEVERE] at ru.tehkode.permissions.backends.FileBackend.getUser(FileBackend.java:126)
    22:17:45 [SEVERE] at ru.tehkode.permissions.PermissionManager.getUser(PermissionManager.java:113)
    22:17:45 [SEVERE] at ru.tehkode.permissions.PermissionManager.getUser(PermissionManager.java:132)
    22:17:45 [SEVERE] at be.Balor.Manager.Permissions.Plugins.PermissionsEx.getPermissionLimit(PermissionsEx.java:124)
    22:17:45 [SEVERE] at be.Balor.Manager.Permissions.PermissionManager.getPermissionLimit(PermissionManager.java:65)
    22:17:45 [SEVERE] at be.Balor.bukkit.AdminCmd.ACHelper.getLimit(ACHelper.java:516)
    22:17:45 [SEVERE] at be.Balor.Listeners.ACPlayerListener$2.run(ACPlayerListener.java:266)
    22:17:45 [SEVERE] at org.bukkit.craftbukkit.scheduler.CraftWorker.run(CraftWorker.java:34)
    22:17:45 [SEVERE] at java.lang.Thread.run(Unknown Source)
  19. Offline


    It's AdminCmd related ...

    An optimization that seems to be not working some times --''
    I'll fix that.
  20. Dark_Balor
    /mobkill Snowman - pleeeaaase :)

    Uh.. and i cant find any dev later then 10/3. Not enough time to focus on plugin?

    No dev builds makes me a sad puppy :(
  21. Offline


    is there a way to convert essentials userfiles to admincmd userfiles?
  22. Offline


    Well right know school is taking a lot of my time (and Mass Effect didn't helped ^^')
    Maybe I'll have more time, but you know coding at school, then coding here ... Hopefully Lathanael is helping a lot :)

    biokemisten : not for now.
    biokemisten likes this.
  23. Offline


    Okay.. :)
  24. It is on our ToDo list for some time now, just to much to do to actually look into it sry :(
  25. Lathanael Dark_Balor
    Thanks for the new dev version, will give it a good testing :)

    Edit: I seem to be having a issue where after a random amount of hours (~12) the cpu usage spikes and then /home, /spawn and /tp stops working. Teleporting with commands from other plugins still seem to work, such as kFeatherTeleport and Multiverse. I dont know if AdminCmd is the cause or not but it seems most effected by it.

    Edit2: Mobkill should take parameters like this, /mobkill <name> <world> and if world is omitted from player then current world should be used and if omitted from console then all worlds should be used. As it is now you cant clean an individual world from console. It sould also take the keyworld all, snowman villager and whatever name xporb uses.

    Edit3: More candy... CB 2113 and AdminCmd: 5.12.1-SNAPSHOT (BUILD 21.03.2012)

    19:57:33 [INFO] sorkmine tried to use command /ban Bryan_harris01 Excessive use of caps on chat
    19:57:33 [SEVERE] Could not pass event PlayerQuitEvent to AdminCmd
            at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:303)
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:459)
            at net.minecraft.server.ServerConfigurationManager.disconnect(ServerConfigurationManager.java:178)
            at net.minecraft.server.NetServerHandler.disconnect(NetServerHandler.java:158)
            at org.bukkit.craftbukkit.entity.CraftPlayer.kickPlayer(CraftPlayer.java:220)
            at be.Balor.Manager.Commands.Player.BanPlayer$2.run(BanPlayer.java:118)
            at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:126)
            at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:520)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:452)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:490)
    Caused by: java.util.ConcurrentModificationException
            at java.util.LinkedHashMap$LinkedHashIterator.nextEntry(Unknown Source)
            at java.util.LinkedHashMap$EntryIterator.next(Unknown Source)
            at java.util.LinkedHashMap$EntryIterator.next(Unknown Source)
            at org.bukkit.configuration.MemorySection.mapChildrenValues(MemorySection.java:947)
            at org.bukkit.configuration.MemorySection.getValues(MemorySection.java:97)
            at ru.tehkode.permissions.backends.file.FileEntity.getNode(FileEntity.java:57)
            at ru.tehkode.permissions.backends.file.FileEntity.<init>(FileEntity.java:41)
            at ru.tehkode.permissions.backends.file.FileUser.<init>(FileUser.java:39)
            at ru.tehkode.permissions.backends.FileBackend.getUser(FileBackend.java:126)
            at ru.tehkode.permissions.PermissionManager.getUser(PermissionManager.java:113)
            at ru.tehkode.permissions.PermissionManager.getUser(PermissionManager.java:132)
            at be.Balor.Manager.Permissions.Plugins.PermissionsEx.getPrefix(PermissionsEx.java:139)
            at be.Balor.Manager.Permissions.PermissionManager.getPrefix(PermissionManager.java:69)
            at be.Balor.Tools.Utils.getPrefix(Utils.java:639)
            at be.Balor.Tools.Utils.getPlayerName(Utils.java:606)
            at be.Balor.Tools.Utils.getPlayerName(Utils.java:592)
            at be.Balor.Listeners.ACPlayerListener.onPlayerQuit(ACPlayerListener.java:275)
            at sun.reflect.GeneratedMethodAccessor212.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:301)
            ... 10 more
  26. Offline


    Should be corrected in the last Dev version : 5.12.1-SNAPSHOT (BUILD 25.03.2012 @ 22:57:09)
  27. Offline


    Can I have the log ?

    because It can't be AdminCmd ... we just changed how the plugin was using the teleport, but it's using the same way as bukkit...
  28. There are no errors in the log, it just happens. It appeared in 1.2.3 and ive tried just about every dev build of the server since then, ive already updated all other plugins. I even went so far as to replaced two simpler plugins with versions of my own to try and get rid of it. I also tried changing startup parameters and nothing has worked. So i have no idea as to whats causing it, aside from AdminCmd commands stop working at the same time. I can try checking to see if other AdminCmd command fail the next time. Or if its just the teleporting ones. Note, that the teleporting works fine until the cpu spikes.
  29. Offline


    is it happening with the 5.12 too ? or only with the dev build ?

    is the command /air used a lot ? because it can cause some problems.
  30. I havent tried 5.12 I will test that now. And /air is rarely used. Sometimes not at all between fails.

    During spike:
    /mob, /item and /more will also not work.
    /aversion does work.

Share This Page