Inactive [ADMN/DEV] PermissionsEx (PEX) v1.19.5 - Tomorrow is Today! [1.4.6-R0.1]

Discussion in 'Inactive/Unsupported Plugins' started by t3hk0d3, May 21, 2011.

  1. Offline


    Version: 1.19.5


    PermissionsEx (PEX) is a new permissions plugin, based on Permissions ideas and supports all of its features. But PEX is more! It offers different backends, powerful ingame management, fine grained restrictions for world modification.


    Current features
    1. Bukkit Permissions (SuperPerms) compatible.
    2. Several backend support. Currently bundled backends is File (YAML) and SQL (MySQL, SQLite). Also it's possible to add your own.
    3. YAML backend, with new, fully rethinked, config schema. Now all user, groups and their permissions are stored in one file - permission.yml. BTW file name is adjustable too.
    4. SQL backend, most delicious. Currently MySQL and SQLite supported, but other DB (like Postgre) are possible too. PEX deploys the DB scheme (tables and initial data) automatically. This means, that you only need to provide data on how to connect to the db, everything else PEX will handle by itself.
    5. Flexible architecture and API - you can change a lot programmatically.
    6. Compatibility layer with TheYeti's Permissions (2.7.4) (as a separate part of the plugin). In most cases plugins, which use Permissions, will alsowork with PEX also.
    7. Rich chat/console command interface. You can do almost everything ingame. Command list below.
    8. Modifyworld - Embedded restrictions mechanism (we call it "modifyworld"), which provides the possibility to control players abilities, such as destroying/placing blocks, riding carts/boats or even getting spotted by mobs and much more. Disabled by default.
    9. Multigroup inheritance. User, as well as Group, can be member of several groups. And inherit their permissions, options and prefix/suffix.
    10. Permissions based upon Regular Expressions. This mean you can use regular expressions. Example: modifyworld.blocks.(destroy|place).(3|12) - this permission allow place or destroy only sand (12) or dirt (3) blocks. There is still limitation on dot usage in your regexps - dots are escaped by default.
    11. Multiworld permissions. Just don't specify world and permission would work in any world.
    12. Multiworld inheritance. You can inherit different groups in different worlds.
    13. Easy migration from Permissions 2.x. Converter for both YAML and SQL are embedded into PermissionsCompat. Just use simple instruction.
    14. Perfomance friendly. Low-level caching helps alot when you have 100+ online users :)
    15. Promotional/Demotional system. You can assign ranks to groups and promote/demote users to higher/lower ranked group.
    16. World-inheritance - permissions/option of one world can be inherited by another world.
    17. Timed Permissions - you can give user permission only for some amount of time.
    18. Chat Manager - small chat plugin, bundled with PEX. With prefixes/suffiex and colors. Check wiki for more details.


    Basic setup tutorial (Thanks to lycano)

    Nice tutorial made by Bennetman

    Stable version

    Development version (mostly stable) - always lastest dev build.



    Maven Repository

    Join us on #permissionsex, Feel free to ask any related questions.

    Tools !NEW!
    Pex Auto-Setup Tool - MySQL and FlatFile !

    Show Changelog (open)
    Proper intervals for timed commands (both group/permissions management), without pesky seconds calculations (like /pex user t3hk0d3 timed add cool.permission 10days)
    1.4.6 compatibility.

    Built for Bukkit 1.4.2-R0.1
    Added inventory permissions (modifyworld.items.put/take.<item>.of.<chest>)
    Added item hold permission (modifyworld.items.hold.<item>)
    Sdded monster egg spawn permission (modifyworld.spawn.<creature>)
    Few other minor fixes
    Modifyworld improvements (configurable messages, now independent from PEX)
    /pex help command
    Minor improvements and bugfixes
    New modifyworld permissions
    Some bugfixes
    Bugfix release
    Bukkit R6 compatible.
    Several bugfixes!
    Permissions now case-insensetive.
    Users logging and cleanup feature.
    Non-inheriting nodes feature.
    Several Bugfixes.
    PermissionsCompat is finally remove from default bundle.
    User/group specific management permissions (
    Fixed some superperms compatibility issues
    Fixed several bugs
    SuperPerms compatbility bridge were rewritten - no lags anymore and now with debug output (now you can view superperms checks).
    Numerous of bugs were fixed (Thanks you guys for reporting them)
    Modifyworld were improved (modifyworld.item.use)
    Compatiblity for 1317+
    Fixed perfomance issues with SuperPerms (if you still experience they try to disable "raw-permissions" in config.yml)
    Fixed issue with prefix inheritance
    Improved Options mechanism.
    Auto saving new users feature, disabled by default.
    SuperPerms bridge improved - more permissions supported by wildcards.
    File backend dumping now fully functional. SQL dumping is still bogus (do not dump world-specific inheritance and prefixes), will be fixed soon.
    Many bugfixes and minor improvements.
    Superperms (BukkitPerms) support
    Multiworld inheritance and prefixes/suffixes
    Groups weighting
    ChatManager, chat plugin which bundled with PEX.
    Modifyworld now separate plugin, but still bundled with PEX.
    API changed slightly, CustomEvents (PermissionsEntityEvent, PermissionsSystemEvent) introduced.
    Many lesser improvements and tons of bugfixes.
    API get slightly improved
    Ranking ladders.
    User/group name case-insensetivity.
    Timed permissions.
    Modifyworld rules are get improved.
    Tons of minor improvements and bugfixes.
    Many bugfixes and improvements.
    MySQL connection stability improved - reconnection mechanism.
    Promotional/Demotional system.
    Perfomance improvement, with new low-level caching system (thx Joy)
    Modifyworld improved.
    Many lesser improvements and bugfixes.
    New p2compat backend, for easy migration from Permissions 2.x to PEX.
    Users/Groups dumping (pex dump <backend> <file>).
    New commands pex promote/demote. Actually this is just aliases for "pex user group set/remove"
    Few bugfixes.
    Players now can be informed about changes (has been added to group, changed permission/option). Disabled by default - set "permissions.informplayers.changes" to "true"
    Config node "permissions.verbose", which responsible for player informing about modifyworld restrictions has been renamed to "permissions.infromplayers.modifyworld".
    Autocomplete has been improved.
    New command "pex config <node> [value]". This command help to manipulate configuration file (config.yml) from console/chat interface.
    Many bugfixes.
    Autocomplete for users (taken from registred users and online users) and groups names.
    New command for user removing (pex user <user> delete)
    Fixed several nasty bugs. Thanks for bugreports!
    Compatibility layer loading order issue fixed. Now most of plugins should work.
    Tested with new CB 803 build.
    Regular expression permissions support.
    Newer permissions now added above (bugfix).
    Several bugfixes.
    Initial public release.
    BRampersad, grid21, MrRazull and 71 others like this.
  2. Yes there is. Put a dash in front of the node.

    -bukkit.command.kick will deny access to bukkit's built-in kick command
  3. Offline


    I have a problem with the modifyworld.
    I want new users not be able to chat.
    So i didn't gave them
    They have totaly no modifyworld permission.
    But when i talk with that rank players can still see me chatting.
    I get a message that i'm not allowed but ppl can still see it.
    I hope you can fix this else i will need another plugin for this thats kinda stupid.
  4. I'm not sure I understand the question/problem, but prevents players from using the in-game chat, it doesn't stop them from seeing global chat.

    As for the message you are getting, without knowing the exact message you are getting, I would almost guess that something else is producing the message. To verify, we would have to know the plugins you are running and probably see your server.log starting at the bukkit version line down to the server is ready line.
  5. Offline


    thank god.. thank u
  6. Offline


    Yeah you got it wrong,

    they may see the global chat.
    But they CAN chat like all others
    while they dont have that permissions.
    They see a message that they dont have permissions but the message still get sent to the chat.
    Hopeful you see it now.
  7. Offline


    I have one problem, I don't know why my users doesn't have access to teleport, maybe there is special permissions for build, help me please.
  8. Offline


    hey, pluging mostly works great on my server but something.
    everyone ( new members ) can build and use everytink. i want them they just can use the chat.
    they can login and grief.
    my .yml file is just like this.
            default: true
    can you help me ?
  9. Offline


    Whenever I start my server or check my permissions.yml... i get an error showing up saying

    mapping values are not allowed here
    in "<unicode string>", line 58, column 16:
    I have toyed with it and cant fix it...
    Here are my server stats
    I am running essentials, Commandbook, NoCheat, SetRankPEX, ChestShop, iConomy, LWC, Chatlogging 2.0, Spout, Vanishnopacket, World edit, World guard, and Mob Disgise
    my version of permissions is 1.17
    i am running bukkit build #1597

    please help me!!!
  10. Offline


    Please update for craftbukkit-1.0.1-R1 :( Got some bugs... sometimes i can build, sometimes not -.-
    btw. what is the command/Permission for kick? i want to have "user, mods and admins .. " mods = just can kick
  11. Offline


    Yes i didnt have the permissions.jar
  12. Offline


    How the balls do i convert My permissions.yml to an Importable sql file.
    I set all my groups and users up in the .yml file then enabled SQL but it didn't auto add.
  13. Offline


    I was wondering something. I started useing the built in chat manager so people can see which world and which rank the person talking is, which i do like for that, but while useing essentials and the /nick command, i cant find a way for that nick name to show up with the custom message format. Is there anyway to make chat manager use the nicknames?
  14. Does the * permission node work?
  15. Offline


  16. Offline


    why do i not get the kit "woodtools" as a knight but i do as a peasent?
    - King
    - Apprentice
    - Peasant
    - Peasant
    - Peasant
    - Peasant
    - Knight
    default: true
    rank: '5'
    build: false
    prefix: '&7Peasant &d[&6'
    suffix: '&d]'
    - commandbook.kit.list
    - commandbook.kit.woodtools
    - commandbook.rules
    - commandbook.msg
    - lwc.deny
    - commandbook.who
    - commandbook.motd
    default: false
    rank: '4'
    build: true
    - Peasant
    prefix: '&7Citizen &d[&f'
    suffix: '&d]'
    - custom.worldguard.knight.tnt
    - custom.worldguard.citizen.*
    - commandbook.kit.stonetools
    - commandbook.time.check
    - commandbook.teleport
    - commandbook.home.teleport
    - commandbook.home.teleport
    - commandbook.home.teleport
    - commandbook.warp.teleport.other
    - commandbook.home.set
    - commandbook.whereami
    - commandbook.clear
    - commandbook.slap
    - commandbook.reload
    - commandbook.intro
    - commandbook.midi
    - worldguard.ungod
    - iConomy.access.*
    - iConomy.rank
    - multiverse.access.NAME
    - worldedit.selection.*
    - mcmmo.commands.ptp
    - mcmmo.ability.*
    - mcmmo.skills.*
    - mcmmo.regeneration
    - mcmmo.commands.whois
    - mcmmo.commands.myspawn
    - mcmmo.commands.setmyspawn
    - mcmmo.commands.ability
    - mcmmo.item.chimaerawing
    - mcmmo.commands.ability
    default: false
    rank: '3'
    build: true
    - Citizen
    prefix: '&7Knight &d[&2'
    suffix: '&d]'
    - custom.worldguard.knight.*
    - bukkit.command.reload
    - commandbook.qgive
    - commandbook.qgive.infinite
    - commandbook.qgive
    - commandbook.qgive.infinite
    - commandbook.more
    - commandbook.more.infinite
    - commandbook.time.player
    - commandbook.time.player.check
    - commandbook.spawnmob
    - commandbook.home.teleport.other
    - commandbook.rocket
    - commandbook.shock
    - commandbook.thor
    - commandbook.gamemode
    - commandbook.kick
    - worldguard.region.claim
    - lwc.protect
    - iConomy.list
    - iConomy.payment.*
    - multiverse.teleport.self.NAME
    - multiverse.core.*
    - craftbook.mech.bridge
    - craftbook.mech.gate
    - worldedit.wand
    - worldedit.fixwater
    - worldedit.fixlava
    - worldguard.slay
    - mcmmo.item.chimaerawing
    default: false
    rank: '2'
    build: true
    - Knight
    prefix: '&7Sorcerer &d[&1'
    suffix: '&d]'
    - commandbook.give.*
    - commandbook.kit.*
    - worldedit.*
    - commandbook.kit.textiles
    - custom.worldguard.sorcerer.*
    default: false
    rank: '1'
    build: true
    - Knight
    prefix: '&7Apprentice &d[&5'
    suffix: '&d]'
    - custom.worldguard.tnt
    - commandbook.time.lock
    - commandbook.time
    - commandbook.time.player.other
    - commandbook.spawnmob.many
    - commandbook.teleport.other
    - commandbook.locations.coords
    - commandbook.teleport.other
    - commandbook.home.teleport.other
    - commandbook.home.set.other
    - commandbook.warp.set
    - commandbook.say
    - commandbook.mute
    - commandbook.clear.other
    - commandbook.barrage
    - commandbook.thor
    - commandbook.gamemode.other
    - commandbook.bans.ban
    - commandbook.bans.unban
    - worldguard.god
    - worldguard.god.other
    - worldguard.ungod.other
    - worldguard.slay.other
    - worldguard.stack
    - worldguard.stack.illegitimate
    - worldguard.halt-activity.*
    - worldguard.region.*
    - worldedit.listchunks
    - worldedit.clipboard.*
    - lwc.mod
    - ChestShop.mod
    - multiverse.core.spawn.*
    - craftbook.mech.*
    - worldedit.superpickaxe.*
    - bukkit.command.*
    - custom.worldguard.apprentice.*
    default: false
    rank: '0'
    build: true
    prefix: '&7King &d[&4'
    suffix: '&d]'
    - '*'
    - world
  17. Offline


    Is it possible to reload the permissions config? because as of now I have to manually /reload which crashes sometimes D:

    EDIT: Nevermind, AWESOME plugin!!
  18. Can you post/link your permissions and your server.log, starting at the bukkit version line?

    What teleport command from which plugin? Several plugins implement teleport with different commands and different permission nodes.

    Can you post/link your entire permissions and your server.log, starting at the bukkit version line?

    Yes, I use it myself.

    My guess is that you have another plugin blocking it or you are trying to build in the spawn area. I just tried your permissions on a test server and I was able to build with a user in the default group.

    I'm afraid I can not tell as you didn't use code tags (the {}# icon in the editor) to preserve the permissions file formatting, which makes all the difference at times.

    I believe this earlier post will help you with this. :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Nov 10, 2018
  19. Offline


    allowOps: true
    Does not work, operators still don't have all permissions.

    And yes, i did reload the server.
  20. It works for me. :) Are the players in the ops.txt?
  21. Offline


    they are, for example:
    I used reload command and afterwards it told me that i have no permission to do so.

    This actually happened, so the server must have recognised me as operator before.;)

    Are there any known plugin conflicts?
    Im using:
    Hawkeye (MySQL and Webinterface)
    Wormhole xtreme
    iConomy (MySQL)

    All Plugins worked well before and still do except the no permissions issue i'm experiencing as well as all the other operators.
    I would say i just messed up the file but i just changed it from false to true like i did many times in many other config files. :/
    Means in fact it's one of the smallest changes in made in config files so far considering the SQL-stuff. Im using Notepad++ so it shouldn't break anything if it didn't break the other files i've changed so far.

    Meeeeeeh, how embarassing...
    It works, i didnt look up the log and got what i deserved, my mistake, i messed up another config file of permissionsex, i was focusing to hard on the wrong file. >.<

    Sorry for bothering you.
  22. None of those listed ring any bells as known problem children. In fact, I use Worldedit and Hawkeye myself. And files just don't go bad... well, unless you have hardware problems or are using a microsoft product to run your server... ;)

    However, you stated that it did work until you used /reload. I would strongly suggest not using that. There is actually a petition to remove the command as it can cause more problems than it solves, as show above with your post.:)

    I stopped using it as well because of random weirdness I would see if I used it....


    Ah, here it is:

    Anymore, I call all bets are off if /reload is involved. It's just not safe IMO.
  23. Offline


    Nope, look at my edit, reload works fine for me(and always did, maybe im just extremly lucky or the bukkitdevs solved the problems).

    It was all my mistake(and a stupid one) to begin with. There was an obvious error in the log regarding another config file of permissionsex. I was just to blind to see. (Oh and not to forget: i still hate the yaml syntax, why the h.... couldn't they just use {} like everyone else?)

    Well anyways, thank you for your patience and sorry for wasting your time.

    But something else:
    Is there a way to change the Loglevel of your plugin?
    would be nice to set it to "warning", so the log file doesn't grow that fast.
  24. Offline


    :) Very good plugin working well :D
  25. Offline


    Can someone send me an example of a permissions 2.x yml? Because i want to migrate from permissions 3.x. But i keep getting errors and i think i'm doing the converting wrong.
  26. Nice Plugin! Better as Permissions 3x! I use it the next time. Many Plugins are compatible (all xD). I hope you make more Versions from the Plugin
  27. Offline


    does ' * ' give you all commands in all plugins?
  28. Offline


    Yes, it does. But there are some plugins for it can be bad. For example, with Vanish you will always appear invisible. You must disallow certain nodes with "- -permission".
  29. Offline


  30. Offline


    Hey guys im very new here and are eager to learn more about bukkit but i have a tiny problem i think it may link back to PEX somehow, heres what im encountering.

     [SEVERE] Could not pass event PLAYER_JOIN to Vault
    01:42 AM [SEVERE] Could not pass event PLAYER_JOIN to Essentials
    01:42 AM [SEVERE] Could not pass event PLAYER_JOIN to EssentialsGeoIP
    01:42 AM [SEVERE] Could not pass event PLAYER_JOIN to EssentialsXMPP
    01:42 AM [SEVERE] Could not pass event PLAYER_TELEPORT to Essentials
    01:42 AM [SEVERE] Could not pass event PLAYER_RESPAWN to EssentialsSpawn
    01:43 AM [INFO] [PLAYER_COMMAND] guy: /help
    01:43 AM [SEVERE] Command help failed:
    01:43 AM [INFO] [PLAYER_COMMAND] guy: /helpop
    01:43 AM [SEVERE] Command helpop failed:
    01:43 AM [SEVERE] Could not pass event PLAYER_INTERACT to EssentialsProtect
    01:43 AM [SEVERE] Could not pass event BLOCK_BREAK to EssentialsProtect
    01:43 AM [SEVERE] Could not pass event PLAYER_INTERACT to EssentialsProtect
    01:43 AM [SEVERE] Could not pass event BLOCK_BREAK to EssentialsProtect
    01:43 AM [SEVERE] Could not pass event PLAYER_INTERACT to EssentialsProtect
    01:43 AM [SEVERE] Could not pass event BLOCK_BREAK to EssentialsProtect
    01:43 AM [SEVERE] Could not pass event PLAYER_INTERACT to EssentialsProtect
    01:43 AM [SEVERE] Could not pass event PLAYER_INTERACT to EssentialsProtect
    01:43 AM [SEVERE] Could not pass event PLAYER_INTERACT to EssentialsProtect
    01:43 AM [SEVERE] Could not pass event PLAYER_INTERACT to EssentialsProtect
    01:43 AM [SEVERE] java.lang.RuntimeException: Default user group is not defined. Please select one using the "default: true" property
    01:43 AM [SEVERE] at ru.tehkode.permissions.backends.FileBackend.getDefaultGroup(
    01:43 AM [SEVERE] at ru.tehkode.permissions.PermissionManager.getDefaultGroup(
    01:43 AM [SEVERE] at ru.tehkode.permissions.PermissionManager.getDefaultGroup(
    01:43 AM [SEVERE] at ru.tehkode.permissions.PermissionUser.getGroups(
    01:43 AM [SEVERE] at ru.tehkode.permissions.PermissionUser.getInheritedPermissions(
    01:43 AM [SEVERE] at ru.tehkode.permissions.PermissionUser.getPermissions(
    01:43 AM [SEVERE] at ru.tehkode.permissions.PermissionEntity.getMatchingExpression(
    01:43 AM [SEVERE] at ru.tehkode.permissions.PermissionUser.getMatchingExpression(
    01:43 AM [SEVERE] at ru.tehkode.permissions.bukkit.superperms.PermissiblePEX.hasPermission(
    01:43 AM [SEVERE] at org.bukkit.craftbukkit.entity.CraftHumanEntity.hasPermission(
    01:43 AM [SEVERE] at daredevil.ExpMiner.ExpMinerBlockListener.onBlockBreak(
    01:43 AM [SEVERE] at$40.execute(
    01:43 AM [SEVERE] at org.bukkit.plugin.RegisteredListener.callEvent(
    01:43 AM [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(
    01:43 AM [SEVERE] at net.minecraft.server.ItemInWorldManager.c(
    01:43 AM [SEVERE] at net.minecraft.server.ItemInWorldManager.c(
    01:43 AM [SEVERE] at net.minecraft.server.EntityPlayer.w_(
    01:43 AM [SEVERE] at net.minecraft.server.World.entityJoinedWorld(
    01:43 AM [SEVERE] at net.minecraft.server.WorldServer.entityJoinedWorld(
    01:43 AM [SEVERE] at net.minecraft.server.World.playerJoinedWorld(
    01:43 AM [SEVERE] at net.minecraft.server.World.tickEntities(
    01:43 AM [SEVERE] at net.minecraft.server.MinecraftServer.w(
    01:43 AM [SEVERE] at
    01:43 AM [SEVERE] at
    01:43 AM [SEVERE] Could not pass event BLOCK_BREAK to EssentialsProtect
    01:43 AM [SEVERE] Could not pass event PLAYER_INTERACT to EssentialsProtect
    01:44 AM [SEVERE] java.lang.RuntimeException: Default user group is not defined. Please select one using the "default: true" property
    01:44 AM [SEVERE] at ru.tehkode.permissions.backends.FileBackend.getDefaultGroup(
    01:44 AM [SEVERE] at ru.tehkode.permissions.PermissionManager.getDefaultGroup(
    01:44 AM [SEVERE] at ru.tehkode.permissions.PermissionManager.getDefaultGroup(
    01:44 AM [SEVERE] at ru.tehkode.permissions.PermissionUser.getGroups(
    01:44 AM [SEVERE] at ru.tehkode.permissions.PermissionUser.getInheritedPermissions(
    01:44 AM [SEVERE] at ru.tehkode.permissions.PermissionUser.getPermissions(
    01:44 AM [SEVERE] at ru.tehkode.permissions.PermissionEntity.getMatchingExpression(
    01:44 AM [SEVERE] at ru.tehkode.permissions.PermissionUser.getMatchingExpression(
    01:44 AM [SEVERE] at ru.tehkode.permissions.bukkit.superperms.PermissiblePEX.hasPermission(
    01:44 AM [SEVERE] at org.bukkit.craftbukkit.entity.CraftHumanEntity.hasPermission(
    01:44 AM [SEVERE] at daredevil.ExpMiner.ExpMinerBlockListener.onBlockBreak(
    01:44 AM [SEVERE] at$40.execute(
    01:44 AM [SEVERE] at org.bukkit.plugin.RegisteredListener.callEvent(
    01:44 AM [SEVERE] at org.bukkit.plugin.SimplePluginManager.callEvent(
    01:44 AM [SEVERE] at net.minecraft.server.ItemInWorldManager.c(
    01:44 AM [SEVERE] at net.minecraft.server.ItemInWorldManager.c(
    01:44 AM [SEVERE] at net.minecraft.server.EntityPlayer.w_(
    01:44 AM [SEVERE] at net.minecraft.server.World.entityJoinedWorld(
    01:44 AM [SEVERE] at net.minecraft.server.WorldServer.entityJoinedWorld(
    01:44 AM [SEVERE] at net.minecraft.server.World.playerJoinedWorld(
    01:44 AM [SEVERE] at net.minecraft.server.World.tickEntities(
    01:44 AM [SEVERE] at net.minecraft.server.MinecraftServer.w(
    01:44 AM [SEVERE] at
    01:44 AM [SEVERE] at
    01:44 AM [SEVERE] Could not pass event BLOCK_BREAK to EssentialsProtect
    BTW: how do you form a default group.. ive been looking and nothing is helping
  31. Offline


    Might it conflict with the instalation of some plugins? (Like world guard. It doesnt install for me...)

Share This Page