Inactive [ADMN/DEV] PermissionsEx (PEX) v1.19.5 - Tomorrow is Today! [1.4.6-R0.1]

Discussion in 'Inactive/Unsupported Plugins' started by t3hk0d3, May 21, 2011.

  1. Offline


    Version: 1.19.5


    PermissionsEx (PEX) is a new permissions plugin, based on Permissions ideas and supports all of its features. But PEX is more! It offers different backends, powerful ingame management, fine grained restrictions for world modification.


    Current features
    1. Bukkit Permissions (SuperPerms) compatible.
    2. Several backend support. Currently bundled backends is File (YAML) and SQL (MySQL, SQLite). Also it's possible to add your own.
    3. YAML backend, with new, fully rethinked, config schema. Now all user, groups and their permissions are stored in one file - permission.yml. BTW file name is adjustable too.
    4. SQL backend, most delicious. Currently MySQL and SQLite supported, but other DB (like Postgre) are possible too. PEX deploys the DB scheme (tables and initial data) automatically. This means, that you only need to provide data on how to connect to the db, everything else PEX will handle by itself.
    5. Flexible architecture and API - you can change a lot programmatically.
    6. Compatibility layer with TheYeti's Permissions (2.7.4) (as a separate part of the plugin). In most cases plugins, which use Permissions, will alsowork with PEX also.
    7. Rich chat/console command interface. You can do almost everything ingame. Command list below.
    8. Modifyworld - Embedded restrictions mechanism (we call it "modifyworld"), which provides the possibility to control players abilities, such as destroying/placing blocks, riding carts/boats or even getting spotted by mobs and much more. Disabled by default.
    9. Multigroup inheritance. User, as well as Group, can be member of several groups. And inherit their permissions, options and prefix/suffix.
    10. Permissions based upon Regular Expressions. This mean you can use regular expressions. Example: modifyworld.blocks.(destroy|place).(3|12) - this permission allow place or destroy only sand (12) or dirt (3) blocks. There is still limitation on dot usage in your regexps - dots are escaped by default.
    11. Multiworld permissions. Just don't specify world and permission would work in any world.
    12. Multiworld inheritance. You can inherit different groups in different worlds.
    13. Easy migration from Permissions 2.x. Converter for both YAML and SQL are embedded into PermissionsCompat. Just use simple instruction.
    14. Perfomance friendly. Low-level caching helps alot when you have 100+ online users :)
    15. Promotional/Demotional system. You can assign ranks to groups and promote/demote users to higher/lower ranked group.
    16. World-inheritance - permissions/option of one world can be inherited by another world.
    17. Timed Permissions - you can give user permission only for some amount of time.
    18. Chat Manager - small chat plugin, bundled with PEX. With prefixes/suffiex and colors. Check wiki for more details.


    Basic setup tutorial (Thanks to lycano)

    Nice tutorial made by Bennetman

    Stable version

    Development version (mostly stable) - always lastest dev build.



    Maven Repository

    Join us on #permissionsex, Feel free to ask any related questions.

    Tools !NEW!
    Pex Auto-Setup Tool - MySQL and FlatFile !

    Show Changelog (open)
    Proper intervals for timed commands (both group/permissions management), without pesky seconds calculations (like /pex user t3hk0d3 timed add cool.permission 10days)
    1.4.6 compatibility.

    Built for Bukkit 1.4.2-R0.1
    Added inventory permissions (modifyworld.items.put/take.<item>.of.<chest>)
    Added item hold permission (modifyworld.items.hold.<item>)
    Sdded monster egg spawn permission (modifyworld.spawn.<creature>)
    Few other minor fixes
    Modifyworld improvements (configurable messages, now independent from PEX)
    /pex help command
    Minor improvements and bugfixes
    New modifyworld permissions
    Some bugfixes
    Bugfix release
    Bukkit R6 compatible.
    Several bugfixes!
    Permissions now case-insensetive.
    Users logging and cleanup feature.
    Non-inheriting nodes feature.
    Several Bugfixes.
    PermissionsCompat is finally remove from default bundle.
    User/group specific management permissions (
    Fixed some superperms compatibility issues
    Fixed several bugs
    SuperPerms compatbility bridge were rewritten - no lags anymore and now with debug output (now you can view superperms checks).
    Numerous of bugs were fixed (Thanks you guys for reporting them)
    Modifyworld were improved (modifyworld.item.use)
    Compatiblity for 1317+
    Fixed perfomance issues with SuperPerms (if you still experience they try to disable "raw-permissions" in config.yml)
    Fixed issue with prefix inheritance
    Improved Options mechanism.
    Auto saving new users feature, disabled by default.
    SuperPerms bridge improved - more permissions supported by wildcards.
    File backend dumping now fully functional. SQL dumping is still bogus (do not dump world-specific inheritance and prefixes), will be fixed soon.
    Many bugfixes and minor improvements.
    Superperms (BukkitPerms) support
    Multiworld inheritance and prefixes/suffixes
    Groups weighting
    ChatManager, chat plugin which bundled with PEX.
    Modifyworld now separate plugin, but still bundled with PEX.
    API changed slightly, CustomEvents (PermissionsEntityEvent, PermissionsSystemEvent) introduced.
    Many lesser improvements and tons of bugfixes.
    API get slightly improved
    Ranking ladders.
    User/group name case-insensetivity.
    Timed permissions.
    Modifyworld rules are get improved.
    Tons of minor improvements and bugfixes.
    Many bugfixes and improvements.
    MySQL connection stability improved - reconnection mechanism.
    Promotional/Demotional system.
    Perfomance improvement, with new low-level caching system (thx Joy)
    Modifyworld improved.
    Many lesser improvements and bugfixes.
    New p2compat backend, for easy migration from Permissions 2.x to PEX.
    Users/Groups dumping (pex dump <backend> <file>).
    New commands pex promote/demote. Actually this is just aliases for "pex user group set/remove"
    Few bugfixes.
    Players now can be informed about changes (has been added to group, changed permission/option). Disabled by default - set "permissions.informplayers.changes" to "true"
    Config node "permissions.verbose", which responsible for player informing about modifyworld restrictions has been renamed to "permissions.infromplayers.modifyworld".
    Autocomplete has been improved.
    New command "pex config <node> [value]". This command help to manipulate configuration file (config.yml) from console/chat interface.
    Many bugfixes.
    Autocomplete for users (taken from registred users and online users) and groups names.
    New command for user removing (pex user <user> delete)
    Fixed several nasty bugs. Thanks for bugreports!
    Compatibility layer loading order issue fixed. Now most of plugins should work.
    Tested with new CB 803 build.
    Regular expression permissions support.
    Newer permissions now added above (bugfix).
    Several bugfixes.
    Initial public release.
    BRampersad, grid21, MrRazull and 71 others like this.
  2. Really... That's a new one on me. I tried that node and it didn't make any difference for me, only modifyworld worked under PEX.

    I know that the permissions manager PermissionsBukkit node for anti-build like permissions 2/3 had with the build: true/false option, but I've never seen it outside of that manager. bPermissions has a similar one called

    Of course, I've not seen everything there is to know about permissions and bukkit, so I could be way off.:)
  3. Offline


    You've got me really curious now too. Do you see anything else in my configs that would stop Peasants and allow Citizens to build? I am just blaming it on that node. LOL

    I don't have anything in my permissions. :eek:
  4. Ah, OK, I see where that node came from in the bukkitwiki.

    But to further muddle the issue and question;), Dinnerbone posted in the bukkit permissions FAQ (

    My takeaway from all this was that the superperms in bukkit was more of an API call to bukkit which was then handled by the permissions manager.

    As for the next part:), yes I do.

    Peasants don't have anything for the modifyworld.blocks hierarch, while citizens have destroy, place and interact. As I understand it, those differences are all that are needed.
    Stormbow likes this.
  5. That, I couldn't say. I've had a friend who once hallucinated that his poster of a H.R.Giger alien crawled out of said poster and out the window, but that was well after 24 hours of not sleeping, so your mileage may vary. :D
  6. Offline


    Anyone know how to stop hunger depleting on a higher up rank?

    Tried: both modifyworld.damage.take.starvation and modifyworld.digestion both without sucess.

    I can get hunger stopped fine naturally as guest but on a adv builder rank after a previous rank has modifiworld.* it doesn't work both negating and adding.

    Negated modifyworld.digestion everything good now.
  7. Offline


    I know, I am familiar with permissions/yml and get no errors. However, users can still build no matter what.
    Also my yml looks like that
  8. Offline


    Post your full permissions.yml in code tags.
  9. Offline


    Fixed it. I added to permissionsex, and i checked my modifyworld config and it was disabled for some reason

    thanks for the help

    But with and build.* they are muted aswell?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  10. Offline


    Thanks stormbow, but it's not the file... it's PEX acting kinda funky. All my other nodes are inherited, with exception of this one... yet, when I cut and paste it into each group, it works fine.
  11. Offline


    Thanks that helps alot!
  12. Offline


    It also seems that all of my problems with negating permissions, is caused by inheritance not working correctly. If I negate permissions in a group, they seem to work... but inheriting groups to not receive the negated permissions.
  13. Offline


    Hi, i've got problems with my permission.
    I'm trying to block crafting table and furnace interractions to users, but authorize everything else!
    but it does'nt work!

    - -modifyworld.blocks.interact.58
    - -modifyworld.blocks.interact.61
    - modifyworld.*
    But with theses permissions everything is permitted...
    Thanks for helping!

    (ps: i'm french, sorry for my english)
  14. Offline


    Seem to be habing an issue with Modify World and permissions.

    - modifyworld.*
    - -modifyworld.items.have.46
    - -modifyworld.items.use.46

    However, it still lets people do whatever they want with TNT.
  15. Offline

    Codex Arcanum

    I am going to repost my previous question from 7 pages back, since I haven't found anyone willing/able to help, so please forgive me. Also going to post this in the help forum.

    First of all, I want to say that this plugin is great. It is the only permissions option out there that does exactly what I want to do without making me bend over backwards.

    A while ago, I noticed that my server was having lots of lag on teleports (specifically across world boundaries), respawns, and when people logged on. I have tried uninstalling PEX, and that remedied the problem immediately. Since PEX is my favorite choice of permissions plugin, I installed this plugin to check what was slowing down the teleport events.
    Here is the log for the Player_Teleport event.
    Show Spoiler

    10:59:18 [INFO] [-] Event PLAYER_TELEPORT subscriptions
    10:59:18 [INFO] [-] PLAYER_TELEPORT (invoked 117 times, avg 557002us to process)
    10:59:18 [INFO] [-] ru.tehkode.permissions.bukkit.PermissionsEx$PlayerEventsListener [PermissionsEx] (avg 322us)
    10:59:18 [INFO] [-] ru.tehkode.permissions.bukkit.BukkitPermissions$PlayerEvents [PermissionsEx] (avg 554878us)
    10:59:18 [INFO] [-] me.olloth.plugins.flight.listener.Players [SpoutFlight] (avg 9us)
    10:59:18 [INFO] [-] bukkitdev.Rogueleader89.fortification.FortificationPlayerListener [Fortification] (avg 121us)
    10:59:18 [INFO] [-] me.iffa.StyxSpace.listeners.SpacePlayerListener [StyxSpace] (avg 4us)
    10:59:18 [INFO] [-] org.getspout.spout.SpoutPlayerListener [Spout] (avg 1644us)
    10:59:18 [INFO] [-] com.herocraftonline.squallseed31.herosneak.HeroSneakListener [HeroSneak] (avg 2us)
    10:59:18 [INFO] [-] com.nisovin.magicspells.MagicPlayerListener [MagicSpells] (avg 10us)

    It seems to me as if PermissionsEx takes up an inordinately large amount of time. If you look at the attached log, you may notice that all of the things I am having lag issues with are things with a PermissionsEx listener that takes up a large amount of time.
    Show Spoiler

    11:05:41 [INFO] ------- Introspecting plugin 'PermissionsEx'
    11:05:41 [INFO] [-] Event subscriptions
    11:05:41 [INFO] [-] PLAYER_JOIN
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.BukkitPermissions$PlayerEvents [PermissionsEx] (avg 7389372us)
    11:05:41 [INFO] [-] PLAYER_RESPAWN
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.PermissionsEx$PlayerEventsListener [PermissionsEx] (avg 24us)
    11:05:41 [INFO] [-] PLAYER_RESPAWN
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.BukkitPermissions$PlayerEvents [PermissionsEx] (avg 5436187us)
    11:05:41 [INFO] [-] PLAYER_KICK
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.BukkitPermissions$PlayerEvents [PermissionsEx]
    11:05:41 [INFO] [-] PLAYER_QUIT
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.BukkitPermissions$PlayerEvents [PermissionsEx] (avg 10us)
    11:05:41 [INFO] [-] PLAYER_QUIT
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.PermissionsEx$PlayerEventsListener [PermissionsEx] (avg 12us)
    11:05:41 [INFO] [-] PLAYER_TELEPORT
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.PermissionsEx$PlayerEventsListener [PermissionsEx] (avg 322us)
    11:05:41 [INFO] [-] PLAYER_TELEPORT
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.BukkitPermissions$PlayerEvents [PermissionsEx] (avg 554878us)
    11:05:41 [INFO] [-] PLAYER_PORTAL
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.PermissionsEx$PlayerEventsListener [PermissionsEx] (avg 24us)
    11:05:41 [INFO] [-] PLAYER_PORTAL
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.BukkitPermissions$PlayerEvents [PermissionsEx] (avg 3us)
    11:05:41 [INFO] [-] PLAYER_CHANGED_WORLD
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.BukkitPermissions$PlayerEvents [PermissionsEx] (avg 5639370us)
    11:05:41 [INFO] [-] CUSTOM_EVENT
    11:05:41 [INFO] [-] ru.tehkode.permissions.bukkit.BukkitPermissions$PEXEvents [PermissionsEx] (avg 0us)

    Is this a problem with PermissionsEx, or something else I haven't thought of? If so, what, if anything, can be done? Thanks.
  16. Offline


    I have an issue with the inheritance between groups. I'm testing my server by myself un-oped and the permissions for the group I set myself to works, but none of the other commands work at all and says i don't have permission. This is what I have now.
            - Moderator
            prefix: '&3'
            suffix: '&f'
    Should I change it to this?
            - Moderator
            - Member
            - default
            prefix: '&3'
            suffix: '&f'
  17. Flip the nodes around.:) Negation nodes have to come before nodes that grant access due to the way PEX reads permissions on a file back end.

    Bottom of the linked section
    THG3 likes this.
  18. Offline


    I'm a new server admin, and this is the most organized Permission plugin I have used (between the two I tried previously)! Great job!
  19. That should work. This is what I have for guests:
            - -modifyworld.blocks.interact.(23|25|54|61|62|84)
            - modifyworld.blocks.interact.*
    Are you sure modifyworld isn't running into an error and unloading itself?

    They shouldn't be, the nodes for chat are and last time I looked.

    You might be running into the quirk of PEX where group permissions are checked before the inherited ones, does that sound accurate?

    I'm afraid that I don't have any real suggestions. I know PEX can lag when using a file backend with 150+ users (the sql backend doesn't seem to have this issue), but beyond that, I would suggest posting this in the github for PEX as a ticket.:(

    The second code block you posted isn't using inheritance:), so if you are having problems with it, can you post/link to your permissions setup (I'm assuming a file backend) and describe exactly what is breaking for you?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  20. Offline

    Codex Arcanum

    Just realized, I thought I was running 1.17, but I was running 1.15. Update cut my lag problems by 1000 times according to that plugin. Thanks for the response anyway though :).
    Justin The Cynical likes this.
  21. Offline


    How can i make PEX works with Regios?
  22. What have you tried and what isn't working?

    You need to be a wee bit more specific.:) Probably wouldn't be a bad idea to post your permissions setup or link to them in a pastebin/pastie.
  23. Offline


    2012-01-05 22:16:30 [INFO] [Regios] Spout not detected. No Spout support.
    2012-01-05 22:16:30 [INFO] [Regios] Checking directories.
    2012-01-05 22:16:30 [INFO] [Regios] Deleting directory @_root/plugins/Regios/Dependancies
    2012-01-05 22:16:30 [INFO] [Regios] Directory check completed.
    2012-01-05 22:16:30 [INFO] [Regios] Checking configuration files.
    2012-01-05 22:16:30 [INFO] [Regios] Configuration check completed.
    2012-01-05 22:16:30 [INFO] [Regios] Loading configuration files.
    2012-01-05 22:16:30 [INFO] [Regios] Loaded default region configuation file.
    2012-01-05 22:16:30 [INFO] [Regios] Economy preset found : ICONOMY
    2012-01-05 22:16:30 [INFO] [Regios] Loading world configuration for world : Mundo
    2012-01-05 22:16:30 [INFO] [Regios] Loading world configuration for world : Mundo_nether
    2012-01-05 22:16:30 [INFO] [Regios] Loading world configuration for world : Mundo_the_end
    2012-01-05 22:16:30 [INFO] [Regios] Configuration files loaded successfully!
    2012-01-05 22:16:30 [INFO] [Regios] Loading [1] Regions.
    2012-01-05 22:16:30 [INFO] [Regios] Permissions not detected, checking PEX...
    2012-01-05 22:16:30 [INFO] [Regios] Permissions (PEX) support enabled!
    2012-01-05 22:16:30 [INFO] [Regios] Starting scheduler task...
    2012-01-05 22:16:30 [INFO] [Regios] Scheduler task initiated!
    2012-01-05 22:16:30 [INFO] [Regios] Regios version 5.0.01 enabled successfully!
    2012-01-05 22:16:30 [INFO] [Regios] Regios Developed by [Adamki11s].
    Users can only set regions of 3 size block and can set regions within a region. Regionception.
  24. Offline


    this may be an off the wall and somewhat odd question about PEX, but is there anyway to have it so that when you add a prefix or a suffix to a rank, you can have it keep another prefix or suffix from a group that the user is also in, like a secondary suffix and prefix entry to be kept while the first prefix/suffix is updated to match changes with the users group and rank.
    for example, if we had a user with the following.


    would it be possibly that when the user is promoted, that the following could occur.
    [new prefix1][prefix2]NAME[suffix]

    its not too major a problem, as prefixes and suffixes can be manually written for players that have additional titles on the server, but if a user could inherit a portion of their prefix/suffix from the previous rank they were, that would be great!

    something along the lines of adding options for

    anyway this could be possibly implemented either in a future version, or manually myself?
  25. This was an interesting one.:)

    I dropped your permissions into my test server and looked. PEX was finding the nodes regios.restrictions.3 (restrict number of regions) and regios.restrictions.size20(restrict the size of the region), but regios still was saying that I wasn't allowed to make a region larger than three blocks...

    I tried earlier versions of regios and PEX and was unable to get it to work... until I found this ticket in the regios dev bukkit page (
    I tried it by setting the regios.restrictions.size3 and regios.restrictions.20 nodes, and it worked.

    At this point, it looks like a problem with regios, not PEX. I would add into that ticket for regios that you are having the same issue. This could very well still be PEX, but from what I have personally seen and can tell, I'm leaning toward regios.

    Actually, it's not that strange. I think it's been asked a few times before.:)

    Manually, I don't think there is a way to do it with chatmanager at this time. You could put in a feature request on github for it, or if you aren't set on chatmanager, I believe that mchat will support this functionality and a lot more.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  26. Offline


    And what about regionception, users can create regions within a region.
  27. Offline


    hey there, I have a little problem. It seems no users can promote, but ops can. Have the permission nodes changed? Here is the section for mods where they should be able to promote. I would really appreciate it if someone could help me out.(tried adding multiple possible permission nodes)
            - assistant
            default: false
            - lockette.admin.*
            - essentials.ban.notify
            - essentials.ban
            - permissions.manage.users.*
            - permissions.manage.users
            - spamhammer.unmute
            - spamhammer.unban
            - district.ignore
            - bukkit.command.kick
            - minecraft.kick
            - minecraft.pardon
            - minecraft.ban
            - nocheat.flying
            - permissions.manage.users.permissions
            - essentials.broadcast
            - essentials.kill
            - essentials.spawnmob
            - essentials.tphere
            - hawkeye.tool
            - lb.*
            - mcbans.*
            prefix: '[&3Moderator&f] '
                rank: '8'
    here is my config:
                file: permissions.yml
        backend: file
            disable-unmatched: false
            enable: true
            debug: false
            strict-mode: false
            parent-nodes: true
        createUserRecords: false
        allowOps: true
        debug: false
        basedir: plugins/PermissionsEx
  28. Is it not supposed to? I didn't see anything on the wiki stating that it shouldn't be allowed, nor did I see it check for any permission node to allow or disallow creation of a region within another one.

    Personally, I can see how being able to create a region with a region would be useful... Big castle type of building with various levels of access. Only the most trusted are allowed into the treasure room where all the diamonds are kept, for example, but most everyone are allowed into the common areas that surround it.:)

    Thank you for posting your permissions and configs in code tags!:)

    As for the problem, the nodes you want to add are permissions.user.promote.default and permissions.user.demote.default. Default is the name that PEX uses 'internally' for a permissions setup that has a single ladder that isn't named.

    References: (bottom of the page)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  29. Offline


    Still does not work. Says no permission
  30. Ok, can you post/link to your entire permissions setup?

    And when a mod tries to promote a user, what group is that user in at the time? They are running /pex promote $player, correct?
  31. Offline


    I tried removing his other rank, so he would just have the moderator group. and yes Ive tried different commands as well. /pex user <user> group add <group>, /pex promote <user>

    Specifically use the first command.

    Heres a pastebin link to permissions folder:

    EDIT: It had just happened recently.. few weeks ago I think. Even before the update. Was working perfectly fine before. Although... could it be a reason because my file has grown too large? Around 80k users have been set on it.

    EDIT2: Ive also noticed some other permission nodes not working. Such as blacklisted item placement of essentials. Other perms of essentials works.. just not that one.

    Another is worldedit copy/paste, or butcher from essentials.. They dont have perms for it, but they can do it anyways..

Share This Page