[ADMN/DEV] PermissionsBukkit v2.0 - Official Default Groups Plugin [1.5.2-R1.0]

Discussion in 'Archived: Plugin Releases' started by SpaceManiac, Jul 17, 2011.

  1. Offline


    PermissionsBukkit - the Official Default Groups Plugin
    Current Version: v2.0
    Find PermissionsBukkit on BukkitDev!

    If you are getting a specific error or cannot determine what is wrong with your permissions file, filing a ticket on BukkitDev will make me much more likely to respond to you; general questions are best to ask in this thread or on the forums on BukkitDev.

    It's been a long time coming, but with the accomplishment of build 1000 Bukkit has finally accomplished a built-in Permissions system (codenamed Superperms). For more info on how they work, and how to integrate them with your plugin, see the official Permissions FAQ. Keep in mind that you should rarely, if ever, have to hook this plugin directly; instead keep things in the realm of checking player.hasPermission("yourplugin.node"). The FAQ thread has more info on how to use Superperms with things like chat prefixes/suffixes.

    • Storage of users and groups in plugins/PermissionsBukkit/config.yml.
    • Both users and groups can be assigned individual permissions and parent groups to inherit permissions from.
    • Support for global and per-world permissions.
    • Reload configuration from file with out reloading the plugin.
    • Ability to check if a player has a specific permission node.
    • Ability to dump all permissions a player has and the plugins that set them.
    • Ability to print plugin, description, and default for a given permission node.
    • Ability to modify the permissions of groups and users and the groups of a user in-game.
    • Built-in antibuild via the "permissions.build" node (defaults to allowing anyone to build).
    • A minimalistic bridge from Permissions 3.0 to Superperms is available as a separate plugin, which does not depend on PermissionsBukkit.
    Command Usage:

    Show Spoiler
    PermissionsBukkit uses the command /permissions, with aliases /perms and /perm.

    /permissions reload - reload the configuration from disk.
    /permissions check <node> [player] - check if a player or the sender has a permission (any plugin).
    /permissions info <node> - prints information on a specific permission.
    /permissions dump [player] [page] - prints info about a player's (or the sender's) permissions.
    /permissions setrank <player> <group> - set a player to be in a group with per-group permissions.
    /permissions group - list group-related commands.
    /permissions group list - list all groups.
    /permissions group players <group> - list players in a group.
    /permissions group setperm <group> <[world:]node> [true|false] - set a permission on a group.
    /permissions group unsetperm <group> <[world:]node> - unset a permission on a group.
    /permissions player - list player-related commands.
    /permissions player groups <player> - list groups a player is in.
    /permissions player setgroup <player> <group,...> - set a player to be in only the given groups.
    /permissions player addgroup <player> <group> - add a player to a group.
    /permissions player removegroup <player> <group> - remove a player from a group.
    /permissions player setperm <player> <[world:]node> [true|false] - set a permission on a player.
    /permissions player unsetperm <player> <[world:]node> - unset a permission on a player.

    All commands have in-game help and are usable from the server console.

    Show Spoiler
    A permission node is a string like 'permissions.build', usually starting with the name of the plugin. Refer to a plugin's documentation for what permissions it cares about. Each node should be followed by true to grant that permission or false to revoke it, as in 'permissions.build: true'. Some plugins provide permission nodes that map to a group of permissions - for example, PermissionsBukkit has 'permissions.*', which automatically grants permissions for all PermissionsBukkit commands. You can also specify false for permissions of this type.

    Users inherit permissions from the groups they are a part of. If a user is not specified here, or does not have a 'groups' node, they will be in the group 'default'. Permissions for individual users may also be specified by using a 'permissions' node with a list of permission nodes, which will override their group permissions. World permissions may be assigned to users with a 'worlds:' entry.

    Groups can be assigned to players and all their permissions will also be assigned to those players. Groups can also inherit permissions from other groups. Like user permissions, groups may override the permissions of their parent group(s). Unlike users, groups do NOT automatically inherit from default. World permissions may be assigned to groups with a 'worlds:' entry.

    The cannot-build message is configurable. If it is left blank, no message will be displayed to the player if PermissionsBukkit prevents them from building, digging, or interacting with a block. Use '&' characters to signify color codes.

    An example configuration file might look like this:
                permissions.example: true
            - admin
                permissions.build: false
                permissions.*: true
            - user
                permissions.build: true
                    coolplugin.item: true
            - default
        build: '&cYou do not have permission to build here.'

    Show Spoiler
    PermissionsBukkit checks for the following permission nodes:
    • permissions.build - Allows a player to build. Defaults to true.
    • permissions.help - Allows viewing of usage for /permissions.
    • permissions.reload - Allows use of /permissions reload.
    • permissions.check - Allows use of /permissions reload.
    • permissions.info - Allows use of /permissions reload.
    • permissions.dump - Allows use of /permissions reload.
    • permissions.group.help - Allows viewing of usage for /permissions group.
    • permissions.group.list - Allows use of /permissions group list.
    • permissions.group.players - Allows use of /permissions group players.
    • permissions.group.setperm - Allows use of /permissions group setperm.
    • permissions.group.unsetperm - Allows use of /permissions group unsetperm.
    • permissions.player.help - Allows viewing of usage for /permissions player
    • permissions.player.groups - Allows use of /permissions player groups.
    • permissions.player.setgroup - Allows use of /permissions player setgroup.
    • permissions.player.addgroup - Allows use of /permissions player addgroup.
    • permissions.player.removegroup - Allows use of /permissions player removegroup.
    • permissions.player.setperm - Allows use of /permissions player addgroup.
    • permissions.player.unsetperm - Allows use of /permissions player removegroup.
    Also, the following parent nodes are provided for convenience:

    • permissions.* - Maps to permissions.help, .reload, .check, .info, .dump, and to permissions.group.* and permissions.player.*. Defaults to op.
    • permissions.group.* - Maps to permissions.group.help, .list, .players, .setperm, and .unsetperm.
    • permissions.player.* - Maps to permissions.player.help, .groups, .setgroup, .addgroup, .removegroup, .setperm, and .unsetperm.

    Frequently Asked Questions:
    1. Where are my * nodes? (open)
    Bukkit's Superperms has no built-in concept of a global '*' node that automatically gives all permissions, which is intentional - a player can instead be given all permissions by being given 'op' status (that is, listed in ops.txt). Additionally, individual plugins define a parent node (which could be 'pluginname.*' or 'pluginname.all' or anything else) which maps to whatever subpermissions in that plugin the author desires.

    An example is PermissionsBukkit, which provides three such permissions: 'permissions.group.*' for all /permissions group commands, 'permissions.player.*' for all /permissions player commands, and'permissions.*' for all /permissions commands (including permissions.group.* and permissions.player.*).

    If you are using SuperpermsBridge, you can do something similar to '*' nodes for plugins which use Permissions 2.7/3.1 - see the next FAQ for more information.
    2. How do I use SuperpermsBridge? (open)
    SuperpermsBridge is kind of like FakePermissions for GroupManager or PermissionsBridge for PermissionsEx. Once it's installed, it pretends to be the Permissions plugin and converts any plugins that use Permissions 2.7 or Permissions 3.1 to use Superperms instead.

    You can have PermissionsBukkit without SuperpermsBridge or SuperpermsBridge without PermissionsBukkit if you like, but both of these are limited in functionality. If you install SuperpermsBridge without PermissionsBukkit you will not be able to make use of PermissionsBukkit's groups feature or admin commands, and if you install PermissionsBukkit without SuperpermsBridge, plugins that have not updated to use Superperms directly will not function.

    For plugins that use Permissions 2.7/3.1, you can use the special node 'superpermbridge.*' to give the equivalent of what used to be the '*' node for plugins that do not use Superperms directly. If you don't want to give the * node, you can also use the node 'superpermbridge.pluginname' to do the equivalent of what used to be the 'pluginname.*' node. Once again, these only apply to plugins that SuperpermsBridge handles and not to plugins using Superperms directly.
    3. How do I use the root permissions.yml? (open)
    The file 'permissions.yml' in the root of your server can be used to set up custom parent permissions. Parent permissions are a single node that, when given to a player or group, automatically give all their children node. Here's a simple example:
            commandbook.motd: true
            commandbook.say: true
            commandbook.say.me: true
            commandbook.time: true
    Now, if you give a player the node 'server.basics', they automatically get all the nodes listed here. Children may also say 'false' instead of 'true', in which case giving the parent will remove the child instead of giving it.

    You can also specify a description if you like, which can be used by plugins to provide information on your node (such as PermissionsBukkit's /perm info command). If you want, you can also provide a default, which can be one of "true", "false", "op", or "notop". CraftBukkit will automatically assign everyone, no one (default), ops, or non-ops the children permissions based on the specified default. Without any plugin like PermissionsBukkit, you can use this defaults system as a limited way to assign people permissions. Here's a more complex example:
        description: Basic permissions for My Cool Server.
        default: true
            commandbook.motd: true
            commandbook.say: true
            commandbook.say.me: true
            commandbook.time: true
        description: Admin permissions for My Cool Server.
        default: op
            commandbook.broadcast: true
            commandbook.teleport: true
            commandbook.kick: true
            commandbook.ban: true
    You can also define permissions without children, but this is of limited usefulness in permissions.yml (though is important in plugin.yml; see question #6)
    4. How do I switch from (other Permissions plugin)? (open)
    Depends on the Permissions plugin! If you were using PEX's YAML backend, I have a converter done and available on the PermissionsBukkit Tools page. Also available on the tools page is an automatic converter for Essentials GroupManager users.yml and groups.yml files. Automatic converters for Permissions 2.7 and 3.x are on their way, but in the meantime you can still convert your configurations manually.
    5. Where are prefixes and suffixes (or option nodes)? (open)
    Bukkit Superperms has no built-in prefix/suffix settings or non-boolean permission nodes, so individual chat plugins will have to start supporting Superperms in order to make use of non-Permissions-plugin based prefixes and suffixes. Herochat, iChat, and Simple Suffix are all aware of the Superperms update, but in the meantime you can use mChat, which already supports Superperms.

    Once you install mChat and configure the mchat.prefix, mchat.suffix, and mchat.group names in its configuration file (see the example), use PermissionsBukkit to give players or groups the permissions "mchat.prefix.admin", replacing "admin" with whatever node you configured. For example, with an mchat configuration that looks similar to this:
    da-name-format: '+prefix+name&e'
    date-format: HH:mm:ss
    message-format: '+prefix+name&f: +message'
            admin: '&4DtK [SO] &7 '
            sadmin: '&9DtK [SA] &7 '
            jadmin: '&aDtK [JA] &7  '
            member: '&cDtK [M] &7 '
    You can assign players or groups the mchat.prefix.admin node to get the "SO" prefix, mchat.prefix.sadmin to get the "SA" prefix, and so on.
    6. (Coders) How do I set up my plugin.yml? (open)
    Take a look at this post in Dinnerbone's FAQ for an example. This is a lot like the setup of permissions.yml (see above), but you can also define non-parent permissions (just include description and default and leave out children).
    7. Is PermissionsBukkit outdated? (open)
    No! PermissionsBukkit 2.0 was last updated for 1.3.1-R2.0, is verified to work on 1.4.7-R1.0, and is unlikely to break on future releases.

    Current Version:

    PermissionsBukkit v2.0 (jar) (details)
    Old Versions:
    PermissionsBukkit v1.6 (jar) (details)



    Friday 7 September 2012 (2.0)
    • Fixed a case-sensitivity issue with setting per-world permissions that could cause some permissions to fail to apply.
    • Added /perm setrank <player> <group> subcommand (alias rank) with per-group permissions (permissions.setrank and permissions.setrank.<group>)
    • Added plugin metrics via http://mcstats.org/plugin/PermissionsBukkitMCStats (disableable in plugins/PluginMetrics/config.yml)
    Wednesday 29 February 2012 (1.6)
    • Fixed some massive issues that were caused due to having uploaded a buggy, in-development version instead of 1.5.
    • Note: If your configuration was messed up as a result of this issue, the new build should gradually correct it as needed.
    Saturday 25 February 2012 (1.5b)
    • Revamped to be compatible with R5.
    • Fixed issues with permissions not carrying properly on world change.
    • Many internal improvements for performance and stability.
    • SuperpermsBridge: in honor of R5 removing deprecated code, SuperpermsBridge is officially gone!
    Monday 18 July 2011 (1.1/1.2)
    • Fix BukkitContrib incompatibility issues.
    • Improved the output of the /perm check command.
    • Fixed issues when 'users:' is not specified in the config file.
    • Fixed the /permissions reload command.
    • SuperpermsBridge: improve wildcard handling; in addition to 'superpermbridge.*' and 'superpermbridge.pluginname', now supported are 'superpermbridge.plugin.*', 'superpermbridge.plugin.subnode.*', and so on.
    Monday 18 July 2011 (1.0/1.1)
    • SuperpermsBridge: adding the special 'superpermbridge.*' and 'superpermbridge.pluginname' nodes (see #2 in the FAQ for details).
    Sunday 17 July 2011 (1.0/1.0)

    • Initial release of PermissionsBukkit v1.0 and SuperpermsBridge v1.0.
    madmac, Gesundheit, tripleX and 23 others like this.
  2. Offline


    When i starting my server, there is error appering, whats wrong with my config? Answer my question please, here is the code:
            - admin
            - admin
            - admin
            - admin
                permissions.build: true
                PhysicalShop.use: true
                stargate.use: true
                lwc.protect: true
                wolfpound.use: true
                heroicdeath.messages: true
                fight.user: true
                PhysicalShop.build: true
                    permissions.build: false
                permissions.*: true
                permissions.build: true
                    permissions.build: true
            - user
                    permissions.build: false
            - default
        build: '&cYou do not have permission to build here.'
  3. Offline


    Anyone able to help me with PermissionsBukkit/Superperms and multi-world? This is my config http://pastebin.com/7DxhpKEg The issue I am having is that if I give someone SLB group they get access to those commands on both worlds. I have tried many ways but can't seem to figure it out.

    Some more info on this issue. I used mChat it does the same thing. I have it add the prefix on one world but not the other. The prefix seems to stay even if they change worlds. Also if someone has no commands in one world and switchs to the world they have commands in. They can't use the commands till the relog. Then if they reload and jump back to the other world they still keep the commands. I think your multi-world support is buggy.
  4. Offline


    I am having problems as well, some of the permissions work (iconomy, mcmmo, localshops and craftbook) but the rest don't work however I add them to the list. With our without superpermbridge. it doesn't work. Specifically Essentials, Spawncontrol, Citizens (NPC), Tombstone and McDocs. Does anyone have any idea why these don't work? They have been updated.
    If you had this problem and solved it, how did you do it?
            - admin
            - admin
            - admin
                permissions.build: true
                iConomy.payment: true
                mcmmo.motd: true
                mcmmo.commands.party: true
                mcmmo.skills.*: true
                superpermbridge.npc.user.*: true
                superpermbridge.essentials.chat.shout: true
                superpermbridge.essentials.helpop: true
                superpermbridge.essentials.me: true
                superpermbridge.essentials.motd: true
                superpermbridge.essentials.rules: true
                superpermbridge.essentials.afk: true
                superpermbridge.essentials.msg: true
                SpawnControl.sethome.basic: true
                superpermbridge.essentials.list: true
                localshops.user.*: true
                localshops.manager.*: true
                superpermbridge.tombstone.use: true
                superpermbridge.tombstone.freechest: true
                superpermbridge.tombstone.playermessage: true
                mcmmo.ability.*: true
                craftbook.mech.ammeter.use: true
                craftbook.mech.bridge: true
                craftbook.mech.bookshelf.use: true
                craftbook.mech.cauldron: true
                craftbook.mech.gate: true
                craftbook.mech.light-switch: true
                craftbook.ic.safe: true
                superpermbridge.mcdocs./cmds: true
                superpermbridge.mcdocs./intro: true
                superpermbridge.mcdocs./motd: true
                superpermbridge.mcdocs./news: true
                superpermbridge.mcdocs./register: true
                superpermbridge.mcdocs./rules: true
                superpermbridge.mcdocs./story: true
                permissions.*: true
                mcmmo.*: true
                superpermbridge.mcdocs.*: true
                superpermbridge.npc.*: true
                craftbook.*: true
                superpermbridge.tombstone.*: true
                superpermbridge.essentials.*: true
                iconomy.*: true
                localshops.*: true
                superpermbridge.SpawnX.*: true
                superpermbridge.*: true
            - user
                permissions.build: true
                    coolplugin.item: true
            - default
        build: '&cYou do not have permission to build here.'
    Thanks in advance!
  5. Offline


    For those having trouble with multi-world, give the dev build a try. There was a commit after the 1.1 release that seems to have fixed the issues.

    Also, cancelled events should really be honored. I finally figured out the issue between PermissionsBukkit and AdminsCanFly (which originally caused me to switch to bPermissions... today I'm switching back. :p) Despite AdminsCanFly cancelling the player kick event for flying, PermissionsBukkit goes ahead and unregisters the player. So in the next tick, non-op players would no longer have permission to fly and get kicked.

    I believe there's an outstanding pull request @ GitHub which addresses this and then some. If you'd like a smaller diff with just the cancelled event changes, let me know. ;)

    Anyway, thanks for all your work on this!
  6. Offline


    i'm sure its something wrong on my end but none of the commands are working and this isn't the only plugin to do this any suggestions?
  7. Offline


    Hi, i have been reding for like 6 hous straight now trying to figure out how to do this but i keep failing :/
    if some one could please have a look at my screen log and my Permissions fil and let me know what i'm doing wrong i would be verry greatfull.

    Screen Log

    151 recipes
    16 achievements
    03:13:28 [INFO] Starting minecraft server version Beta 1.7.3
    03:13:28 [INFO] Loading properties
    03:13:28 [INFO] Starting Minecraft server on *:25565
    03:13:28 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    03:13:28 [INFO] [SuperpermBridge] Superperm/Permissions bridge initialized
    03:13:28 [INFO] LWC: Loading shared objects
    03:13:28 [INFO] LWC: Protection cache: 0/10000
    03:13:28 [INFO] LWC: Native library: plugins/LWC/lib/native/Linux/i386/libsqlitejdbc.so
    03:13:28 [INFO] Preparing level "Eriador"
    03:13:28 [INFO] Preparing start region for level 0 (Seed: 4390141178203935834)
    03:13:29 [INFO] Preparing start region for level 1 (Seed: 4390141178203935834)
    03:13:29 [INFO] Preparing spawn area: 77%
    03:13:30 [INFO] [PorteCoulissante] plugin version 1.2.1 by Captain_Chaos enabled
    03:13:30 [INFO] [iConomy] Logging is currently disabled.
    03:13:30 [INFO] [iConomy] v5.01 (Eruanna) loaded.
    03:13:30 [INFO] [iConomy] Developed by: [Nijikokun]
    03:13:30 [INFO] TPack: Loading Cuboids...
    03:13:30 [INFO] TPack: Loaded 0 cuboids successfully!
    03:13:30 [INFO] TPack version 3.5 is enabled!
    03:13:30 [INFO] Enabled!
    03:13:30 [INFO] [Towny] Database: [Load] flatfile [Save] flatfile
    03:13:30 [INFO] [Towny] Using: Permissions, iConomy, Questioner
    03:13:30 [INFO] [Towny] Version: 0.74.0 - Mod Enabled
    03:13:30 [INFO] [RAM] Version 1.0 enabled!
    03:13:30 [INFO] PermissionsBukkit v1.1 is now enabled
    03:13:30 [INFO] [RetractableBridge] plugin version 1.3.7 by Captain_Chaos enabled
    03:13:30 [INFO] [Bandages] Found Permissions Plugin!
    03:13:30 [INFO] [Bandages] Enabled! Version:1.2.4 by bekvon
    03:13:30 [INFO] [MagicCarpet] MagicCarpet version 1.5.6 is enabled!
    03:13:30 [INFO] [MagicCarpet] Take yourself wonder by wonder, using /magiccarpet or /mc.
    03:13:30 [INFO] [MagicCarpet] Using Permissions.
    03:13:30 [INFO] [Quantum Connectors] version 1.0.2 ENABLED
    03:13:30 [INFO] Lockette version 1.3.8 is being enabled!  Yay!  (Core version 1.0)
    03:13:30 [INFO] Lockette: Detected craftbukkit build [1060] ok.
    03:13:30 [INFO] [SuperpermBridge] Superperm/Permissions bridge enabled
    03:13:30 [INFO] [iConomy] hooked into Permissions.
    03:13:30 [INFO] Lockette: Linked to Permissions plugin version 2.7.7
    03:13:30 [INFO] Lockette: Using ops file for admin permissions.
    03:13:30 [INFO] Lockette: Ready to protect your containers.
    03:13:30 [INFO] [WaterproofRedstone] Enabled.
    03:13:30 [INFO] [DCREASON] DCReason version 1.5 for Minecraft version 1.7.3 by Eevables and Darklust enabled.
    03:13:30 [INFO] [Multiverse-Core] - Version 2.0-b228 Enabled - By Rigby and fernferret
    03:13:30 [INFO] [Multiverse-Core] - Attached to Permissions
    03:13:30 [INFO] [AllPay] - Version 1.0.3 - hooked into iConomy 5 for Multiverse-Core v2.0-b228
    03:13:30 [INFO] [Multiverse-Core] - Multiverse Config -- Loaded
    03:13:30 [INFO] [Multiverse-Core] - World Config -- Loaded
    03:13:30 [INFO] [Multiverse-Core] Loading World & Settings - 'Eriador_nether' -NETHER
    03:13:30 [INFO] [Multiverse-Core] Loading World & Settings - 'Eriador' - NORMAL
    03:13:30 [INFO] Preparing start region for level 2 (Seed: -3768944882360637595)
    03:13:31 [INFO] [Multiverse-Core] Loading World & Settings - 'Wonderland' - NORMAL
    03:13:31 [INFO] [Multiverse-Core] 3 - World(s) loaded.
    03:13:31 [INFO] [Flight] Enabled!
    03:13:31 [INFO] [MultiVerse-Portals] - Version 2.0-b183 Enabled - By Rigby and fernferret
    03:13:31 [INFO] [MultiVerse-Portals]  0 - Portals(s) loaded
    03:13:31 [INFO] NoSpeedKick: Found and will use plugin Permissions v2.7.7
    03:13:31 [INFO] NoSpeedKick 0.2 enabled
    03:13:31 [INFO] [LIGHTSENSOR] 0 sensors loaded
    03:13:31 [INFO] [LIGHTSENSOR] version 0.8 is enabled!
    03:13:31 [INFO] [Questioner] v0.4 - Enabled
    03:13:31 [INFO] [MultiVerse-NetherPortals] - Version 2.0-b182 Enabled - By Rigby and fernferret
    03:13:31 [INFO] LWC: Loaded 135 locale strings (0 overrides)
    03:13:31 [INFO] LWC: Permissions API: BukkitPermissions
    03:13:31 [INFO] LWC: Currency API: iConomyCurrency
    03:13:31 [INFO] LWC: Loading SQLite
    03:13:31 [INFO] LWC: Using: Native
    03:13:31 [INFO] LWC: Precached 0 protections.
    03:13:31 [INFO] LWC: At version: 3.31-git-LWC-b9ea01e8c2f66480ada443ba9084dfbe9832f06e-b81jnks
    03:13:31 [INFO] [iChat] Found Permissions (v2.7.7)
    03:13:31 [INFO] iChat (v2.3.3) enabled
    03:13:31 [INFO] [OddItem] 0.7.3 enabled
    03:13:31 [INFO] [OddItem] Using RefinedSoundEx for suggestions.
    03:13:31 [INFO] [OddItem] Group samplegroup added: [greenwool, ironblock:2, diode]
    03:13:31 [INFO] [OddItem] 851 aliases loaded.
    03:13:31 [INFO] properTime reading from config at /home/ts/minecraft/plugins/properTime/properTime.conf
    03:13:31 [INFO] Applying default config on world Wonderland
    03:13:31 [INFO] properTime 1.9.0 initialized
    03:13:31 [SEVERE] Permission node 'groups' in server config is invalid
    java.lang.IllegalArgumentException: 'default' key contained unknown value
            at org.bukkit.permissions.Permission.loadPermission(Permission.java:184)
            at org.bukkit.craftbukkit.CraftServer.loadCustomPermissions(CraftServer.java:494)
            at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:167)
            at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:286)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:273)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:149)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:337)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    03:13:31 [INFO] Done (0.292s)! For help, type "help" or "?"
    My Permissions file is:

                permissions.build: false
                permissions.build: true
                    craftbukkit.command.time: false
                    craftbukkit.command.time.add: false
                    craftbukkit.command.time.set: false
                    craftbukkit.command.time: false
                    craftbukkit.command.time.add: false
                    craftbukkit.command.time.set: false
            - default
                craftbukkit.command.ban: true
                craftbukkit.command.ban.ip: true
                craftbukkit.command.ban.player: true
                craftbukkit.command.op: true
                craftbukkit.command.op.give: true
                craftbukkit.command.op.take: true
                craftbukkit.command.save: true
                craftbukkit.command.save.disable: true
                craftbukkit.command.save.enable: true
                craftbukkit.command.save.perform: true
                craftbukkit.command.time: true
                craftbukkit.command.time.add: true
                craftbukkit.command.time.set: true
                craftbukkit.command.unban: true
                craftbukkit.command.unban.ip: true
                craftbukkit.command.unban.player: true
                craftbukkit.command.whitelist: true
                craftbukkit.command.whitelist.disable: true
                craftbukkit.command.whitelist.enable: true
                craftbukkit.command.whitelist.list: true
                craftbukkit.command.whitelist.reload: true
                craftbukkit.command.whitelist.remove: true
                lwc.admin: true
                lwc.allcommands: true
                multiverse.core.modify: true
                multiverse.core.modify.add: true
                multiverse.core.modify.clear: true
                multiverse.core.modify.modify: true
                multiverse.core.modify.remove: true
                permissions.*: true
                permissions.check: true
                permissions.dump: true
                permissions.group.*: true
                permissions.group.help: true
                permissions.group.list: true
                permissions.group.players: true
                permissions.group.setperm: true
                permissions.group.unsetperm: true
                permissions.help: true
                permissions.info: true
                permissions.player.*: true
                permissions.player.addgroup: true
                permissions.player.groups: true
                permissions.player.help: true
                permissions.player.removegroup: true
                permissions.player.setgroup: true
                permissions.player.setperm: true
                permissions.player.unsetperm: true
                permissions.reload: true
                towny.admin: true
                towny.cheat.bypass: true
                towny.nation.new: true
                towny.publicspawntp: true
                towny.spawntp: true
                towny.town.*: true
                towny.town.claim: true
                towny.town.new: true
                towny.town.plot: true
                towny.town.resident: true
                towny.wild.*: true
                towny.wild.build: true
                towny.wild.destroy: true
                towny.wild.item_use: true
                towny.wild.switch: true
                example.permission: true
            - loyal
                permissions.*: true
            - mod
        myname(didn't want to post my username sorry):
            - owner
  8. Offline


    Sorry about having to post this here, but I've encountered an error while trying to use the default configuration template provided in the first page. I copied and pasted the file and booted up my server and I got this error: (Sorry it's not spoilered, not entirely sure how to do that) Any help would be appreciated.
    [SEVERE] Permission node 'groups' in server config is invalid
    java.lang.IllegalArgumentException: 'default' key contained unknown value
    at org.bukkit.permissions.Permission.loadPermission(Permission.java:184)
    at org.bukkit.craftbukkit.CraftServer.loadCustomPermissions(CraftServer.java:494)
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:167)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:286)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:273)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:149)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:337)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  9. Offline


    A useful post I found.
    Myrrdin likes this.
  10. Offline


    I didn't use tabs, heck, I haven't even edited the config yet, I just copied it from the front page and ran it....
    Tried editing it with Notepad++, same thing happened
  11. Offline


    @Thrain @Shivanous Please ensure you are putting your config in plugins/PermissionsBukkit/config.yml and not permissions.yml; see the FAQ.

    I've returned from my hiatus and now only have to deal with school, so I'll be getting major fixes pushed pretty soon, then I plan to figure out what features are most important, then go into 'maintenance mode' as much as possible. Special thanks to @krinsdeath for being so kind as to find and fix bugs and @Celtic Minstrel for helping to support the plugin.
  12. Offline


    Well, there wasn't one, so I assumed that Bukkit had put out a new version that used the permissions.yml....
    Also, I didn't see anything about doing that in the FAQ...Though I will read it over again just in case I missed it.
    Okay, that fixed that problem. Now I have a new one, the server now says:
    Server permissions file permissions.yml is empty, ignoring it
  13. Offline


    @SpaceManiac @krinsdeath

    This Plugin is starting to piss me off, after having to completely avoid inheritance as it appeared to not be working with nodes used by older plugins (the ones using Superpermbridge). Now I am told certain permissions are still missing. For example, coowners can't spawn items, or teleport in the world "world", and I believe ops aren't able to either.


    EDIT: Looks like this is a commandbook issue, and someone mentioned to me that the latest commandbook supports the new bukkit permissions? It does not. Why is commandbook failing to detect when someone has a permission?

    DOUBLE EDIT: It isn't a commandbook issue, it is an issue with this plugin's multiple world support being buggy. Here is my config.yml: http://pastebin.com/p54gcWX7

    I fear I may have to go back to using the old permissions until this plugin shapes up, or I am told if I am doing anything wrong
  14. Offline


    Thanks @SpaceManic I will try that when I get home, I must have been looking to hard since I missed a simple thing like that :eek:
  15. Offline


    I used CommandBook before Essentials updated and the latest build from http://build.sk89q.com/ worked with PermissionsBukkit.
  16. Offline


    im a real noob and i really need permissions to start my server all i need is a basic template to edit (all i need is 3 groups for the guest, members and admins) thank you!:)
  17. Offline


  18. Offline


    didn't work.
  19. Offline


    Odd, it worked fine with me even without the bridge. Same for WorldGuard and WorldEdit (latest builds).
  20. Offline


    maybe its trying to use both and that's messing it up? nah i think it's the multi world on this plugin
  21. Offline


    I seem to be having an issue with any of my plugins that ban/kick a player from the server. Essentials and smighty both cause the following error in the console along with restarting the server
  22. Offline


    Well, I just figured out what my problem was... I assumed I wouldn't need to download anything because I was under the impression that bukkit's permission system was built in and didn't rely on a plugin to function... Which means it's not very useful to me at this point in time....As it will clash with my current permissions system.
  23. Offline


    How much longer till a converter for 3.x thats all I am waiting for as I'm actually against the move personally I think superperms is a bad move an API should have been made since DAY1 not almost a year later. The only way I'm even going to attempt to do this is with the converter or if someone makes a superperms to 3x bridge so I can use superperms permissions in 3x format.

    The current superpermisisons systems are silly no offence to plugin making use of them. From a Server administrators point of view it's just a whole lot of work for almost no real benfit over the old system that only needed Mysql support.

    But now instead we have a Hmodvsbukkit war all over again where we effectively just split the user base instead of creating an easy move for everyone we created a system that some agree and some don't. I know for a fact a lot of older plugins that still work will never update to superperms.

    I think the 3x method is better formatted and already has native support for everything missing in bukkits. Overall I'm disappointed I begged for an API based on the current methods so ppl stop rolling out new systems not another new system. I know that some people are going to rage about this post and disagree but thats fine. I'm just sating my point that there is no way on earth im going to tear down my working system and trial something that has been rushed out with out thinking about existing systems.

    That to me is slackness I would never develop a system and leave ppl scratching heads it make it auto convert current known systems and already have built in bridges and I'd keep the * node for backwards comptability sakes.

    But never am I going to start mixing two systems into one config that will ruin any chance of an easy conversion later. Right now more plugins are on 3x then superperms I'm happy to wait until this system matures a bit.

    Sorry for messing thread up with this post well the undeeded bits.

    Somone give me 15 reasons why this trumpts existing systems and maybe Ill swing my vote
    I understand that I dont understand this system very well at all but Im in no rush to do that.
    Lunar Delta likes this.
  24. Offline


    I have been trying to convert from Permissions 2.7.4 to this 'Bukkit Permissions' for about 3 days now. I have had to delete plugins, find new ones that work with, alternatives to plugins I already have, etc etc...... needless to say I have spent more time than I think anyone should have too.

    I am inclined to agree with the gentleman who posted above me........ Let's see.....

    -Horrible explanation of how to use/install this permissions system! The 'spoilers' are crap.....
    -Multiworld Bugs
    -superpermbridge. <---- Doesn't work 99% of the time!
    -/reload in-game.... Doesn't work 99% you must do a full restart
    -/permissions reload <---- Doesn't work 99% of the time!

    Extremely disappointed that Dinnerbone would support something like this.......... :( Makes me QQ
  25. Offline


    I havent had any of the troubles you stated, reloading works, superpermsbridge works, spoilers give me just enough info to make it all work.

    Am happy that @Dinnerbone supports this for being the one built-in system that actually makes sense and isnt bloated like e.g. PEX. (which is also a great plugin, but yet another one thats not 'native')
  26. Offline


    I get this error pretty much every time a player quits.
    permissionsbukkit 1.1
    CB 1060

    12:19:07 [SEVERE] Could not pass event PLAYER_QUIT to PermissionsBukkit
    java.lang.IllegalArgumentException: Attachment cannot be null
            at org.bukkit.permissions.PermissibleBase.removeAttachment(PermissibleBa
            at org.bukkit.craftbukkit.entity.CraftHumanEntity.removeAttachment(Craft
            at com.platymuus.bukkit.permissions.PermissionsPlugin.unregisterPlayer(P
            at com.platymuus.bukkit.permissions.PlayerListener.onPlayerQuit(PlayerLi
            at org.bukkit.plugin.java.JavaPluginLoader$2.execute(JavaPluginLoader.ja
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
            at net.minecraft.server.ServerConfigurationManager.disconnect(ServerConf
            at net.minecraft.server.NetServerHandler.disconnect(NetServerHandler.jav
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:313)
            at net.minecraft.server.Packet10Flying.a(SourceFile:126)
            at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:89)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:454)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:363)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
  27. Offline


    Had this issue, the newest dev build of permissions bukkit fixed it for me
  28. Offline


    Hmmm.. Now i can't add a player in the whitelist :s

    /whitelist add pseudo

    I hava this message : I'm sorry, Dave, but i cannot let you do that.

    I'm admin and OP. I have this message too when i write the command in the console.
  29. Offline


    I don't get only 1 thing... Why the hell is this better than the normall permissions?
  30. Offline


    I can't do the /permissions command, just rejects me and says i do not have the permission to do that.

    I also tried in console, but it just said the same thing .. -_-
    10:11:32 [INFO] You do not have permissions to do that.

    Any idea what the heck this is, and how to fix it?
  31. Offline


    I agree there should be a readily available API and it should have been available since PermissionsBukkit release, I was just talking about this with a dev yesterday actually. Bit erm... you know it's no where near a year right? More like a month and a half. :p

Share This Page