Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    What version of craftbukkit are you running? Have you tried updating cb and the permissions plugin? What other plugins do you have?
  3. Offline


    hey guys i think i found a way to fix some of your problems! i had the problem of premissions moving the x.yml to the plugins folder and naming it: permissions"world" and it wasnt realy used at all. so i just COPIED(move didnt work) that file to the permissions folder and named it to my world name again and it worked!

    Using craftbukkit 621
  4. Offline


    you need to fix this so it works with help pages
  5. Offline


    I don't know if this is related to permissions or not, but everytime i load my server, I get an "invalid config file; converting to proper name/format" line right before Permissions is initialized... it doesn't bother the server at all, but im just checking to see if i can fix it or not. :D
  6. Offline


        default: false
        info: {prefix: '&f[&5Architect&f]&d', suffix: '', build: true}
        inheritance: []
        permissions: ['*', '*']
    Hello. I tried removing a single command for the admins on server, but it doesn't seem to work. Did I do something wrong?

    Reason why I want to do this is because HeroChat plugin is on, and I dont like the mcmmo chat plugin.

    Also the server is running 2.5.5, with bukkit version 612
  7. Offline


    You can't fix it, just ignore it. It shows that even if the config file is valid :B
  8. Offline


    I am getting this error when I start up my server:

     [SEVERE] Could not load plugins\Permissions.jar in plugins: null
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.d(
    Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        ... 8 more
    Caused by: while scanning a quoted scalar
     in "<reader>", line 121, column 15:
    found unexpected end of stream
     in "<reader>", line 121, column 16:
        at org.yaml.snakeyaml.scanner.ScannerImpl.scanFlowScalarSpaces(
        at org.yaml.snakeyaml.scanner.ScannerImpl.scanFlowScalar(
        at org.yaml.snakeyaml.scanner.ScannerImpl.fetchFlowScalar(
        at org.yaml.snakeyaml.scanner.ScannerImpl.fetchSingle(
        at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(
        at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(
        at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(
        at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceFirstEntry.produce(
        at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
        at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
        at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeDocument(
        at org.yaml.snakeyaml.composer.Composer.getSingleNode(
        at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(
        at org.yaml.snakeyaml.Yaml.load(
        at org.bukkit.util.config.Configuration.load(
        at com.nijikokun.bukkit.Permissions.Permissions.<init>(
        ... 13 more
    And 2 important permission-reliant plugins have stopped working.
  9. Offline



    I have problems with permissions,
    Groups admin, modo and joueur have no rights.

    Here is my config.yml :

    Bukkit 612
    Permissions 2.5.5

    Thanks for help!
  10. Offline



    Just reporting back on my earlier issue: Permissions functioned, but would not use permissions from the yml file. I got fed up, blew up the entire server, deleted the directory, and started over. It works now. I guess if you have that issue what you could try is removing everything except your map, and then redownloading it all. Inconvenient, but hell.
  11. Offline


    I'm not getting errors in the console, but for some reason Permissions is not preventing anyone from using commands. I'm running CB 617. Other plugins: BackupPlugin, dynmap, Essentials, Essentials Spwan, GlassDrop, GlowstoneDrop, Multiverse, SimpleSave, Spawnlist, and xWarp.

    Here's my YML file:

    Edit: Looks like players are unable to place or destroy blocks.
  12. Offline


    Goo to know, thanks for posting here to tell us :)

    I don't think you need those "+"es in your permission nodes. It also looks like the first permission node for each group isn't indented enough, give each one another space.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  13. Offline


    I can't get this to disable build rights...

    im using build 617, permission v2.5.5,
    and the only other plugins i have are world edit and world guard

    is there anything else i need to do besides
    put permissons.jar in the plugins dir,
    and name the config file "world.yml" (same as world name), put that in the plugins/permissions dir,
  14. Offline


    how do you set permissions? On this Plugin?
  15. Offline

    Celtic Minstrel

    Could also be the built-in spawn protection. Go further away from your spawn point, or edit your to reduce the spawn protection.

    Oh hey, someone else who actually knows YAML! :D I'm not sure if negated permissions actually work, but you could try moving it to after the * permission.

    Huh, maybe it was a file permissions issue? An alternate would be to (on UNIX-based systems) cd into the server directory and run the following command:
    chmod -R u+rw .
    This is of course assuming that you run Minecraft as your login user, which probably isn't the greatest choice to begin with.

    (On Windows I'm not sure if file permissions could be an issue anyway, and if it can, I'm not sure how you'd fix it.)

    Well, you start by reading the instructions in the first post.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  16. Offline


    an hour later and still not working... can someone help me with this? =/

    I read all the instructions, i honestly don't know what im doing wrong.
  17. Offline


    Wait, so if I just have the .jar, when I start the server, does it create the Permissions folder automatically?
  18. Offline


    aperently it doesnt, which is what is causing me all sorts of problems because i have no idea what my world is called... ive just been assuming its "world"
  19. Offline


    Go to your minecraft server folder. There's another folder in there called "plugins". Are there any other folders?

    If you're just starting permissions, use the .zip! The jars file generation is bugged.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  20. Offline


    i dont have access to the root directory (its a hosted server)

    also, i banged my head against the keyboard long enough and something finally fixed it, i have no idea what i did but it works now
  21. Offline


    Will permissions convert nicely from the latest GroupManager?
  22. Offline


    I appreciate your thought, but I am familiar enough with my OS to understand permissions and ownership. I've tried chmod/chown. Before i removed the files, they were all chmodded 777 and owned/run by the user minecraft. At the moment, they're still chmodded 777 (worry not, it's because i edit things with a GUI based text editor every 2 minutes). I deleted the "minecraft" user and group and replaced it with "service" just for good measure, though. I was pretty fed up at that point.

    The issue started when i updated to the first 1.4 compatible CB build. Later, even with new permissions.jar and fresh default world.yml, it still wouldn't bite. I don't know what was wrong, but i'm happy enough it works now :)
  23. Offline


    Having some issues getting permissions setup correctly. The only plugin im using that ties into Permissions is AdminCmd v4.3 .My YML file is here

    What i really need is the permission to reload the permissions.
  24. Offline


    I've tried that several times, and no avail. Do you mind posting any screen-caps of your directory, or whatnot? Maybe because I'm running off the run.bat and "SNAPSHOT.jar" (617) it's causing issues?

    Also, are you running any other plugins along side permissions at this time? Essentials?
  25. Offline


    We really need the ability to change world configuration options on a copy with negative or positive permissions.

    Sorry to say that atm theirs no point in having a copy or saying its multiworld compatible for assigning permissions when you cant do anything with multiworld currently unless you don't use the copies option.

    Guys please research and learn permissions and don't pm people especially admins of other servers to give you personal help.

    I'm seeing too many noobs in the thread I'm sure the developer is getting a little tired of it.

    Its good you all are wanting to use permissions but allot of the questions are answered in all the plugin threads you get your plugins from on what nodes to use and how to use permissions is right at the top of this thread.

    If you get permissions not loading its normally because your file is incorrectly formatted.

    And the developer could be missing proper support requests like mine with multiworld permissions or serious bugs and feature requests for his plugin.
  26. Offline


    Hi all, I myself with Ukraine on this and not read in English and I have a problem.
    As soon try to build something that the server writes the following text: (Help established the problem, please: (
    After starting in Plugins folder create another folder Permissions, which is empty and I've found Permissionsworld.iml which is also empty. Server runs as windows, and on Linux

    I'm sorry, all pekst I translated using Google Translator:)

    [SEVERE] Could not pass event BLOCK_BREAK to Permissions
            at com.nijiko.permissions.Control.getGroups(
            at com.nijikokun.bukkit.Permissions.Listener.onBlockBreak(
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.ItemInWorldManager.d(
            at net.minecraft.server.ItemInWorldManager.b(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
            at net.minecraft.server.NetworkManager.a(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(
  27. Offline


    I've got a question for setting up the yml
    I want to set each players country that their in and their rank so for example i want to put mine as


            default: false
                prefix: '&4'
                suffix: ''
                build: true
                - '*'
            group: Owner
                prefix: ''
                suffix: '&4U&fS&1A'
    but everytime i set it up the USA is combined with owner like this [Owner USA]
    How should i go about setting this up? Or is it even possible. We have a few different nationalities in our server and it would be nice to see what country their from :D

    Any help would be much appreciated

    Btw, Code is obviously not complete. That is just my user settings and my Owner rank.
  28. Offline

    Geko X

    @Itssnowing: Here is my config

            default: true
                prefix: '&7CowSlayer'
                suffix: ''
                build: true
                var1: '[+world]
                - ''
                - ''
                - 'war.player'
                - 'war.warp'
                - 'warpz0r.home'
                - 'warpz0r.sethome'
                - 'warpz0r.worldhome'
                - 'deathmessageplugin.*'
            default: false
                prefix: '&3*M*'
                suffix: ''
                build: true
                var1: '[+world]
                - Player
                - ''
                - 'war.*'
                - 'humiliation.*'
                - 'honeypot.*'
                - 'itemid.usecmd'
            default: false
                prefix: '&1*M+*'
                suffix: ''
                build: true
                var1: '[+world]
                - Mod
                - 'npc.*'
            default: false
                prefix: '&4*A*'
                suffix: ''
                build: true
                var1: '[+world]
                - '*'
            group: Admin
            group: Mod+
                prefix: ''
                suffix: ''
                - ''
            group: Mod+
                - ''
            group: Mod
                - ''
            group: Mod
                - '' 
    This is the same config that I used for CB556, and it worked perfectly then.
  29. Offline


    I recently got bukkit installed but I am having problems with this Permissions installation...

    When I extract the contents into my plugins folder all I get is "Permission.jar" "CHANGELOG" & Folder "Permissions" with a "RENAME-ME.yml" file in it... Where do I configure things? :S
  30. Offline


    RENAME-ME.yml is the config, it needs to have to name of your world so just change it to the exact spelling of your world :D.

    But since permissions v3 is coming soon this version doesn't work probably to my knowledge, and if it does could someone please explain why every command says i don't have permissions?
  31. Offline



    Please, Help ME!!!!!!
Thread Status:
Not open for further replies.

Share This Page