Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    Please can you update for #456? ( New/changed API PLAYER_COMMAND_PREPROCESS ) Currently your 2.4 is outdated. I wait you for my plugin, thx.
  3. Offline


    Just checked, current recommended build is 440, thus, this plugin is NOT outdated.
  4. Offline


    I'm trying to make Permission work with Iconomy, but for some reason i can't get this to work. I have tried this for hours now, without success. So a video walk through or a detailed tutorial would be nice.
    In advance thanks!
  5. Offline


    Versions and console errors?
  6. Offline


    Sorry i was not see the little green star "recommended", it's ok i gonna wait.
  7. Offline


    I agree with what some other people have said, this plugin needs an in game modification.
  8. Offline


    the Bukkit crew has said they're adding permissions... but, I think that's been an ongoing claim :)
  9. Offline


    Ok, I've pulled permissions.jar and the world.yml from another server that is working, and I still get the same error message... :eek: Must not be a problem with permissions?
  10. Offline


    I mean, we can hold out on them forever or take the time to do it ourselves until they have time to do it. I know that the modify in game is a rather simple process. The original permissions never did it and everytime it was brought up nothing was done about it. I just hope this creator doesnt do the same. On a server with over 150 players it is NOT fun to go in and edit the mail file from the server using RDP every time a person needs a group change. Before somebody goes and calls me lazy, its called efficiency and wasting 2 - 5 min each time to do one persons edit is certainly not efficient.

    So, i beg for /modify!!!
  11. Offline


    @TheYeti Thanks so much for picking this up, my players thank you as well!
  12. Offline


    I've deleted everything in the plugin, so i could get a "clean" console. I'll go and look in the server.txt and see if i can find anything.
    --- merged: Feb 27, 2011 8:32 PM ---
    This server is running Craftbukkit version git-Bukkit-unknown (MC: 1.3)
    2011-02-27 16:39:40 [INFO] Preparing level "NyGamereactor"
    2011-02-27 16:39:40 [INFO] Preparing start region
    2011-02-27 16:39:41 [INFO] Preparing spawn area: 32%
    2011-02-27 16:39:42 [INFO] Preparing spawn area: 89%
    2011-02-27 16:39:42 [INFO] [Permissions] version [2.4] (Phoenix) was Initialized.
    2011-02-27 16:39:42 [INFO] [iConomy] Logging is currently disabled.
    2011-02-27 16:39:42 [SEVERE] PLAYER_COMMAND (Is it up to date?)
    java.lang.NoSuchFieldError: PLAYER_COMMAND
        at com.nijiko.coelho.iConomy.iConomy.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.d(
    I'm not sure if i have done this right.
  13. Offline


  14. Offline


    can you do this for me please?
    I don't know what I must do now >_>

    when I use my world.yml, and when I restart my Server, I get this Error:
    Edited world.yml file:

    Please help >_>
  15. Offline


    This error is from CB build 454+ so just back down to 453 or lower and you'll be set.
  16. Offline


    This is not really directed at anyone in particular, but I'm not really sure where else to put this.
    If ever there was a need for a standardized Permissions plugin, now is the time. Between Permissions 2.0, Permissions 2.1, Permissions 2.2 Unofficial, Permissions 2.4, GroupManager and EssencialPermissions, such a necessary framework is so fragmented between different plugin developers that it's effectively impossible for a server admin to use all the plugins they want to. :/
  17. Offline


    I'm so confused on this error I just got. I searched for it and it led me here.
    I'm using essentials group manager. I tried to add an admin but when I started it it glitched up...

    I keep getting this cannot read group manager file. Here is my code that I have in data.yml.

        permissions: ['*']
        group: Admins
        permissions: ['*']
        group: Admins
        permissions: ['*']
        group: Admins
        permissions: ['*']
        group: Admins
        permissions: ['*']
        group: Admins
        default: true
        permissions: [essentials.spawn, essentials.motd,, essentials.home,
        inheritance: []
        info: {prefix: '', build: true, suffix: ''}
        default: false
        permissions: ['*']
        inheritance: [Moderator]
        info: {prefix: '', build: true, suffix: ''}
        default: false
        permissions: [, essentials.tphere, essentials.item, essentials.give]
        inheritance: [Default]
        info: {prefix: '', build: true, suffix: ''}
      permissions: {system: default}
  18. Offline


    Ehm not to be newbish but what is Cb build? [​IMG]
  19. Offline


            system: default
            copies: '*'
    should work, shouldn't it?
  20. Offline


  21. Offline


    Could anyone give me install instructions, or how to upgrade from v2.0?
    rct2guy likes this.
  22. Offline


    This is the only official plugin under the "Permissions" name, all the forks are unapproved. Nijikokun officially handed it over to TheYeti, so all of Nijikokun's versions are no longer supported either.
  23. Offline


    Could someone please help me? For some reason none of the addons are loading either...
    Also...a fire broke out due to no fire protection so I am having to temporarily shut down.
  24. Offline


    no, copies needs to have the world name it copies from, or be left blank
    --- merged: Feb 27, 2011 9:07 PM ---
    if no plugins at all are loading, that sounds like you're using Bukkit 456
    roll back to the Bukkit team's recommended build 440
  25. Offline


    try it, i havnt tried this option yet...
  26. Offline


    Like i told before, it's cuz you have a version who use not anymore "PLAYER_COMMAND" (probably #456+) you need to rollback your version to 440. That why i want TheYeti up to date him plugin with new API. lol aw my bad its from iConomy :/
  27. Offline


  28. Offline


    iConomy is throwing the error, not Permissions this time :)

    @TheWallPainting iConomy is using PLAYER_COMMAND, you're using a version of Bukkit in which PLAYER_COMMAND was removed. Please use the Bukkit team's recommended build (440)
    --- merged: Feb 27, 2011 9:22 PM ---
    haha nm, you got it :)
  29. Offline


    So, if I was running the original Permissions, do I just replace the old JAR with this one? Or do I have to change other stuff too?
  30. Offline


    Some plugins dont work and I dont know what happends... (Like iZone, worldguard, etc)

    Can someone please support me, thanks!
  31. Offline


    i load this on my server i downloaded the .jar, and it created the permissions folder, but there is nothing inside of it. and when someone talks it just has [] NAME: any help?
Thread Status:
Not open for further replies.

Share This Page