Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    dont know witch /mod command u mean, i dont have any plugin which use it, so the servert says unknown command.
  3. Offline


    ok yeti ty but i wont downgrade my server for permissions guess i gotta use essentials (too whome stole permissions for them selves) :( well thanks anyway mate you can contact me on my youtube channel Exspelcraft
  4. Not working for me:(
    no errors except could not pass to iChat
  5. Offline


    what is not working? could u use any command?
  6. No, I can't use any commands and I am using the recommended build 440.
  7. Offline


    Alright. I need some serious help. My server has taken a serious hit from the new Minecraft update, breaking nearly all my plugins. None of my commands were working so I then checked and realized my essentials jar had magically disappeared. So I reinstalled it, and now anytime someone tries to use the commands, its says they aren't allowed. Here's my Config.Yml in .txt form so I can upload it.

    Attached Files:

  8. Thx, works on #440 :)

    Edit :
    For those that can't get it work on 440, be sure to redownload the 2.4 version, and to rename "config.yml" into "yourworld.yml" where 'yourworld' shall be the name of the world you want to set the permissions to.
  9. Offline


    1. is the .yml file renamed to ur default world?
    2. do u use tabs? only use 4spaces instead of tabs.
  10. THANK YOU!!!
    Changing config.yml to world.yml in the Permissions folder fixed it :D

    OP You should put this at the top!
  11. Offline


  12. That isn't there on the .yml, that is on the spawnmob node.
  13. WHen do u think, will come a MySQL Supported VersiON?
  14. Offline


    I tried to upvote you when I read Herpina and Derpina in the config.yml, but I realized it wasn't reddit xD

    Also, I get this error-

    16:12:41 [INFO] [Permissions] version [2.4] (Phoenix) was Initialized.
    16:12:41 [SEVERE] PLAYER_COMMAND (Is it up to date?)
    java.lang.NoSuchFieldError: PLAYER_COMMAND
            at com.bukkit.intelli.antibreak.AntiBreak.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.d(
    I'm not sure if this is a problem with Permissions or with Antibreak.
  15. Offline


    @txtsd Thanks for the orangered. ;) Also, pretty sure that is a problem with AntiBreak. Only reason that Permissions is even mentioned is because it tries to initialize itself as soon as possible so that other plugins will be able to see it and hook into it quickly.
    txtsd likes this.
  16. Offline


    When I try to use the /permissions -reload all I get the following error message.

    2011-02-26 23:55:34 [WARNING] Unexpected exception while parsing console command
    org.bukkit.command.CommandException: Unhandled exception executing command 'perm
    issions' in plugin Permissions v2.4
            at org.bukkit.command.PluginCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.MinecraftServer.b(
            at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.NullPointerException
            at com.nijiko.permissions.Control.permission(
            at com.nijikokun.bukkit.Permissions.Permissions.onCommand(Permissions.ja
            at org.bukkit.command.PluginCommand.execute(
            ... 6 more
  17. Offline

    Matt L

    Does this build support anti-build?
  18. Offline


    @Cweggz The line in question should have no problem what so ever. The only thing I can think of, are you running this in game or from the console? After looking it over I can see how this would actually cause errors if ran from the console and I need to fix that. However, unless your name is a null in game (That should NEVER happen) then this error should be generating.
    --- merged: Feb 27, 2011 12:06 AM ---
  19. Offline


    It's ran from the console due to in game telling me I don't have permission to use it. Even after trying multiple times of trying to fix the code in the .yml file. (Putting my username in the "User" section) I go in game and type the /permissions -reload all command and it tells me I don't have permission.
  20. Offline

    Matt L

    where is the latest build download? Nikki's servers are no longer hosting files...
  21. Offline


    Is that version support 451+, because I get the same error of @Springrolls :(
  22. Offline


    Just woke up, post your .yml on or something and I'll give it a once over just to make sure.
  23. Offline


    This obviously isn't my final .yml, merely what it will be until I find a way to make it work.
  24. Offline


    Never have Admin inherit ANYTHING if you've given it " - '*' ". Giving Admin all commands with '*' and then having it inherit something will call an error and cause no admin commands to work. So take away the -Default inheritance and it should work fine.
  25. Offline


    It still isn't working :/, would you like to teamview to see it personally?
  26. Offline


    really sounds like there needs to be an extra level of checking to strip those redundancies and prevent the error
  27. Offline


    Sure just pm me the info.
  28. Offline


    done so
  29. Offline

    Matt L

    does anyone have a solution to anti-build? how can is top griefers?
  30. Offline


    Been trying FOREVER to install this.. can u PLEASE help me? >.<
    2011-02-26 17:29:38 [SEVERE] ENTITY_DAMAGEDBY_ENTITY (Is it up to date?)
    java.lang.NoSuchFieldError: ENTITY_DAMAGEDBY_ENTITY
            at zerodps.iMonster.iMonster.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginM
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.d(
Thread Status:
Not open for further replies.

Share This Page