Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    then yedit, fakepermissions or essentials groupmanager? because the structure isnt from permission, permissions use an other structure
  3. Offline


    yedit but is just a editor no ?
  4. Offline


    ok yes ur right, ok, then i dont have a guess, could u try to start the server without essentials? maybe this causes a problem...
  5. Offline


    13:31:44 [SEVERE] Could not pass event BLOCK_PLACED to Permissions
            at com.nijiko.permissions.Control.getGroups(
            at com.nijikokun.bukkit.Permissions.Listener.onBlockPlace(
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.ItemBlock.a(
            at net.minecraft.server.ItemStack.a(
            at net.minecraft.server.ItemInWorldManager.a(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet15Place.a(SourceFile:57)
            at net.minecraft.server.NetworkManager.a(SourceFile:230)
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(
    Currrent builds of both bukkit + permissions plugin :(
  6. Offline


    I try start the server without essentials and the problem still there
    i no understand
    thx for help ;)
  7. Offline


    Thank you for updating this to these builds! I can finally have permissions (and therefore most of the plugins) on my newly Bukkit-ified server!
  8. Offline


    ok i too dont understand, maybe ask in the yedit thread maybe its a problem with this...
    --- merged: Mar 4, 2011 1:58 PM ---
    i dont know, maybe theyeti could help
  9. Offline


    hmm i dont see any errors

            default: true
                prefix: ''
                suffix: ''
                build: true
                - 'general.'
                - 'essentials.home'
                - 'essentials.sethome'
                - 'essentials.spawn'
                - 'lwc.protect'
                - 'iConomy.payment'
                - 'iConomy.rank'
                - 'iConomy.list'
                - 'essentials.list'
                - 'essentials.helpop'
                - 'essentials.msg'
            default: false
                prefix: '&1[&1Mod&1]'
                suffix: ''
                build: true
                - Default
                - 'lwc.mod'
                - 'essentials.jail'
                - 'essentials.kick'
                - 'essentials.ban'
            default: false
                prefix: '&4[&4Admin&4]'
                suffix: ''
                build: true
                - '*'
                - 'iConomy.admin.grant'
                - 'iConomy.admin.set'
                - 'iConomy.admin.stats'
                - 'iConomy.admin.reset'
                - 'lwc.admin'
                - 'lwc.blockinventory'
                - 'cleaner.*'
            default: false
                prefix: '&c[&cWolf&c]&f'
                suffix: ''
                build: true
                - Default
                - 'iConomy.payment'
            default: false
                prefix: '&e[&eDonater&e]&f'
                suffix: ''
                build: true
                - Default
                - ''
                - 'essentials.tpahere'
  10. Offline

    Jandalf is down wait or put it in coede tags here...
  11. Offline


    I remove all plugin except permissions and the problem still there
    I'm lost
  12. Offline


    The problem is , I'm running 2.5.2 and its reporting errors that the changelog suggests where fixed in 2.5.1.

    Is there a list of known plug in incompatibilities? The only thing I can possibly think is that maybe one of the other plugins I have includes an embedded copy of permissions, but its all pretty standard here:
  13. Offline


    ok u've got an overload, when u use '*' dont give that group or people any other permission, cause they already have all
    --- merged: Mar 4, 2011 2:31 PM ---
    ok, maybe make an new cb server, copy ur world and start again, i dont have any idea what it could be-.-
  14. Offline


    Tested against

    and a multitude of other plugins - seems to work fine.
  15. Offline


    switch back to 2.5.1 for the first, 2.5.2 makes some problems and i dont know any incompabilities with this plugins...
  16. Offline


    thanks that worked =]
  17. Offline


    Yes, compatible with Multiverse.
    Be sure you've the right versions or each, check your server log.
    From my server log:
    2011-03-04 09:26:29 [INFO] [Permissions] version [2.5] (Phoenix) was Initialized.
    2011-03-04 09:26:30 [INFO] [MultiVerse] Permissions Found
    2011-03-04 09:26:30 [INFO] [MultiVerse] - Version 1.4 (Permissions 2.1) Enabled
  18. Offline


    Yeah, that doesn't seem to fix it :(

    edit: Ok, I've definately isolated this as a Permissions.jar problem. I removed *all* plugins except for Permissions, re-downloaded craftbukkit
    14:43:44 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-493-g8b5496e-b493jnks (MC: 1.3)
    and still get the problem .

    For reference, here is my config.yml (with comments stripped)
            system: default
            default: true
                prefix: ''
                suffix: ''
                build: true
                - 'general.spawn'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Default
                - '*'
             group: Admins
             - '*'
         (removed other player for privacy!):
             group: Admins
             - '*'
  19. Offline


    I make a new server
    install permissions
    make the new config file

    And the problem still there
    I stop me investigation :( and wait a news update or news informations

    Thx all for help
    monday it's new week maybe a new solution ;)
  20. Offline


    Craftbukkit 493 and permissions 2.5.2 dont work, craftbukkit 493 and permissions 2.5.1 do work.
    Also the download link of the jar only of 2.5.1 downloads version 2.5. This may be causing problems.
    Try downloading the zipped 2.5.1. Works for me.
  21. Offline


    Have patience my friend. Some of these plugins have to get deep into the guts of an obsfucated minecraftserver base that presents a constantly moving target, and the plugin authors are just volenteers.
    --- merged: Mar 4, 2011 3:26 PM ---
    Yeah that doesnt seem to solve the problem with the BLOCK_BREAK/PLACE errors (which seem to spring from getGroups(xxxxx)
  22. Offline


    try out this its a complete CB-server with craftbukkit and general(outdated but works) so u can build an this...
  23. Offline


    Maybe this is because you don't have a properly named permission file? The permission file have to be the same name as the world you are in. Maybe the bug is similar to my rejected one.

  24. Offline


    I can't seem to get this plugin working. Here is my config file: <Edit by Moderator: Redacted mediafire url>
    Last edited by a moderator: Dec 15, 2016
  25. Offline


    Last edited by a moderator: Dec 15, 2016
  26. Offline


    What is the permission code for the original /tp Player1 player2 command ?
    please !!
  27. Offline


    this is not supported by any plugin, try general for that
  28. Offline


    Here it is at pastebin. Also, the level name in the is hgsbackup/braveworld. I can't rename it. I tried deleting the 'hgsbackup/' but it reverted back to its previous state. And I can't have a '/' in my config file name. Is this the problem?
  29. Offline


    yes that is, stop the server, put the braveworld folder into the CB main folder and delete the 'hgsbackup/' in the serverproperties and start again
    --- merged: Mar 4, 2011 5:36 PM ---
    and u must use ' ' around the prefix too
  30. Offline


    Ehm, i would need some help: i have added 2 friends to moderator but it seems that only 1 of my friends are in moderator and the other in default? would be glad for help if someone knows how to edit so he go into moderator too
  31. Offline


    please copy ur permission file to
Thread Status:
Not open for further replies.

Share This Page