Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline


    That has nothing to do with a new release of CraftBukkit. It actually lists the exact error in the log.
    Caused by: mapping values are not allowed here
     in "<reader>", line 98, column 20:
                     prefix: ''
    Now figuring out what that means is a bit harder but in this case, you forgot to put an info: after QUBiCA's group and before the prefix. They are also spaced over 1 extra space (the prefix and suffix that is).
  3. Offline


    im getting this error and it wont respond to any of my settings.
    00:57:30 [SEVERE] Error occurred while enabling Permissions v3.0 (Is it up to date?): null
        at com.nijikokun.bukkit.Permissions.Permissions.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
  4. Offline


    Well, i want to chane prefix and suffix only to one person without adding a group. When i'm tried to do this, just modify prefix and suffix in the users list, system just show me old prefix and suffix. So, could i edit prefix\suffix to one person, without adding new group?
  5. Offline


    Download a new copy of 3.0. I just fixed this bug.
    What version of Permissions are you using?
  6. Offline


    Had big problems with build #803 of Craftbukkit. 2.7.4 and #803 stopped my Default group working, and #803 and 3.0 stopped all Permissions working, so I'm rolling back to #798.


    Not sure what I'm doing wrong, but build #798 and Permissions 3.0 still disabled all of my permissions. I switched back to 2.7.4, and everythings working fine now.
  7. Offline


    Did you make the changes described in Transitioning from 2.x to 3.0? If then, post the group and user configs.
  8. Offline


    Ok I'm so mad right now I JUST found out I need java 1.6 for this to work and there's no bloody 1.6 for Mac :mad:
    Any idea of how to get 1.6 for Mac?
  9. Offline


    From the Java download page. Hope that helped.
  10. Offline


  11. Offline

    Legend Hoods

    Great plug-in!

    Question: I got the nodes
    And how can I make my Moderators to not be able to use them. Because they do need to be OPs, I can't figure it out.
    The group is Moderator.

    Thanks! :D
  12. Offline


    Just don't add them to your moderator group or any group they can inherit from
  13. Offline

    Legend Hoods

    I did, but they can just use it...
  14. Offline


    rcjrrjrc, Tried latest permissions again today prefix wasn't working with essentials chat 2.2 the term 'GROUP' wasn't pulling the info.

    Main thing Is how do we use the global groups and users with the world inheritance in storageconfig.yml?

    Still trying to work out the new permissions after leaving it a bit as there's not enough info for the setup I'm wanting to do which is.

    Inherit all users and there groups from global users.
    Inherit all groups permissions from global groups
    Then inherit for 2 subworlds from a primary main world that we have are going to have as 1 system.
    Add or subtract extra permissions for all the world groups.

    Pretty much this in flow chart.

    Users (Global)
    - Inherit automatically all worlds (reg a user they get global world access and permissions)

    Groups (Global) (inherit and change per world)
    - Inherit all primary worlds
    - Real Main world
    |- Inherit to sub world 1
    |- Inherit to sub world 2

    If a new user joins up, I want to be able to do a simple command and add them once to global users and then they get the same grouping "Member' on ALL 6 worlds with whatever I have the permissions I have for member on that world which will be different.

    We have been awaiting this permissions 3 for a while to do this and its frustrating when I can set stuff up kinda now but due to lack of advanced info on all the permissions 3.0 features in these areas, I cant.

    You are overall doing a great job on the plugin btw.
  15. Offline


    I kind of figured it out. I have to put the commands inside of my user and groups tab and implement them that way. I got it rolling last night after many hours of racking my brain. Never got permissions working however ended up installing another plugin and went that route. I just updated bukkit and now my /give commands are not working.....grrrrrrr..........any ideas?
  16. Offline

    Legend Hoods

    OP yourself. :)
  17. Offline


    op did not work but thanks for your help! :D
  18. Offline


    Anyone can tell me, how to give only a certain player a prefix?
          prefix: '&b[Admin] '
  19. Code:
            group: Admins
                prefix: '&b[Admin]'
                suffix: '&f'
    That's how I do it
  20. Offline


    Can someone help me out? I configured my world.yml file the correct way. I know because the checking website didnt read any errors. I made my self an admin, because well I host the server and I own it. However when I get in the server I can use certain mods(ibicf and yeditor) because the server tells me that I do not have the permission to use it. I dont understand what I'm doing wrong. Can someone help me out here? :(
  21. Offline


    16:55:33 [SEVERE] Could not load 'plugins\Permissions.jar' in folder 'plugins':
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
    Caused by: while scanning an alias
     in "<reader>", line 91, column 16:
                    - '*'
    expected alphabetic or numeric character, but found but found '
     in "<reader>", line 91, column 17:
                    - '*'
        at org.yaml.snakeyaml.scanner.ScannerImpl.scanAnchor(
        at org.yaml.snakeyaml.scanner.ScannerImpl.fetchAlias(
        at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(
        at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(
        at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(
        at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
        at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
        at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeDocument(
        at org.yaml.snakeyaml.composer.Composer.getSingleNode(
        at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(
        at org.yaml.snakeyaml.Yaml.load(
        at com.nijiko.configuration.NotNullConfiguration.load(
        at com.nijikokun.bukkit.Permissions.Permissions.<init>(
        ... 13 more
    Could you help me with this?

    EDIT: I got that working now, but now it says my ranks are not defined, that is what I need help with
  22. Offline


    Thanks for the help. I couldn't figure out what was wrong, but now I know what that meant. I really do appreciate it.
  23. Offline


    Well, if you know your file is configured correctly then the only things left to look for are if you are running v2.7.4 of Permissions and if you named your file correctly. The file should be in the plugins\permissions directory and named <world name>.yml or just <world name> if you have file extensions turned off.

    You have a problem in your permissions.yml file at or around line 91. Post your permissions file and we can take a look.

    Being in the OP list gives you a lot of permissions to plugins just by itself. If you don't want them to have these and have it only controlled by Permissions, you need to remove them from the ops.txt file.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  24. Offline


    I am having a problem, I have set up my permissions and there do not appear to be any errors, but when I try to do anything in game it say's I do not have permission to. All the names are correct but nothing works.

        system: 'default'
        default: false
          prefix: '&normal'
          suffix: '§multiplay'
          build: true
        inheritance: ''
          - '*'
        default: true
          prefix: ''
          suffix: ''
          build: true
        inheritance: ''
        default: false
          prefix: ''
          suffix: ''
          build: true
          - 'Default'
        group: 'Admins'
            prefix: ''
            suffix: ''
        group: 'Admins'
        permissions: ''
    I am getting this in the log file though:
    2011-05-23 17:16:56 [SEVERE] null loading Permissions v3.0 (Is it up to date?)
        at com.nijikokun.bukkit.Permissions.Permissions.onEnable(
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
  25. Offline


    If you look carrefuly you will see group citizen has inherits from default groups , i've try with and without and it dosent work :x
  26. Offline


    The permissions.yml file you listed there is a 2.7.4 file but you are running 3.0. I would either read the conversion document from 2.7 to 3.0 or roll back to 2.7.4.
  27. Offline


    PLEASE help me! I used the online YAML parser and this was my error:
    while parsing a block mapping in "<unicode string>", line 61, column 5: Default: ^ expected <block end>, but found '<block mapping start>' in "<unicode string>", line 71, column 6: Member: ^"
  28. Offline


    You'll need to post the file in code blocks or on
  29. Offline


    i cant wait for 3.0 to be the stable version... god i love sql.
  30. Offline


    Oh it was this simple. I thought this was plugin related, but apparently it wasn't. Thanks!
  31. Offline


    Yes I tried that but still no 1.6?
    Download link PL0X?
Thread Status:
Not open for further replies.

Share This Page