Inactive [ADMN/DEV] Permissions v2.7.4 (Phoenix) - DISCONTINUED! 3.0 has a new home!

Discussion in 'Inactive/Unsupported Plugins' started by TheYeti, Feb 25, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 2.7.4 (Phoenix) - Now with AntiBuild built in!
    Latest Stable: Full Zip | Jar Only
    Latest Dev Build: Full Zip | Jar Only
    Previous Versions: 2.7.3 (JAR) | 2.7.2 (JAR) | 2.7.1 (JAR) | 2.7 (JAR) | 2.6 (JAR) | 2.5.5 (JAR) | 2.5.4 (JAR) | 2.5.3 (JAR) | 2.5.2 (JAR) | 2.5.1 (JAR) | 2.5 (JAR) | 2.4 (JAR) | 2.3 (JAR) | 2.2 (JAR)

    Plugin Authors: How to hook into Permissions

    Permissions 2.x is being discontinued! 3.0 can be found HERE!!!

    I am discontinuing Permissions 2.x and leaving the project. Permissions is not going away though! Since 2.6 I have been working closely with another developer and added them to the team. For the past several version they have not only been assisting with 2.x but also doing a lot of the development of much anticipated 3.x. rcjrrjcr will be taking over as lead developer of Permissions from 3.x forward. I have full faith in them and after working closely with them on the development on the last few version and the next major version I feel that I am leaving this project in more than capable hands. I put way to much work into this project to just leave it with anyone, and this is one of the few programs that I am incredibly proud of.

    Many people will probably wonder why I am leaving again after taking over the project just a few months ago. I could quote drama and headaches, of which there were quite a few with this project. Unfortunately real life happens. Many people already know that I have been having medical issues here lately. Unfortunately while they have gotten better, they have not gone away. This coupled with other real life commitments, going to school full time, and starting up my own company, I am currently in the process of being laid off from work. At this point I have so much stuff going on in my life and am being pulled in so many directions that I am not able to get any work done on anything. This has lead to me missing commitments and letting people down on multiple things.

    Permissions is also a very high maintenance plugin that requires a lot of attention and time. Right now I am not able to devote that time and do not feel it is fair for me to try to continue to be the lead developer on it. I had originally thought that adding other members to the team would be helpful, but unfortunately this just lead to frustration for them and myself as I just was not able to commit to the project enough. Hence, 3.0 has been rewritten almost exclusively by rcjrrjcr with minimal contributions by myself.

    At this point I will be stepping away from the project to focus more on real life and to try to free up some time for other projects and to work with more individual like the wonderful HeroCraft Coding team to fulfill some commitments that I made to them a long time ago and sadly did not come through on. I feel that this is the best for all involved, both myself and the other Permissions developers, as well as the community who deserve someone who can contribute more time and attention to them and supporting them. I do not want to see Permissions end up like many other plugins with an absentee programmer and just slowly wasting away from a great plugin with a lot of potential to a headache with no support.

    I will still be active in the community, just not as much as not in the same way. I'm sure my server will be more than happy to have their head admin back and active again as well.

    Thank you and happy gaming.

    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems
    • 2.6
      • Pulled in commits by rcjrrjcr
      • Fixed versioning. Last version should have technically been 2.6
      • Fixed invalid config file being written
      • Fixed erroneous conversion message.
    • 2.5.5
      • Updated to be compliant with CB600+
      • Further Maven Integration and Autobuilding
      • Better handling of configuration file errors.
        • If you do not have a world config file for the default world at startup it will now look for config.yml
        • If it cannot find that it will look for world.yml instead in case you named it that when that is not what is in level-name:
        • It will rewrite the config file to be the proper name. At this time it does not delete the old one though.
      • Removed defunct public abstract calls. If your not using the right one by now you should be shot anyway.
    • 2.5.4
        • Added Command aliases for perms and pr
        • Changed the way directories are handled.
        • Stopped it from creating an empty <world>.yml file in base directory
        • Moved project to using Maven.
    • 2.5.3
      • Change from File.pathSeparator to File.separator to fix multiworld perms
    • 2.5.2
      • Added more instructions to the included config file within the plugin
      • Added a check that will use the default world permissions if a world specific config file cannot be found.
      • Added a function to get only the group that a player is assigned to without checking for group inheritance.
      • Added a change to colorize() to fix it hopefully not adding an extra unneeded ascii character and thus creating a linebreak/color switch issue
      • Removed as it was not needed and was a artifact of testing I was doing.
    • 2.5.1
      • Fixed a bug that could cause a group to be returned as null for getGroups()
    • 2.5
      • Added in AntiBuild functionality to Permissions
      • Minor code tweaks
      • Added getGroups(world, player) to PermissionHandler so that plugins can call it to get all of a users groups
      • Fixed the inability to use the permissions -reload all command from within the console. I still need to do some more work on this as it doesn't seem to like to accept anything other than all from console.
    • 2.4
      • Refactored namespaces to keep in line with Java & Bukkit policy
        • This was cancelled as it ended up being not needed
      • Fixed setupPermissions()
    • 2.3
      • Undid removal of some code that I had overzealously purged during cleanup
      • Merged in last of Nijikokun's changes
      • Re-ordered the main class to attempt to fix the problems with Plugin API
    • 2.2
      • Developer change
      • Fixed reloading of configuration files
      • Moved commands to registering with plugin.yml
      • Commands now use onCommand instead of onPlayerCommand
      • Command is now /permissions instead of /pr
    mruczek, kahlilnc, Pii and 58 others like this.
  2. Offline

    Celtic Minstrel

    My guess is that you forgot the "- " (without quotes) in front of all the permissions, but without seeing your entire config I can't be certain. Pastebin and link it, please.

    Uhh... that's absolutely incorrect.

    As I understand it, WorldEdit will only use those permissions if Permissions is not installed. If you have no other plugin that uses Permissions, you can just remove Permissions and I think it should work. If you have other plugins that use Permissions, you will have to move that information from the WorldEdit config to the Permissions config. If it helps, the format is mostly the same.
    You're posting in the wrong thread. This thread is for Permissions, not WorldEdit. Go post that in the WorldEdit thread.
    I'd say test it and see. If it can't, just put this in your nether config:
        system: default
        copies: world
    (I think that's correct, someone want to verify?)
    No bug. You just need to put the name in quotes.
  3. Offline


    Answer for this please? :).
  4. Offline


    Anyone please?
  5. Offline


    Yes, that's the correct way of excepting commands.
    Need the whole log, not just your snipped portion.
  6. Offline


    Help please
  7. Offline


    Who is it saying that for? Everyone? Does anyone even in the default group have permissions for it?
  8. Offline


    Ok, here it is:

    2011-04-18 11:28:21 [INFO] Starting minecraft server version Beta 1.4
    2011-04-18 11:28:21 [WARNING] **** NOT ENOUGH RAM!
    2011-04-18 11:28:21 [WARNING] To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
    2011-04-18 11:28:21 [INFO] Loading properties
    2011-04-18 11:28:21 [INFO] Starting Minecraft server on IP-ADRESS
    2011-04-18 11:28:21 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-653-g9992fff-b677jnks (MC: 1.4)
    2011-04-18 11:28:22 [INFO] Preparing level "la_prats4"
    2011-04-18 11:28:22 [INFO] Preparing start region
    2011-04-18 11:28:22 [INFO] 144 recipes
    2011-04-18 11:28:23 [INFO] Preparing spawn area: 77%
    2011-04-18 11:28:23 [SEVERE] Could not load 'plugins\Permissions.jar' in folder 'plugins':
    java.lang.NoSuchMethodException: com.nijikokun.bukkit.Permissions.Permissions.<init>()
    	at java.lang.Class.getConstructor0(Unknown Source)
    	at java.lang.Class.getConstructor(Unknown Source)
    	at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    	at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    	at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    	at net.minecraft.server.MinecraftServer.e(
    	at net.minecraft.server.MinecraftServer.a(
    	at net.minecraft.server.MinecraftServer.d(
    2011-04-18 11:28:23 [INFO] [iConomy] Logging is currently disabled.
    2011-04-18 11:28:26 [INFO] [iConomy] v4.65 (Kenzi) loaded.
    2011-04-18 11:28:26 [INFO] [iConomy] Developed by: [Nijikokun, Coelho]
    2011-04-18 11:28:26 [INFO] LocalShops: Permissions not found.
    2011-04-18 11:28:26 [INFO] LocalShops: iConomy found.
    2011-04-18 11:28:26 [INFO] LocalShops: Loading shop GeneralStore
    2011-04-18 11:28:26 [INFO] LocalShops: Loading shop GoldExchange
    2011-04-18 11:28:26 [INFO] LocalShops: Loaded 2 shop(s).
    2011-04-18 11:28:26 [INFO] LocalShops: version 2.2.1 is enabled!
    2011-04-18 11:28:26 [INFO] [OddItem] 0.6.5 enabled
    2011-04-18 11:28:26 [WARNING] [OddItem] Permissions not found. Using op-only mode.
    2011-04-18 11:28:26 [INFO] [OddItem] Parsed 263 entries.
    2011-04-18 11:28:26 [INFO] [Questioner] v0.2 - Enabled
    2011-04-18 11:28:26 [INFO] [Towny] Database: [Load] flatfile [Save] flatfile
    2011-04-18 11:28:26 [INFO] [Towny] Using: iConomy, Questioner
    2011-04-18 11:28:26 [SEVERE] PLAYER_ITEM loading Towny v0.6 (Is it up to date?)
    java.lang.NoSuchFieldError: PLAYER_ITEM
    	at ca.xshade.bukkit.towny.Towny.registerEvents(
    	at ca.xshade.bukkit.towny.Towny.onEnable(
    	at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    	at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    	at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    	at net.minecraft.server.MinecraftServer.e(
    	at net.minecraft.server.MinecraftServer.a(
    	at net.minecraft.server.MinecraftServer.d(
    2011-04-18 11:28:26 [INFO] [OddGive] 0.8 enabled
    2011-04-18 11:28:26 [INFO] [OddGive] Permissions not found. Using op-only mode.
    2011-04-18 11:28:26 [INFO] Done (0.462s)! For help, type "help" or "?"
  9. Offline


    Hate to be another kid here complaining and asking for help, i've been good with permissions up until now. I tried to enable McMyadmin permissions integration, but it messed up my yml, so I restored my world.yml to a backup I made, and no plugins gain access to it. I have a limited log because of McMyadmin, and the only thing i see about permissions is Permissions: (Phoenix) was Initialized.

    Here is my world.yml

    Any help is greatly appreciated.
  10. Offline


    Only Admins can make them Defaults have no permission
  11. Offline


    Can a person be a part of multiple groups?
  12. Offline


    OK, so first, why not have an Admins group?
    Second, you'll want to put in
    prefix= ''
    suffix= ''
    before "build=" in each group's info, or you will have console spam for every time someone logs in.
    Third, remove the duplicate "- ''" and "- ''" permissions from the Default group, and also the -, as there is no such permission.
    Fourth, I'm assuming if you want the Default group to have this that you want every other group above to have it as well? If so, you'll want to put in
    - Default
    in each group after Default just before permissions: on the same indentation as permissions:.
    Fifth, are you sure you want the Default group to be able to create ChestShops?
    Have you tried doing a fresh download of the .jar?
  13. Offline


    Yes I want them to be able to sell to other players so yes ill get back to you in a lil to see if that works. Another Issue I'm having is that Multiverse is asking for permissions 2.1 and I have 2.7 I update Multiverse to no avail

    Still not working

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  14. Offline


    Ok, surprisingly that seemed to work as the error changed to me having a tab in my file, I fixed that and it work s now!
  15. Offline

    Celtic Minstrel

    Don't worry about that; it should work anyway.
  16. Offline


    Still dont understand what your saying...
  17. Offline


    Are there any entries in the server log that might put some light on this? Why don't you post that along with your current updated Permissions .yml.
  18. I dont know if this is a problem with essentials or permissions so I'm posting this on both.

    I have installed Permissions and Essentials (only the main one) and edited the permissions file for one rank as follows...
            default: false
                prefix: '&8'
                suffix: ''
                build: true
                - Traveler
                - ''
                - 'essentials.msg'
                - 'essentials.afk'
                - 'essentials.rules'
                - 'essentials.motd'
                - ''
                - 'essentials.list'
                - 'essentials.mail.send'
                - 'essentials.helpop'
    12 spaces from the front on the nodes, 4 spaces from the group name.

    Can anyone reveal the solution to this problem?
    I've ran this code through Online YAML Parser and there is no errors.
    Could someone point out where I'm going wrong please?
  19. Offline


    @ARavinMadMonkey No, not really, not without knowing what your problem is XD.
  20. XD im such an idiot (Thats probably the cause of the problem)

    When I or anyone else plays as that rank, when we try any of those command in game we get a message saying "You do not have access to this command."

    Now that I've stopped being an idiot, any idea why this is?
  21. Offline


    I use Brohoster so I dont have access to error logs -,-" I use notepad++ so I dont know what's wrong
  22. Offline


    Do I need to add any nodes on the admin group? Say if I download a plugin that I only want admins to have access to it? If I set myself as OP would that be the same as being Admin?
  23. Offline


    Hey its me again Permissions isnt stopping people from using LWC or anything else
  24. Offline


    No, but the - '*' node gives all permissions to Admins (usually Admins is the only group that has them).
    Some plugins have OP support, and some allow Admin permissions enabling based off of ops.txt, but for the most part, you just want to have yourself in the permissions Admins group.
  25. Offline


    Yo Malkierian can you join my teamspeak server so I can explain this
    port- 18877
  26. Offline


    Everythign is working fine accept the suffix and preffix does not seem to work. It is supposed to add a tag thing afte rtheir name when they talk isn't it?
  27. Offline


    Thank you for your answer Celtic Minstrel :)

    Last thing, is there a way to add a player in a group in game (or move him to another group) ?
    I know it's possible with GroupManager and it's actually the only reason I'm currently using it.
  28. Offline


    So does that mean that I don't have to add any plugin nodes to the admin group and admins are still allowed to use them even if I didn't allow any groups before it to?
  29. Offline


    Yo Malkierian can you join my teamspeak server so I can explain this
    port- 18877
  30. Offline


    Help my permissions arent working.

    This is my Permissions why isn't it working?

            default: true
                prefix: ''
                suffix: ''
                build: true
                - 'lc.shout'
                - 'lv.*'
                - ''
                - ''
                - ''
                - 'iConomyChestShop.command.iteminfo'
                - 'monsterhunt.usercmd.hunt'
                - 'monsterhunt.usercmd.huntscore'
                - 'monsterhunt.usercmd.huntstatus'
                - 'iConomy.getBank()'
                - 'iConomy.getBank().getAccount(player.getName())'
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - ''
                - 'parties.allow.join'
                - 'parties.deny.join'
                - 'parties.allow.create'
                - 'parties.deny.create'
                - 'essentials.who'
                - 'balance'
                - 'help'
                - 'list'
                - 'motd'
                - 'msg'
                - 'pay'
                - 'rules'
                - 'sell'
                - 'spawn'
                - 'level'
                - 'lvl'
                - 'buy'
                - 'money'
            default: false
                prefix: '&1'
                suffix: ''
                build: true
                - Default
                - 'Essentials.*'
                - 'WorldEdit.*'
            default: false
                prefix: '&a'
                suffix: ''
                build: true
                - '*'
            default: false
                prefix: '&a'
                suffix: ''
                build: true
                - '*'
    My users:

            group: Moderator
             group: Moderator

    and NO GROUP works. tried moderator , owner , admin none works besides the default group.
  31. Offline


    Hi, I have used this before but now I'm trying to update it. Ok so I downloaded the .jar, ran the server and checked my plugins directory. It created a folder with nothing in it and inside the root of the plugins folder it created this file Permissionsrealisticwold.yml. This file also has nothing in it. What am I supposed to do at this point?
Thread Status:
Not open for further replies.

Share This Page