Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Alright, I got everything to work EXCEPT promoting/demoting in-game.

    Any help? Tracks don't seem to work.
  3. Offline


    What would be the in-game command to add permissions to the globalGroups file? Also when using entry.addParent(group) what would the groups "world" have to be set as?
  4. Offline


    I have a odd problem.
    First off, Im going to give the code I am using for these:
    /Bukkit Server/plugins/Permissions/world/users.yml:
            - Admins
            permissions: []
            - Default
            - herp.derp
            - Default
            - -derp.derp
            - Default
            - -derp.derp
    /Bukkit Server/plugins/Permissions/world/groups.yml:
    # AntiBuild is included with this.  To disable a group from being able to build then
    # set the build: flag to false (build: false).  If you want a group to be able to build
    # then set it to true.
    # Groups can contain inheritance.
    #   To make a group inherit the permissions from another
    #   group simply place the groups name in the "inheritance:" like so:
    #   Example:
    #       inheritance:
    #           - Default
    #   Globalized Permission settings:
    #       If a permission contains periods (.) you can denote a globalized parameter:
    #           - 'foo.*'
    #       This will allow you to use all general commands.
    #   Single Asterisk denotes all commands:
    #       - '*'
    #   To exempt a node use the - prefix like so:
    #       - ''
    #   prefix: and suffix: do not do anything on their own.  You need another outside plugin
    #   such as iChat or HeroChat in order for these to do anything.
            default: true
                prefix: ''
                suffix: ''
                build: false
                - ''
                - ''
                - ''
                - ''
                - 'essentials.signs.sell.use'
                - 'essentials.signs.balance.use'
                - 'essentials.back'
                - 'essentials.back.ondeath'
                - 'essentials.tpa'
                - 'essentials.tpaccept'
                - 'essentials.tpdeny'
                - 'essentials.home'
                - 'essentials.sethome'
                - 'essentials.warp'
                - 'essentials.warp.list'
                - 'essentials.balance'
                - ''
                - 'essentials.afk'
                - ''
                - 'essentials.list'
                - 'essentials.mail'
                - 'essentials.mail.send'
                - 'essentials.nick'
                - 'essentials.gc'
                - 'tetris.use'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Default
                - ''
            default: false
                prefix: ''
                suffix: ''
                build: true
                - '*'
    Now the problem, I know that essentials is working because switching build off for default works, but the actual permissions don't. Players can still spawn items by typing /i item and all this good stuff. I know I have configured it correctly because I can make it so they cannot destroy or place blocks. Any help on this would be appreachated. Thanks.
  5. Offline


    I've noticed when playing around with promoting/demoting that I've only been able to get promoting working. My track is RisingPower and I have it in order of Default -> Trusted -> Mod -> Admin -> CoOwner.

    I've gotten that for someone who is already an Admin in "world", that the command would be
    /permissions ACStache w:world promote Admin RisingPower
    After doing this, checking the users.yml of "world" shows ACStache now as a CoOwner

    what I can't figure out is the demote function. I changed promote to demote and I've tried changing the parent parameter to Admin, Mod, and CoOwner but ACStache never changed from CoOwner group in the users.yml. So:
    /permissions ACStache w:world demote CoOwner RisingPower
    since I'm trying to remove ACStache from the CoOwner group on the track.

    well... thinking about it now I'm fairly certain i changed promote to demote... let me get back on that one after I check the server logs.
  6. Offline


    Make sure to tell us the results of your testing-- I too need to get promotion/demotion working and it still doesn't seem to be working.
  7. Offline


    yes this happens to me as well but I have no permissions typed in and they can still use all commands HELP US
  8. Offline


    Sorry for my pessimism but the syntax for adding members to a group is horrible :(

    its like /pr w:world g:Admin Guy add parents Admins

    wtf? :(

    Why cant it just be /pr Guy Admin

    if no w: is there, take the current one where the command is executed.
  9. Offline


    To make some commands easier would make the rest harder is my understanding
    If you don't provide a world it defaults current already, that is why you give it a w: to make it understand it's taking a world
    /pr username parents add group
    This seems simple enough to me but then I understand the reasons behind it, best I could say is perhaps allow alias commands (not sure if there is an existing plugin that does this) either predefined or better yet customisable by config file
    /admin <user> [world]
    So the command /admin Maxis010 world is turned in to /pr Maxis010 w:world parents add Admin by permissions
    If I could write java I'd do it right now
  10. Offline


    I agree the commands are totally retarded. far too complex...

    should be /permissions or /pr then promote name group (W:world t:track) if you need the advanced options not required.
    The first track should be used and the world that it was ran from if they are not set in the command.
    that is as simple as it is maybe promote is the wrong word maybe add to add them to a group because you could have more that 1 group from what i understand.
    Maxis010 likes this.
  11. Offline


    Ive found answers about globalgroups.yml and globalusers.yml, think is for multi-world. But i just have nether and normal. so i dont have to fill these files so. thanks. I dont have mcmyadmin.
    Thanks for answer one of my questions
  12. Offline


    I like this (EDIT: And now I remembered the like button, derp)
    How about Tracks promote and demote and for groups grant/add and remove since you can multi group

    Also, a request as I'm not sure if this already exists

    Can you set a priority per group for group names as I have a group for granting WorldEdit seperately and whenever I grant someone this group I have to regrant them their existing group else the online plugin I use reports them as WorldEdit instead of their actual group
    Also can deny permissions ALWAYS take priority over grant permissions or do they already do so (not sure if it's Allow then Deny or in the listed order)
  13. Offline


    Here's a proposal as to new commmands:

    /pr username promote (w:worldname [optional, defaults to the default world]) trackname
    example: /pr battlekid promote StaffRankTrack
    /pr username demote (w:worldname [optional, defaults to the default world]) trackname
    example: /pr battlekid demote StaffRankTrack

    Quick commands:
    /pr username promote
    example: /pr battlekid promote
    result: battlekid is promoted to the next group up in the config.yml file.
    /pr username demote
    example: /pr battlekid demote
    result: battlekid is demoted to the previous group down in the config.yml file.
  14. Offline


    battle kid to me thats a bit backwards it should be what you want to do first then the data to fill the command so:

    /pr promote name

    first the plugin then the command then the info for the command and no stupid static words mid command just annoying as all SH!T to type...
  15. Offline


    looking through the server logs I found the part where I was testing the commands (as found on github) when I was making a list of all commands for my users. I was curious how they worked so I went through and tested them all out and they were working. or so it seemed.

    2011-06-11 18:04:11 [INFO] [Permissions] No world specified. Defaulting to default world.
    2011-06-11 18:04:11 [INFO] [Permissions] User promoted along track RisingPower.
    2011-06-11 18:04:30 [INFO] [Permissions] No world specified. Defaulting to default world.
    2011-06-11 18:04:30 [INFO] [Permissions] User demoted along track RisingPower.
    2011-06-11 18:05:14 [INFO] [Permissions] No world specified. Defaulting to default world.
    2011-06-11 18:05:14 [INFO] [Permissions] User not in specified group.
    2011-06-11 18:05:50 [INFO] [Permissions] No world specified. Defaulting to default world.
    2011-06-11 18:05:50 [INFO] [Permissions] User not in specified group.
    2011-06-11 18:06:12 [INFO] [Permissions] User demoted along track RisingPower.
    2011-06-11 18:06:23 [INFO] [Permissions] User not in specified group.
    2011-06-11 18:07:39 [INFO] [Permissions] All worlds reloaded.
    2011-06-11 18:10:12 [INFO] [Permissions] No world specified. Defaulting to default world.
    2011-06-11 18:10:12 [INFO] [Permissions] User promoted along track RisingPower.
    2011-06-11 18:10:29 [INFO] [Permissions] No world specified. Defaulting to default world.
    2011-06-11 18:10:29 [INFO] [Permissions] User demoted along track RisingPower.
    2011-06-11 18:10:46 [INFO] [Permissions] No world specified. Defaulting to default world.
    2011-06-11 18:10:46 [INFO] [Permissions] User demoted along track RisingPower.
    2011-06-11 18:11:14 [INFO] [Permissions] No world specified. Defaulting to default world.
    during my testing I had put the user back into Admin since CoOwner wasn't on RisingPower track initially. did some more testing and still couldn't get him back down to Admin during that testing, so I'm not sure if I did it right or not.

    to reiterate:
    RisingPower track is Default -> Trusted -> Mod -> Admin -> CoOwner

    Edit: Unfortunately it didn't save what I actually typed, so I can't say for sure exactly what combinations I tried, but I did use promote and demote, but I didn't see demote change anything.
  16. Offline


    I've figured out how to add to the global permissions file in-game, simply use an asterisk for the world:

    /pr Guy w:* perms add

    This should really be added to the wiki.

    (Although global permissions seem buggy at the moment... for me they work sometimes and not other times.)
  17. can anybody help me with this. my permissions doesn't work.
  18. Offline


    its now possible to set prefixes for user in user.yml?
  19. Offline


    I am using world mirroring right now, works perfectly.
    Hmm, the whole command system is pretty broken right now. We really need a simple command, or MUCH better documentation on the current command.
    That's also fine, but my example is using the system he uses for all the other commands.

    Alright, figured out a hacked-together method of promoting/demoting.

    /pr player parents add group
    /pr player parents remove group
    /pr player parents list

    Let's say I'm a "Founder", and I have spammed TNT all over, but I am still trusted so we want to demote me to a "Admin". What you'd do is type "/pr battlekid parents list", which lists my groups. For my server, it'll say "Rank Founder in world" or something like that. Now, type "/pr battlekid parents add Admin" (exact spelling/caps is CRUCIAL). This added me as a "Admin", however I'm still a "Founder", so we need to remove that via "/pr battlekid parents remove Founder". Now, I am a Admin, not a founder.

    Basic steps:
    1. Find out group.
    2. Add new group.
    3. Remove old group.

    Anyways, hope it helped!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  20. Offline


    can anyone explane me how i can use the Global groups?
    Please add me on skype:

  21. Offline


    2011-06-15 20:09:05 [SEVERE] mapping values are not allowed here
    in "<reader>", line 53, column 16:
    default: false
    why do i get this error everytime i change something how can i fix this?
  22. Offline


    ok so i have a question. how many ranks can this thing handle. becuase we are wanting to have different classes for people to be in in our RP server and the owner doesnt know if this plugin can handle them all. there are around 24 different ranks. if you know if the plugin can handle this please respond ASAP. thanks
    ok so in answer to my own question i have another one. is it possable to have multipal different tracks to rank up on if you are able to specify the track name??
    and please we really need help with this to get our RP server running to its max potential. so please respond
  23. i have the same sort of problem but i have a whole permissions.jar error around it. but nobody has responded to me yet.
  24. Offline


    i use hero chat i have set it now so

            default: false
                prefix: ''
                suffix: '&4'
                build: true
            prefix: '&b[&fBaron&b]'
            - SAdmin
            permissions: []
    but i have no prefix bevore my name

    this is the output
  25. Offline


    Upgraded to 3.1.5b Now when ever i go in to manually edit my users.yml and then do a /pr reload all permissions adds a whole bunch of [] so some users. And then it duplicates the users below with no permissions and without []. Adding players using /pr playername parents add groupname works fine, buts its a real pain not being able to manually edit my .yml files anymore. and no I am not using sql or mysql
  26. Offline


    Indeed, Help plug-in gives a lot of errors when used with Permissions 3.x.x. Now I already asked the developer there, if he/she could update the plug-in to work with Per. 3.x.x but I just want to ask here as well. Could you explain (briefly) what the exact problem is and if it has to be fixed in Permissions or Help? The work-around will probably work, but I rather have it fully working, with Permissions 3.x.x enabled, that is. Thanks!

    (Also, a quick thumbs up! I've been using this/the old version for over a month now and it works great! Except this small issue, never had any problems! Good work and keep it up! :D)

    Quoted from the Hero Chat page:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  27. Offline


  28. Does anybody know what causes this?

    [SEVERE] Could not load 'plugins\Permissions.jar' in folder 'plugins':
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(
        at net.minecraft.server.MinecraftServer.e(
        at net.minecraft.server.MinecraftServer.a(
        at net.minecraft.server.MinecraftServer.init(
    Caused by: while scanning an anchor
     in "<reader>", line 168, column 22:
                    prefix: '&2Admin'
    expected alphabetic or numeric character, but found '(39)
     in "<reader>", line 168, column 29:
                    prefix: '&2Admin'
        at org.yaml.snakeyaml.scanner.ScannerImpl.scanAnchor(
        at org.yaml.snakeyaml.scanner.ScannerImpl.fetchAnchor(
        at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(
        at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(
        at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockSequenceEntry.produce(
        at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(
        at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(
        at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeMappingNode(
        at org.yaml.snakeyaml.composer.Composer.composeNode(
        at org.yaml.snakeyaml.composer.Composer.composeDocument(
        at org.yaml.snakeyaml.composer.Composer.getSingleNode(
        at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(
        at org.yaml.snakeyaml.Yaml.load(
        at com.nijiko.configuration.NotNullConfiguration.load(
        at com.nijikokun.bukkit.Permissions.Permissions.<init>(
        ... 13 more
  29. Offline


    can anyone explane me how i can use the Global groups?
    Please add me on skype:

  30. Offline


    Post or report the COMPLETE error stack along with your users and groups ymls, this is a format error which means there is a problem with your files

    Post your groups config file, it's a format error

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018

    itis in 2.7.4, because towny doesn't support 3.x.
Thread Status:
Not open for further replies.

Share This Page