Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    ichat works great on my server ?
  3. Offline


    Ok, I will do that. Thank for the help :)
  4. Offline


    How to make a default group using mySQL? I tried with cmd `
    permissions g:Default w:world info set default true
    `, but it seems to not work.
  5. Offline


    should new users have the default group name in their user section?

    all i'm getting are these

    permissions: []
    groups: []
    permissions: []
    groups: []
  6. Offline


    I have defined a group (called "Default") in globalGroups.yml and I set " default: true".
    But this group is not the default group for newly created users: I need to add this to globalUsers.yml:
            - Default
    I use the latest versions of Permissions and CraftBukkit.
  7. Offline


    Wait a minute, are you saying I cant have mywarp , or I just can change it in the Config? I wanna Know , I love my warps! I NEED MAH WARPS.
  8. Offline


    Do you read his post? I have the same problem and it is not about (automatic) adding users to the global user file! It is about the use of the default group! Every user which is not in the user files should (temporarily) in the default group, which mean if the default group has some permissions (like the list, msg etc commands) then these users should be able to use them!
  9. Offline


    Hey, I'm a bit of a noob with Permissions, could someone please help, I've put all the nodes needed under default and Mods/Admin as '*' But, ingame none of the commands work from the default class. Any help would be appreciated,

    Group.yml code (open)
            default: true
                prefix: ''
                suffix: ''
                build: true
                - ''
                - 'lockette.user.create.*'
                - 'MobBounty.mb'
                - 'localshops.user.*'
                - 'admincmd.player.list'
                - 'admincmd.player.heal'
                - ''
                - 'lottery.admin.addtopot'
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Default
                - '*'
                - ''
            default: false
                prefix: ''
                suffix: ''
                build: true
                - Moderators
                - '*'

    Thanks in advanced!
  10. Offline


    Mysql Support?
    Can you make that?
  11. Offline


    Read the OP
  12. Offline


    When setting the "build:" option in the default group to false, will this be a sufficient protection against griefing? Or in other words: With "build" set to false, can I let everybody enter my server and be sure that they cannot do any havoc to the terrain and existing buildings? (except fire, I guess, for which I have a separate protection anyway).
  13. Offline


    Yes, at least it was so with Permissions 2.x but it seems that there is a problem now with the default group setting, it seems that unregistered users are not added to the default group in the current state
  14. Offline


    I see. Then, I guess, as soon as this problem is sorted out it should be safe to let foreign people in and let them have a look around.
  15. Offline


    That's only if you define the default setting in the global config. I'm thinking about how to fix that.
  16. Offline


    Haah, thanks, i search Mysql and nothing found xD
  17. Offline


    many Userresets ._.
  18. Offline


    You haven't converted your users.yml yet. Your group: <group> needs to look like:
                - <group>
    You can give them "- ''" which will remove that one permission from the '*'.

    Permissions doesn't work based on nickname but instead on the name they signed in with.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 10, 2018
  19. Offline


    Hey, i want my moderators to use /permissions -reload all i gave them the note Permission node: permissions.reload.all and with default but he is still not able to...
    help fast plx
  20. Offline


    New users will have access to whatever commands the default group offers them but they will not have that default group written to the users.yml file. This allows you to add them to whatever group you really want them to belong to with "/pr <user> w:<world> parents add <group>" without needing to first remove them from a group.

    I'll probably be accused of not reading someones post again but the problem is that the user is being written to the worlds users.yml file and I'll bet that the worlds groups.yml file probably doesn't have anything in it. This is probably bypassing the standard default group inheritance because it doesn't know which group to inherit from. You could try to add a default group to the worlds groups.yml file and let it inherit from the global file.

    There are 2 known ways to still grief even with the build flag set to false. They can still use lava and water. I think you can use GuestPrev to even remove access to those.

    Which version of Permissions are you running?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  21. Offline


    Thanks for pointing me to that one.
  22. Offline


    So help me out, guys.
    I`ve tried like 3 versions, but cant get default group working.
    Created a group called `Players` with default: true, build: true, perms: adminchat.
    Joined the server with not used nickname, but I`m not allowed to build and use adminchat command. Although I`m able to do those things if I`m manually put in that group.
  23. Offline



    I'm setting up a server for me and my friends to run the DnD plugin. I would like to have 2 groups, Players and DM.
    I would like Players to have every command EXCEPT
    How would i go about setting that up? if i got rid of the * they wouldn't have any commands. However, if i keep the * then they also get the
  24. Offline


    I added this, and now everytime I place a block, it disappears and seems rejected. I can't destroy anything either. Why is that?
  25. Offline


  26. Offline


    Thanks a million!
  27. Offline


    Did you set your build flag to true for whatever group you belong to? You might want to post your files to make sure there aren't any problems with them. Also, check to make sure you aren't getting any errors in your server.log.
  28. Offline


    That is different too.
  29. I want permissions to be the same in both normal world and nether, how do I go about doing this without re-writing all the permissions for that world? :D
  30. Offline


    I would post that as a bug on the GitHub site just to make sure rcjrrjcr sees it.

    You can use world mirroring for that. Take a look at the information here.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  31. Offline


    Indeed, using GuestPrev you can prevent users from having items, just don't add the bucket, water bucket and lava buckets to the allowed items and voila, any time they pick those up GuestPrev remoevs them
    Obviously don't allow the water and lava blocks as well (8-11) just to be safe
Thread Status:
Not open for further replies.

Share This Page