Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Its tempting to do, I just wanted to get their permission first but if they don't respond soon, I will update this plugin, there are so many servers that use it and others who don't wana switch to something else, especially if you can make a bridge from superperms to permissions 3
    Inscrutable likes this.
  3. Offline


  4. Offline


  5. Offline

    Sean Duran

    For some reason, my users aren't able to use hoes unless they're an op. Anyone know why?
  6. Offline


    My reason for sticking with it is that I have only heard skeptical comments about the other "new" perm plugins from good developers from the likes of heroes and Citizens crew I rather stick to what I would call a brand you could trust. Some mentioned were "PEX" "Superperms" as being not really a replacement to this plugin as they have seen instences of them failing to be stable.

    Once this is updated there is no reason anyone would actually want to ditch it I don't think as I assume the people who have done so not by choice.

    congrats for taking this up :)
  7. Offline


    Not that i dont love you for this, but is it really needed? theres enough permission plugins now that work as expected.

    I moved to PEX a week or so ago, seriously, it runs better then permissions 2.7.4, i havent seen the 'warning, is the servers time out of date?' (if thats correct, didnt see it a while lol) in ages, my simplistic winblows server runs fast!

    Besides, if your afraid itll be any work, it can automatically convert 2.7.4 permissions for you.
    Personally, i enabled mysql from the getgo, added 1 or 2 permissions trough ingame cmds, did the rest trough phpmyadmin (or adminer to be precise)

    And now i just use the commands to add any additional permissions for new plugins, finetune modifyworld (a hefty global protection system inside PEX) or promote/demote somebody, this thing is such a breath of fresh air its amazing.
  8. Offline


    thank you so much! i will tell you my server ip sometime your the best man!!!

    after i installed permissions i tried to make a npc and i had this error with permissions

    19.08 15:18:08 [Server] SEVERE at
    19.08 15:18:08 [Server] SEVERE at
    19.08 15:18:08 [Server] SEVERE at net.minecraft.server.MinecraftServer.h(
    19.08 15:18:08 [Server] SEVERE at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    19.08 15:18:08 [Server] SEVERE at net.minecraft.server.NetServerHandler.a(
    19.08 15:18:08 [Server] SEVERE at net.minecraft.server.NetworkManager.b(
    19.08 15:18:08 [Server] SEVERE at net.minecraft.server.Packet3Chat.a(
    19.08 15:18:08 [Server] SEVERE at net.minecraft.server.NetServerHandler.a(
    19.08 15:18:08 [Server] SEVERE at
    19.08 15:18:08 [Server] SEVERE at net.minecraft.server.NetServerHandler.handleCommand(
    19.08 15:18:08 [Server] SEVERE at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    19.08 15:18:08 [Server] SEVERE at org.bukkit.command.SimpleCommandMap.dispatch(
    19.08 15:18:08 [Server] SEVERE at org.bukkit.command.PluginCommand.execute(
    19.08 15:18:08 [Server] SEVERE at com.citizens.Citizens.onCommand(
    19.08 15:18:08 [Server] SEVERE at com.citizens.resources.sk89q.CommandsManager.execute(
    19.08 15:18:08 [Server] SEVERE at com.citizens.resources.sk89q.CommandsManager.executeMethod(
    19.08 15:18:08 [Server] SEVERE at com.citizens.resources.sk89q.CommandsManager.hasPermission(
    19.08 15:18:08 [Server] SEVERE at com.citizens.resources.sk89q.CitizensCommandsManager.hasPermission(
    19.08 15:18:08 [Server] SEVERE at com.citizens.Permission.generic(
    19.08 15:18:08 [Server] SEVERE at com.citizens.Permission.hasPermission(
    19.08 15:18:08 [Server] SEVERE java.lang.NoClassDefFoundError: com/nijiko/permissions

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Oct 10, 2018
  9. Offline


    I hope this plugin gets revived soon, I don't want to go to the "new" permissions plugins.

  10. Offline


    I know right? I hate change. But you use they others because I heard they have backwards compatibly with p3.
  11. Offline


  12. Offline


    If im host and i write something it does not say [Host] Bajsmabb

    how do i fix this?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 10, 2018
  13. Offline


  14. Offline


    @dark_hunter so now I need to set up permissions again....

    I hate the world...better start working now...
  15. Offline


    HOW do i fix so that when admins say something, it displays that he is admin!

    EX: [admin] exsample: Hi everyone!
  16. Offline


  17. Offline


    :O has permissions died?
  18. Offline


    Mods can make them to Admins because of den "parents add" permission, but they need them for unlocking. :confused:
  19. Offline


    rcjrrcjr, WHAT HAVE YOU DONE? You smite TheYeti, Nijikokun, and the other Permissions developers by letting this into INACTIVE! Please update to RB1060+ or else...
    efstajas likes this.
  20. Offline


    What the hell? Inactive? Did permissions die?
  21. Offline


    you need a chat plugin, go check out iChat or HeroChat :)
  22. Offline


    Is permissions dead?
  23. Offline


    PLEASE port this to the official bukkit permissions api because the official "PermissionsBukkit" Plugin is really frustrating.
    Decided to stay up for the night to switch over to PermissionsBukkit, rewrote everything, updated tons of plugins, after 3 hours final restart... WTF? Config is default again! Looking in the log of my ftp app... It was definitely uploaded. PermissionsBukkit deleted 3 hours of work. Also, it's missing the * and - nodes which are essential. Please update.
  24. Offline


    just let the permissions die like nikojun said. lets use the built in super permissions.
  25. Offline


    why? if someone is willing to take it up, then good for them! Clearly there is still a demand for this, as there are opinions floating around they prefer this to the 'new' built in stuff. I'm not really going anywhere until this either just breaks completely (if continued to not be updated) or is supported by zero of my current plugins.
  26. Offline


    Lol I just found out there hope and its called PermissionSex I mean PermissionsEx! Great plugin no anti-build support though :(
  27. Offline


    I tried BukkitPermissions first, spent hours on them, nothing. Make THIS plugin the standard one! Dont let this die!
  28. Offline


    What do you other developers fail to see about the official permissions system it's not an end all solution its an API, bukkit wrote a basic permissions plugin for it but it sucks the big one the idea of bukkits API in first place was to get all the permissions plugins to use one set of rules "API" but have the layout and design be what ever they want to suit various types of setups. But I'm not going to insult your intelligence as I am sure you already know this :p

    Letting this die is just a big slap in the face considering we called out for an API at the VERY start and was ignored for so long now we have stable permissions systems that are well-tested and your all happy to let them die in favor of something whipped up in most likely a fortnight with little to no real world testing, shame on you !

    Developers should know better in fact every server admin here that has any real experience should know better than to drop any mature system over a not yet proven system in a rush. I understand change is good but when the solution actually is kinda of sloppy over existing solutions then Imo you are better off to update the mature plugin and let the sloppy's serve as a starting point for beginners. I think this system is better than what bukkit has offered and what others have offered and if the original developers want to let it die then they can just disband it like they have and let others take over it.

    I said this once I will say it again I saw this whole debate back when SK killed Hmod with bukkit adverts but lets not repeat that with permissions systems. The only way I am moving from a mature permissions system is you can show me and prove to me that the others are better that bukkits is more flexible and easier to set up to the same this includes how it manages multiworld configs.

    So each to their own Id say if you don't like this and want to use something else good for you but don't come in here and preach your visions.
  29. Offline


    Please, someone revive this plugin! I have been using this on my server for a while, and would hate to see it go inactive.
  30. Offline


    You need to use a chat plugin like iChat or HeroChat, and you need to set up your prefixes under the info node.

    Greeeaaatt.... Now I'm the one with the problem.
    For no apperent reason, I am unable to build in my first world; yet, I am able to build in all of the others without problems.
    There are no console errors. I am running b1000 with this version of Permissions. I have triple checked my permissions files. I can't find anything wrong. There are no tabs to my knowlege. I can only build in the main world with SuperPickaxe.
    If anyone else is still paying attention to errors \ problems, I would appreciate the help.

    DL my server files here. Don't worry. It's small

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  31. Offline


    This is exactly why most plugin developers (including me shortly) get so annoyed with permission plugins....

    We now have a built in Permissions framework from the Bukkit Team and PermissionsBukkit to use for SuperPerms (SuperPermsBridge if needed as well)

    I cannot stress the importance of having one consolidated Permissions plugin to use as these "Bridges" are getting obnoxious. I hope that with SuperPerms, plugins like these and their knockoffs and their knockoffs (list keeps going on) will finally cease to be. Nijikokun said it right when he/she made the post regarding the barrage of copycats. At least have the decency to fork your code off of another's project if you are going to copy them.

    As to the people above who complained that PermissionsBukkit was hard to setup....on the contrary it was very easy to setup if you are a true server admin and know what you are putting into your server. Long has these permission plugins held your hands with '*' wildcards and the like. It was finally time that you took the time (as a server administrator) to actually administrate your server and know what is going on.

    If you find that way to difficult to do then I question why you are administering a server to begin with.
    ultimak, dark_hunter and Ninja Grinch like this.
Thread Status:
Not open for further replies.

Share This Page