Inactive [ADMN/DEV] Permissions 3.1.6 - The Plugin of Tomorrow [935]

Discussion in 'Inactive/Unsupported Plugins' started by rcjrrjcr, May 24, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Permissions 3.1.6 (Yeti)

    Latest Stable (3.1.6) : Full Zip | Main Jar Only | SQL Interface Jar Only

    Previous Versions:
    3.1.5 (JAR|SQL) | 3.1.4 (JAR|SQL) | 3.1.3 (JAR|SQL) | 3.1.2 (JAR|SQL) | 3.1.1 (JAR) | 3.1 (JAR) | More older versions

    Feel free to comment and give suggestions.


    • Revamp commands
    Known plugins that cause IllegalAccessError(s):

    • Help (not fixed yet)
    Temp Fix for IAEs (open)

    1. Open Help's JAR with 7zip.
    2. Find MANIFEST.MF (it can be in the root folder or in the META-INF folder, or both).
    3. Open the MANIFEST.MF file in a text editor
    4. Look for a line that starts with "Class-Path:".
    5. Delete "Permissions.jar" from that line.
    6. Save the manifest.
    7. 7zip will prompt you to save changes back into the archive. Accept.
    8. Restart server.

    Plugin Authors: How to hook into Permissions

    Due to @TheYeti being busy in RL for now, I have created a new thread for Permissions 3.x. TheYeti is still part of the Permissions team.

    Permissions... Reborn.
    This is a continuation of the work that was originally done by Nijikokun. All original credit goes to them as without their work this plugin would not have been possible. This plugin does not provide any commands or additional functionality beyond what is described in this post. That means that you need another plugin to provide colored names, chat prefixes, and op commands such as /give and /time.​

    The Permissions Team

    The team consists of myself @rcjrrjcr and @TheYeti currently with contributions from @Nijikokun as well on occasion. There are also several other members of the community who frequently assist with providing code changes, bug fixes, patches, support, feedback, and beta testing. Special thanks to @flames and the Dynmap & Wormhole X-Treme teams for the hosting of Permissions on their Jenkins server.

    What's new in 3.x?

    Taken from the GitHub page:
    1. In-game commands. For a long time, users have been pestering, nagging, demanding and/or screaming for an way to manage Permissions via commands. Now, in 3.0, in-game commands are available to manage permissions and groups.
    2. SQL storage. This allows web interfaces to manage Permissions by updating the SQL database Permissions uses.
    3. Promotion/demotion tracks. With a simple command, users can be promoted/demoted along a preconfigured track, allowing RP servers with ranks to promote the player along a class track and other possibilities.
    4. Multigroup.
    5. Weightage. Plugins are able to compare users via their weight, which is inherited from their groups. For example, SlapPlugin can check if Player A is higher-weighted than Player B when A tries to slap B (Not IRL, obviously).
    6. Improved world mirroring. Config files are now split into a group file and a user file. Also, by editing storageconfig.yml, you can configure the mirroring of entire worlds, or just its users/groups. You also do not have to create files for worlds that mirror another world. Also, two different worlds can use different storage types, like YAML and SQL.
    7. Global permissions. Instead of having to resort to cross-world group inheritance, now all worlds inherit groups and users from the global permissions file. Also, the inherited groups/users can be overridden via editing the specific world's file.
    Upgrading from 2.x to 3.x

    I have written a guide on GitHub. This demonstrates how to convert 2.x-style configs to 3.0. The YAML-to-SQL converter are still in testing, but it can be downloaded from here. It's written in Perl. @Zgred has created a web version of the script located here. @omgneeq is working on an Web UI for SQL databases (Sorry about the previous statement that he was making a converter.)​

    Install (open)
    For the admins

    In case you missed the link above, the Setup Guide on GitHub will help you quite a bit

    Samkio has updated his tutorial for P3:

    First thing that you will need to do is download the plugin. Place it in your plugins/ folder and unzip it. This should create the folder Permissions and a Permissions.jar file in your plugins folder. Next, go into Permissions/ and create a folder named the same as your world. So if your world name from is Foo you will need to create the folder plugins/Permissions/Foo. You MUST rename it to whatever your world's name is or it will not work.

    Note, if you have your server maps all saved into a single directory then the initial setup will be somewhat different. Say your maps are arranged in the main directory like so: bukkit/mapfolder/world1, bukkit/mapfolder/world2, etc. Then inside of the plugin/Permissions directory you will need to create a folder called mapfolder and inside of that put the directories containing users.yml and groups.yml in there.

    Next, you will need to go in and add yourself to the users, just replace the user that is in there with your name. Make any other modifications that you need to. While making modifications make sure that you do NOT use tabs. These will break the YAML format and cause issues. Instead, each indent should be four spaces. If you want people who aren't in the Admin group to be able to reload the permissions plugin you need to give them 'permissions.reload' permissions within the config file.

    Permissions gives server admins great control, mostly in-game reloading. More info about commands can be found here.

    FAQ (open)


    [Q] What is with the version numbers? I can't keep up, it seems like every time I look there is a new version!
    [A] I use the GNU versioning system for my version numbers. So what this means is the version number should be read as Major.Minor.Revision. So for version 2.5.2 this would mean it is the 2nd Major version, the 5th Minor release in this version, and the 2nd revision. I tend to release bug fixes and anything that doesn't add functionality or will not break things as revisions. So generally you should be safe with just watching the major & minor numbers and only getting the revision if it fixes a bug specific to you. Technically 2.5.2 should have been released as 2.6 as it did add functionality, but this was below even a minor change so I released it as a revision.

    [Q] I am getting an error that it can't pass BLOCK_PLACED or BLOCK _BREAK events to Permissions. Fix it!
    [A] That's not a question. The reason why it can't place these is probably because the syntax of your Permissions file is all whacked out, or it is a different world and you don't have a config file for that world.

    [Q] What am I suppose to name the config file?
    [A] You need to name it the same as your world. So if you look in at "level-name" you will see a world name there. Rename your config file to the same thing as that. Make sure you keep the .yml extension at the end.

    [Q] Permissions are broken. Why can no one use commands? Why am I not an admin?
    [A] First off, make sure that your formatting is correct. Look at the format that the default config file uses. Yours should look like that. Do NOT use tabs. Use 4 spaces (IE. " " <-- Four of those things.). Also, whichever group you give the permission '*' to, do not have that group inherit permissions from anyone else. That is called overloading and it will break things. Also, this.

    [Q] Which one am I suppose to download and unzip to install this?
    [A] Download the main package, not the JAR only. Unzip the ZIP file. The JAR only downloads are simply there for people who are UPGRADING and do not need the default config file.

    [Q] I have done all of this and this doesn't work! I'm going back to GroupManager!
    [A] Well, there is probably the problem. Make sure that you delete EssentialsGroupManager.jar and EssentialsGroupBridge.jar as these don't play well with Permissions and will cause headache.

    [Q] When are you going to add <blah> <feature/command> into this already? You suck! Do what I want NAU PL0X!
    [A] Feature requests should be posted on the GitHub tracker. Stupid suggestions like adding teleportation functionality and other less ludicrous stuff will be rejected.

    • 3.1.6
      • Major fixes.
      • Simplify tracks
    Changelog (open)

    • 3.1.5
      • Fix several minor bugs.
      • Autoconvert 2.x/GM format (only works if you split them into groups.yml and users.yml, but leave the rest untouched)
    • 3.1.4
      • Fix YAML locking bugs.
    • 3.1.3
      • Fix another SQL data and inheritance issue.
    • 3.1.2
      • Fix SQL data issues.
      • Added user/group name autocomplete
      • Separated SQL interface into separate plugin
    • 3.1.1
      • Fix prefix/suffix issues.
      • Added ON UPDATE CASCADE to the SQL foreign [/SIZE]
    • 3.1
      • Tons of fixes.
    • 3.0.6
      • Fix SQLite issues due to misimplementation of methods.
    • 3.0.5
      • Fix cache-related NPEs
      • Fixed quoted worlds (thanks again @Jeyge !)
    • 3.0.4
      • Fix LinkageError caused by ServiceManager not unloading the PermissionHandler class.
      • Added cache
      • Fix index not being incremented when promoting (thanks @Jeyge !)
    • 3.0.3
      • Fixed another getGroup bug.
    • 3.0.2
      • Fixed getGroup bug.
    • 3.0.1
      • Fixed some NPE bugs.
    • 3.0
      • Total overhaul of Permissions. Adds many new features (see What's new in 3.0?).
    • 2.7.4
      • Added overload of has() and permissions() for plugin devs
    • 2.7.3
      • Fixed negate node add/remove bug.
    • 2.7.2
      • Fix for small subtle bug introduced in last minor version.
    • 2.7.1
      • Commit by DThielke to fix several bugs with programmatic modifications of user permissions.
    • 2.7
      • Further commits by rcjrrjcr
        • Removed negatedNode checks
        • Temp fix for NULL issue
        • WorldConfigurationModification to save only modified configs
        • Fix for cache problems

    Credits (open)

    Nijikokun - Without their original work this plugin would not be possible.​
    All of the members of the community that regularly provide support in this thread for Permissions​
    Rigby, Kainzo, DThielke, GoMySQL, sk89q, RightLegRed - For hanging out with me in IRC, tons of testing, and pushing me to improve on the code constantly and make changes to make this plugin constantly better and better, and in general being entertaining.​
    Everyone else on here and in IRC who provides support, feedback, assistance, plugins that have continued to support and integrate this, and in general makes my life a bit easier, THANK YOU!​

    I would like to thank Joy , jamesg and omgneeq for staying in #permissions for long periods of time to test out 3.0, and help me find many coding mistakes I made, patiently waiting for the next build while I fixed the bugs. I appreciate SvenBrnn 's and GoMySQL(Geoff Winans on this forum) 's help that allow me to design and code the SQL interface, and the HeroCraft coding team for providing support and some priceless IRC quotes (Dgco). Also, I would like to thank Lycano for helping me in many different aspects. Last but not least, I would like to thank Nijikokun and TheYeti for developing P2, which was one of my core plugins when I was still a 14-year-old server admin that didn't understand Java, and was the base for 3.0. Without these people, 3.0 would never be possible.​

    If after reading through all of that you are still having issues do one of two things. If it is a provable bug, and you have things like screenshots or copies of startup, steps to reproduce, your craftbukkit build and the version this is running along with your config files then submit the bug on the issue tracker. If it is general help or support you are needing then post a reply to this thread and someone will try to help you.

    Old thread: Permissions v2.7.4
  2. Offline


    Don't use global configs. Use only world-specific ones. Global config doesn't work like it should.
  3. Offline


    how does anyone have this working right now? I havnt been able to get this plugin working for a long time now reguardless of the fact everything is configured correctly there are no errors in the log etc. no one can build but me even though it is set to allow them to... *sigh* permissions plugins need to be more relyable the auther hasnt even been on in a month....
  4. Offline

    Rob Casey

    Hey all, having an issue here getting permissions to work. I've done everything just like the tutorials say or at least I think but I still can't get this to work. I put the permissions.jar in the plugins folder, created a permissions directory in the plugins folder, copies over the appropriate files, edited them and ran then through the YAML parse checker which didn't complain but it still doesn't work. I have the default group set to have build= true but when I or anyone else joins the server as a regular users we can't build anything. One possible clue perhaps is when I start the server it is kicking back a 'Server permissions file permissions.yml is empty ignoring it' message.

    Some help would be great as my server is basically unusable now unless I op everyone.
  5. Offline


    Since the plugin is now flagged as inactive, i would really suggest looking at PEX wich does all this one promises, and more, alot faster too.
    Sorry for being so rude, just trying to help.
    Adv likes this.
  6. Offline


    Same. Not because this was just marked inactive, but also because this plugin's developer(s) has been absent for so long as has this plugin seen no significant updates in forever. And for those using PermissionsPlus to have a command system that makes sense, PEX's command structure is great and is how a command structure should of been from the get go. Oh, one more thing to throw in here, PEX also supports Bukkit's SuperPerms, think of it as a hybrid.
  7. Offline


    well if you could make a download for me in mediafire then i can do it for you
  8. Offline


    Im having a problem with permissions when I start up the server it says this:
    [SEVERE] [Permissions] Unable to load permissions data.
    [SEVERE] [Permissions] Shutting down permissions due to error<s>
    [INFO] [Permissions] <Yeti> was initialized
    [INFO] [Permissions] <Yeti> disabled successfully
    I don't think I did anything I wasn't supposed to. Does anyone know what happend?
  9. Offline


    Most likely syntax errors. Post your ymls for your worlds. Do not use global permissions it will cause some issues.

    What build of bukkit do you have? 1060 RB will not work with this...1000RB will work.

    I've had this plugin working before 953. I works great. Usually its syntax errors or global permissions.

    I can help if you can post your ymls. It seems to work with RB 1000. I think RB 1060 is pushing people to use bukkit permissions. Well that is what I've noticed it may be different for others.

    Make sure that permission node is correct.

    If I'm reading this correctly that permission node is incorrect unless... "The arena name is the same as the one that appears in the config-file"

    Does that make sense?

    I hope someone can get this active. I either this plugin will break with 1060 or bukkit is forcing bukkit perms?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  10. Offline


    Permissions is inactive because people need to start switching to Bukkit SuperPerms. It is far easier than Permissions for both server owners and plugin devs. Simply switch over to PermissionsBukkit or bPermissions to start using SuperPerms because plugins will stop supporting Permissions altogether very shortly.
  11. Offline


    I want to add to Rockstar's point, by saying two things I like this permissions plugin tell people that they have to use something else just (for lack of a better word) sucks. Second well most plugins support this permissions system. Many have gone over to Bukkit Perms but not all.

    So you are right in one aspect that people should wait for an update to this plugin.

    Also this way is far easier in my mind than switching to something new.
  12. Offline


    Uh not it's not. The way SuperPerms is right not is neither convenient or better than current Permissions systems. What is your reasoning for thinking it's better, because it's built into Bukkit? lol. After reading through the PermissionsEX thread I'd say that is how a permissions system should be. Especially since you can use super perms only plugin permissions with PEX ala hybrid permission system.
  13. Offline


    @Rockstar04 @Snipes01 and @Adv Bukkit SuperPerms is easier for plugin devs because you can now check if someone has a permission or not with just 1 line of code. Also, it is better for server owners because they can use PermissionsBukkit with the PermissionsBridge which will allow them to use both Permissions-only plugins and SuperPerms-only plugins.

    Which is why I recommended you download PermissionsBukkit (a SuperPerms manager) with the PermissionsBridge (so you can use your old plugins).

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Sep 9, 2018
  14. Offline


    Which PEX also does. But to respect this thread, even if it is inactive, if you want to continue on please pm. Thanks.
  15. Offline


    i changed the permissions node to -'mobarena.arenas.*' and now it works!
  16. Offline


    why stopped devloping?
    or why is the plugin inactive? its soooo good.
  17. Offline


    Great I see just like Hmod we are being forced to move onto some sketchy new bukkit based permissions system plugin, Hello Hmod/bukkit battle all over again, this time over permissions systems.

    I'm just not a fan sorry why ruin a good thing, adaption = a better chance of survival than creation this is why I lean more towards evolution over any god, tho I'm 90% non belief in any. In any case if I had to choose one it would be evolution I rather evolve than be re created as a new with no memory's,
  18. Offline


    Is there a permissions node that translates as "All but [Insert node here]" ?
  19. Offline


    - '*'
    - ''

    this above system uses the asterisk boolean to say -ALL- and the next would be your node, the one that you don't want, with the negative symbol beside it to tell the system not to give that node, or to remove that node.
  20. Offline


    Cool thanks :)
    Aw wth... Why's the permissions plugin dead for the third time?!
  21. Offline


    Best permissions system! Still working on 1060 ... wish someone would pick this up! :(
  22. Offline


    Why when I try to add someone in a group using /pr add PlayerName GroupName it always says the user/group does not exist ? Cuz it does exist, I verified like ten times I didn't made mistakes.. :/ I really need to get this command to work !
  23. Offline


    I recommend PermissionsPlus. It's a great tool to use for ingame edits like that.
  24. Offline


    Alright I'll try this. Thank you Smidds.
  25. Offline


    hey i need help a lot my permissions is not working i am always default in game but in permissions im owner and in game i can spawn items ever though it says im default but in permissions defaults cant spawn items!
    plzz help these are the files
    there at the bottom but there also a folder there that says permissions that was made that has globalgroups and globalusers and a bunch of world folders with other user group files what ones do i put nodes in. and the global users and groups files were empty

    Attached Files:

  26. Offline


    i ll help you out, ill fix it and post it on paste bin for ya
  27. Offline


    I noticed you were using some plugins that require the spout plugin. Ensure that you have that plugin installed. Put the groups and users file into the world file. Leave the global files empty as they do not work correctly with some plugins.

    Attached Files:

  28. Offline


    We just need somone to pick this up and add the ability for it to work with bukkits permissions API and we have the best/ most stable system back on top again :). Don't mind my other post too much I have just seen this all before with hmod when bukkit first started.
  29. Offline


    I just requested from all 3 to take over this plugin and possibly a bridge for bukkits own perms, just waiting on an answer back
  30. Offline


    Also, try and make sure that you are not OP.
  31. Offline


    I think the general rule around here is if a developer drops the plugins and does not respond in like a month and its open source you just fork it under a new thread giving credits and a back link to original.
Thread Status:
Not open for further replies.

Share This Page