Inactive [ADMIN] Crafty v0.7.6 - Server GUI [1240]

Discussion in 'Bukkit Tools' started by Timberjaw, Feb 3, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Emiya Shirou

    I've wanted to test this but...
  2. Offline


    do you have:
  3. Offline

    Emiya Shirou

    Yeah, I just put fresh server on Craftbukkit today, the jar name is as you posted craftbukkit-0.0.1-SNAPSHOT.jar and it's the newest name.
  4. Offline


    you should name it craftbukkit.jar it is the only thing that works
  5. Offline

    Emiya Shirou

    Ok it works now.
  6. Offline


    handy UI, could really use an option to specify which filename to look for rather than being hardcoded to craftbukkit.jar though. I tend to keep my craft bukkit file tagged with the build number in case I need to roll back
  7. super confused please make vid tutorial i'm a newB
  8. Offline


    I am getting the same problem as Emiya and i named the craftbukkit-0.0.1-SNAPSHOT.jar to be craftbukkit.jar and i still get the same error she/he did, any help?
  9. Offline


    @pieffff Is crafty.jar in the same folder as craftbukkit.jar?
  10. Offline


    yes it is, all of them are in the same folder i just named it [the folder] server for ease of access
  11. works great, except .crafty restart pulls a error on a Ubuntu 10.10 machine with open JDK java or Oracles build. Works fine on Windows 7 though. Are you aware of this error?
  12. Offline


    Haven't heard of that issue specifically, but OpenJDK doesn't support everything that the Sun JDK does.

    What's the error?
  13. Hello, It would be nice if you could make so you can lunch crafty with more Ram like you can with a bat file on the usual server client. i mean this "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
  14. Offline


    thanks man it works
  15. Offline


    Crafty accepts the same command line arguments as any other .jar application. You can use Xmx and Xms as usual; simply modify your crafty.bat to add them.
  16. Offline


    I've noticed that .crafty restart doesn't function for me in Ubuntu 11.04, I assume because of some issue with "javaw" relating ubuntu, as if I remember correctly I couldn't get server to run with javaw, but it worked with java.

    " 10:50:17 [SEVERE] Cannot run program "/usr/lib/jvm/java-6-openjdk/jre/bin/javaw": error=2, No such file or directory"

    When I go there I do see a file but it's located in the /bin folder. (note the s)
  17. Offline


    um i am new to this and i was wondering if you could tell me what program to open the .bat file with?
    because my computer asks what program i want to open it with. plz contact me by email or reply here soon my address is
    [email protected] and put a link for program i need to run .bat with.:D
  18. Offline


    :confused: Windows shouldn't ever ask about what program to open batch files in, because they're ran, not opened... if you're on Windows and that's happening, there's something seriously wrong.

    If you're on MacOS or Linux, you don't need the bat, just run the jar using whatever Java VM you have installed
  19. Offline


    oh well i have windows 7 and when i click it says... please choose program you want to open file with. how do i run the file?
  20. Offline


    @blob9000 long have you had that computer?

    Because the fact you're having this problem indicates either an issue with your registry or some core system files.
  21. Offline

    Justin VonHagen

    Would love to see color codes supported....

    12:47:57 [SEVERE] at Source)
    12:47:57 [SEVERE] at Source)
    12:47:57 [SEVERE] at Source)
    12:47:57 [SEVERE] at
    12:47:57 [INFO] bdp72400 lost connection: disconnect.endOfStream
    12:47:57 [INFO] §7[Moderator]§f §5boingoloid29§f§f§7:§f nope
    12:48:06 [INFO] §7[Citizen]§f §2mari061w§f§f§7:§f ok hvor er du
    12:48:08 [INFO] §9[PLAYER_COMMAND] boingoloid29: /nick Nebhogan'sNyanCat
    12:48:17 [INFO] §7[Guest]§f §eoscardietz§f§f§7:§f i mit hus

    §7[Guest]§f §eoscardietz§f§f§7:§f i mit hus
    Would Look like:
    [Guest] oscardietz: i mit hus

    The only issue would be the white. That would probably need to be switched with black since the background is white on your app, but sort of black in minecraft.

    That would rule!

    KoryuObihiro likes this.
  22. Offline


    Hey what version of minecraft/bukkit does this work on? It looks so good and very useful and i can't find a better one than this.
  23. Offline


    @coopbmc Works just fine on build 860 for me right now.
  24. Offline


    Okay thank you. Im gunna update my server and use this then :D
  25. Offline


    @Timberjaw how do you make a wrapper for craftbukkit
  26. [/quote]
    I keep getting an error saying

    "Culd not find the main class: com.arania.crafty.Crafty. Program will exit."

    without the quotation marks..

    What shall i ever do about it?
    I have no clue in what has happened
    Please help..
    in return i shall add you as a friend of subscribe to your youtube channel(If you have one)

    Thank you.
  27. Offline


    what is in the bat file, what os do you use?
    is craftbukkit.jar existing?

    alert to @theminecraftmaster69

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  28. Offline


    When i try to run it, it just says "Could not find the main class: com.aranai.crafty.Crafty. Program will exit.
    I'm using the standard bat, im not doubleclicking the jar, and i'm on Win7 x64, jre6
  29. Offline


    I was reading through this post and would like to make it use as much RAM as needed (I have 12gb total to play with :) )
    What would I have to have the batch file look like to make it allocate more as it needs it or does it come that way by default?

    @Timberjaw I tried running this on my computer and it was working well. I found an issue though, and I'm not sure if it's this or the plugin's fault, but:
    I run Minecraft Mobile Admin and I can see the console and in-game chat when not running this GUI on the Android App. When I run this GUI I can't load the Android App. Would you have to allow for something like that to access this or would it be something on that plugin's dev to hook into this to make it work? thanks for an awesome GUI and hope you update it soon :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 8, 2016
  30. Offline


    @ACStache I don't know if you can set it to 'as much as it needs', but you can increase the maximum to a specific amount. In the .bat file, where it says '-Xmx1G', change the '1G' part to your desired maximum memory usage. e.g. '-Xmx4G' for 4 gb. It will start out using as little as possible, and allocate up to 4GB if needed.

    Re Minecraft Mobile Admin: I'm not sure how MMA works (it doesn't look like they make the source code available). Crafty doesn't really interact with plugins in any way, so I'm not sure why there would be a conflict. If MMA does something directly involving the system input/output streams (which normally a plugin wouldn't do), that could conceivably clash.
Thread Status:
Not open for further replies.

Share This Page