1.8 Bukkit Discussion

Discussion in 'Bukkit Discussion' started by agafaba, Sep 14, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    It said you're using build 1060. Are you sure you're using 1149?
  2. Offline


    I use bukkit 1.8 since yesterday. Unfortunately my Users can't open doors, chests or pick up blocks. Even the Admins can't, except i make them op. Normally I use PermissionsEX for Permissions. In 1.7.3 I haven't had that problem. Bukkit built 1149

    Plugins in Use:
    - Permissions Yeti (tried PermissionsEX before)
    - World Guard
    - World Edit
    - Default Commands

    I also get following errorcode

    2011-09-19 10:32:04 [INFO] Read timed out
    2011-09-19 10:32:04 [SEVERE] java.net.SocketException: Socket closed
    2011-09-19 10:32:04 [SEVERE]     at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:116)
    2011-09-19 10:32:04 [SEVERE]     at java.net.SocketOutputStream.write(SocketOutputStream.java:153)
    2011-09-19 10:32:04 [SEVERE]     at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:82)
    2011-09-19 10:32:04 [SEVERE]     at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:140)
    2011-09-19 10:32:04 [SEVERE]     at java.io.DataOutputStream.flush(DataOutputStream.java:123)
    2011-09-19 10:32:04 [SEVERE]     at net.minecraft.server.NetworkWriterThread.run(SourceFile:104)
    2011-09-19 10:32:04 [INFO] Gennaro1993 lost connection: disconnect.endOfStream
  3. I have downloaded the build #1149 and uploaded it per ftp to my server an press restart ...
    I dont know why it using the #1060 ..

    Have I to delete the normal craftbukkit data from my server to run it? .. or only delete the old snapshot and upload the new one??
  4. Offline


    hi! this is me:

    04:39:45 [INFO] Starting minecraft server version Beta 1.8.1
    04:39:45 [INFO] Loading properties
    04:39:45 [INFO] Starting Minecraft server on *:10
    04:39:45 [WARNING] The server will make no attempt to authenticate usernames. Be
    04:39:45 [WARNING] While this makes the game possible to play without internet a
    ccess, it also opens up the ability for hackers to connect with any username the
    y choose.
    04:39:45 [WARNING] To change this, set "online-mode" to "true" in the server.set
    tings file.
    04:39:45 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1020
    -gb412283-b1124jnks (MC: 1.8.1)

    my problem is this: none of the non-player generated structures, such as the npc towns, or underground strongholds or whatever... are spawning. ive been through three worlds taking several hours to find them, along with a few friends... no dice...

    is anybody else experiencing this, is this to be expected? am i using the wrong version? i would greatly appreciate some help, or just some info would be good :)

    tyvm in advance.
  5. Offline


    Default Commands was the problem
  6. Offline


  7. Offline


    I'm new to Bukkit Forum but have been using Bukkit since 1.7, I've tried Bukkit 1.8 and it appears to work perfectly on Windows, but I did try it on an older map and it appears to use a few of the old plug-ins as normal such as Essentials, as it appears the 18 September release is good for full use :-D, but because others are still have trouble it maybe worth continue testing until more successful posts, I hope this all makes sense, lol, Thanks guys :-D
  8. Offline


    No problems on Linux for me! (2,7gb after 4h, 43 Plugins)
  9. Offline


    Server OS ? Java version ?

    I Use Debian 6 (squeeze) and Java(TM) SE Runtime Environment (build 1.6.0_27-b07)
    Java HotSpot(TM) Server VM (build 20.2-b06, mixed mode)
  10. Offline


    For java I have to look later.
    Its an ESXI (boot from USB stick) Server with a Ubuntu Server 11 x64 VM on hardware Raid.
  11. Offline

    Todd Chartier

    Dinnerbone just compiled a 1150 build. just thought I would update y'all.
  12. Hey all,

    -.-" ... I need your help! .. now I am searching two days for an update for my bukkit-server on monsterserver.de and nothing wants to work!

    On the normal way I have to download the newest craftbukkit snapshot and have to overwrite the old one on the server.. I ve done it and done it and the server says me always he has the version #1060 and Minecraft 1.7.3 .. can someone help?

    Please as far as possible or i will hit my head on the table ^^


    2011-09-19 15:40:25 [INFO] Starting minecraft server version Beta 1.7.3
    2011-09-19 15:40:25 [INFO] Loading properties
    2011-09-19 15:40:25 [INFO] Starting Minecraft server on
    2011-09-19 15:40:25 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-980-g4ed23b1-b1060jnks (MC: 1.7.3)
    2011-09-19 15:40:25 [INFO] Preparing level "world"
    2011-09-19 15:40:25 [INFO] Preparing start region for level 0 (Seed: 900123154833147922)
    2011-09-19 15:40:25 [INFO] Preparing start region for level 1 (Seed: 900123154833147922)
    2011-09-19 15:40:26 [INFO] Server permissions file permissions.yml is empty, ignoring it

    View attachment 6621

    These are the datas I have on my Server Directory oO

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 19, 2016
  13. Offline


    name the craftbukkit-0.0.1-SNAPSHOT. jar to craftbukkit.jar and delete the old one
  14. Offline


    Hey guy's i tried to follow this thread, so im sorry for being one of thoese guy's but is there a 'stable' version out that doesn't break anything major in 1.8 and that plugin writers are using? and if so is it in the thread? or a link cause honestly i got a bit lost on progress after page 10

    Sorry i know these kinda post can be annoying
  15. Offline


  16. Offline


    anyone get the bug that you cant place smooth stone?
  17. Offline


    My questions is, if they are working on tracking down "hard to recreate" bugs, why not pack it up as a recomended build and update as you are able to iron out the few bugs you have left?
  18. Thanks for that ^^
    My fail ;)
  19. Offline


    there not a "few" errors left
  20. Offline


    Sorry I said "few" looking back at the tweet, it was worded "some" my bad! I know everyone is a bit dissapointed that it has taken this long for a release. Everyone is a bit on edge. And I know we all just want to see a good working Bukkit released.

    It would be greatly appriciated by many if we could get some indication (I mean this week, next, a month, never) on when we should look for a recomended build.

    This wall of silence is rather frustrating, especially when it seems work has slowed down on Bukkit atm. Anyone using MyMcAdmin, which my host forces on me, cannot update to experimental builds. We have to wait on the recomended build.
  21. A noob guide to installing CentOS and Minecraft would be lovely then. :p
  22. Offline


    so yeah, thought i would try this one again... anybody else have any info on this problem?
  23. Offline


    If your a noob there is no easy way :D

    Anyway has anyone tried 1150?

    Edit 1151*
  24. Offline


    With the amount of bugs that still exist, the nearest answer for when is "hopefully sometime in the near future". and personally, unless your testing for bugs, i dont see the point in using an experimental build, which is why our server is simply waiting for an RB. Minecraft itself is buggy, so again waiting is a good idea cause 1.8 will proly have another update of its own soon.
  25. Ye, unless notch is working on some other stuff, jeb is working on cobalt and nobody really cares for mc...
  26. Offline


    Yeah, I've been wondering the same thing. With vanilla 1.8.1, there were NPC towns all over the place. Now with the newer Bukkit builds (>1060), I haven't seen a one. I did get a couple of 'Placed stronghold in INVALID biome' messages, but I've not been able to find any of those either.
  27. Offline


    actually, i got the same messages. still no villages or strongholds.
  28. Offline


    Its minecraft guys... I think this all is pretty par for the course.
  29. Well, lucky me for not saying anything about easy then :p
  30. Offline

    Emiya Shirou

    So strongholds and villages don't spawn for the bukkit designed for 1.8 ?
Thread Status:
Not open for further replies.

Share This Page