1.4.2 Beta Constantly Reloading

Discussion in 'Bukkit Help' started by EliteCreeper, Nov 1, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    I meant restarting, sorry.
  2. Offline


    So then you are having the same issue, as described above?
  3. Offline


    Well, yes. At random moments it will suddenly restart, kicking everyone off and forcing us to wait several moments for it to go back up again.
  4. Offline


    Yeah, that's the same thing.
    Do you get any warning messages/error messages in your server.log?
  5. Offline


    No, it acts like a normal restart.
  6. Offline


    Do you end up with a slight rollback/change loss?
  7. Offline


    Nope, because my issue is more related to this:

    The release of Minecraft 1.3 introduced built in auto-save functionality that is completely new to Minecraft: prior to this release, server admins had to provide their own means to save things on their server at a set interval. As a result, the vast majority of servers already have an auto-saving mechanism of some sort, rendering the newly provided built in auto-save largely redundant. On top of this, it was also immediately noticeable that the built in auto-save was the cause of a significant performance hit to the server, even going so far as to lock up the server each time it ran.

    Bearing this in mind, we decided the best course of action was to make the auto-save interval configurable and default to being disabled. By doing so we immediately saw a noticeable performance increase on servers and noticed overwhelmingly positive feedback on our Beta builds. While some might argue that this could leave servers without frequent saving, this change simply reverts behaviour back to what server admins are familiar with from Minecraft 1.2.5.

    As mentioned before, we have made the auto-save interval configurable and disableable within the bukkit.yml. Simply set "ticks-per.autosave" to the number of ticks you want between each save or set it to 0 to disable it completely and use a script or plugin to manage it instead.

    (Copied from http://forums.bukkit.org/threads/craftbukkit-1-4-2-r0-1-is-now-available.108490/)

    I hope this is solved in RB for 1.4.2.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 29, 2016
  8. Offline


    Try stopping your server and completely delete the bukkit.yml file.
    It will automatically generate a new file.
    It seems like the file that was generated when I installed 1.4.2 had some sort of issue.
    So far, after completely (100%) reinstalling craftbukkit, it seems to be completely stable.

    Well.. that's why they call it an "RB".
    They don't promote a build as a recommended build unless it meets a certain standard. ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 29, 2016
  9. Offline


    Hmm... My bukkit.yml was created in 1.3.2. I'll give it a try.

    Yet it's still here. :/

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 29, 2016
  10. Offline


    You have to completely stop the server,
    delete the file, then start the server.
    It should create a new bukkit.yml file.
    This new file will be exactly the same size, but should show that it was created today.
  11. Offline


    That's what I did.

    Right now, it's probably a plugin conflict, but then again all my plugins are from 1.2.5 or 1.3.2.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 29, 2016
  12. Offline


    It's crashed 3 times since my last message.
    It's definitely a bukkit error. :\
  13. Offline


    Is there anybody else with this error?
  14. Offline


    Well... I don't crash, but I have this annoying reload/roll back issue. I keep the inventory though. (I know where some diamonds are and I can dig them up and store them in my inv to stack more than there actually are xD). Still I can't fix it. I guess we will have to wait for the next update...
  15. Offline


    I have two servers running with almost identical plugins/builds/config but on different computers. One crashes suddenly like this and starts again, and the other doesn't. What host are you guys using? Maybe it's an issue with a wrapper.

    cb build #2452
  16. Offline


    People don't lose their inventory, just any changes that were made from the time the server started to when it crashed.

    My server is hosted with Branzone.com.
    I've never had an issue prior to this update, all the way back to 1.1.
    Besides, running the vanilla 1.4.2 minecraft server jar, I didn't have this problem.

    It's specifically a bukkit issue.
  17. Offline


    I'm trying to replicate it on my test server, but I can't. I thought maybe it was MCMyAdmin, as it crashes at the same time. I really don't know. I'll keep trying different things.

    This happens on our fragnet.net server.
  18. Offline


    The thing is, I literally uninstalled every single plugin (0 plugins).
    I completely deleted craftbukkit, the bukkit.yml and all associated files (even started a new world folder).

    The crashes still continued.
    I switched to vanilla 1.4.2 minecraft, the crashes stopped.
    Switched back to craftbukkit (100% clean install), crashes started shortly after.

    I'm going to file a ticket with my host and see if they can provide any additional information as to what's happening when it crashes. The server.log doesn't return any warnings/errors.
    I'll post back when they respond, they're usually very quick about addressing issues.

    Alright, I filed a ticket with my host.
    I imagine on the back-end of things, they should be able to see if there's any errors, server-side.
    I also asked them (the information isn't readily available) to let me know the various information about the server, and the version of java the server is running.

    Will post back when they respond. ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 29, 2016
  19. Offline


    Hm... there's a funny thing my host does. One of the only files they restrict you from editing directly is the server.properties file. (presumably because of the ip/port numbers) They instead make you go through a form. A couple hours ago I couldn't find spawn-protection in the form (though I may have missed it somehow). But checking now I see the spawn-protection line exists. Maybe it crashes when it doesn't have that line? Or maybe craftbukkit messed it up when it transferred that from bukkit.yml to server.properties. Either way the value was back to default, even though I know it transfers the value in my tests.

    I was crashing every 10-15 min. It's now been an hour and a half with no crash.
  20. Offline


    Well, it seems to fluctuate for me.
    Sometimes it's every five minutes, every ten, every fifteen, and once in a while it goes for as long as an hour.

    My host allows editing of server.properties, the spawn-protection line does exist in the file.
  21. Offline


    Well, it hasn't crashed since. Either it's random or something I changed affected it. I had also taken out a color code in server.properties motd. I generated a new bukkit.yml prior to that, but had crashed once after. When it was crashing, it'd even do so if I was the only person on the server and just sitting afk at spawn.

    I can't think of anything else potentially relevant.
  22. Offline


    I can't recall if this was happening prior to adding the color code to my MOTD.
    Added them in after I added support for them to my server list site.
    TnT - have you had any issues with your server crashing?

    Going to remove the color code from my MOTD and see if the issue persists.
  23. Offline


    No crashes for me. Have you tried without plugins?
  24. Offline


    I tried with a fresh install of craftbukkit without any plugins.
    Once I removed that color code, I haven't crashed since, no issues.
    Put all my plugins back in, still completely stable.
  25. Offline


    That's odd. What OS?

    Same code as mine in my MOTD?
  26. Offline


    Yes, same code/format.

    Windows Server 2008 R2
    8GB DDR3
    Java Version 1.7.0_07
  27. Offline


    Could be a Windows thing. :( Not sure, I run on CentOS.
    Darky1126 likes this.
  28. Offline


    I did the same, they responded with 'Check your plugins'.

    This problem wasn't here in 1.3.2, so it's probably and plugin/jar glitch.

    I managed to capture a screenshot of what happens when it restarts, and it says:

    [CONSOLE: Forcing save..]
    [CONSOLE: Save complete.]
    [CONSOLE: Stopping the server..]

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 29, 2016
  29. Offline


    can't see screenshot :(
  30. Offline


    So it was the color code? Odd. Our host uses a Windows 2008 server too. No problems since removing the color code here either. I'm glad I thought to remove that.
    KarlCullinane likes this.
Thread Status:
Not open for further replies.

Share This Page