I think Minecraft is alive and well, and is actually making a resurgence. Spigot and other servers have a thriving community, I think the only...
Just having a rant in hope it's heard by someone that can do something. Yes, I've messaged MrFlamegoat several times, and it was the reason the...
It's crazy how something once so magnificent has failed to provide so consistently. As a member of the community for 7 years, still supporting a...
Meaning you are trying to get a numeric value of something that may not exist before doing a arguments length validation.
My plugin sounds like what you need. https://dev.bukkit.org/projects/a5h73y For letter repetition I used the following regex:...
Yes you would ideally have a separate class to separate the events logically, for example I have PlayerListener and VehicleListener etc; But you...
Please use the Bukkit documentation, everything you need about the basics is there. (plugin).getConfig().getBoolean("message.enabled"); I'll let...
Your code could be refactored to a better standard. Use a switch statement on their permission to set a message variable to the matching message....
None of this needs to be static, if anything you're abusing static. What you could do is make this class reusable for multiple different types of...
Incredibly hard to fix a problem if you don't give us code to work with.
I've tidied your code up for you and applied the DRY principle. Try to avoid spaghetti code as it's ugly and hard to read. Btw I haven't tested...
If you want to do it in a single line just do dangleHolograms.put(p.getName(), HologramsAPI.createHologram(this, loc));
This looks like a Java knowledge problem, you're referring to the variable hologram which is undeclared at that point (unless you're using a...
Have you tried to debug your code? Print out the variables and stages to see where the code is getting to. Also, you are cancelling the inventory...
I disagree with this. I posted the syntax, relevant to what he asked; If someone asked what is "Hello" in French, you'd answer "Bonjour", not a...
Separate names with a comma.